Sparx Systems Forum
Enterprise Architect => Bugs and Issues => Topic started by: Andrew Warner on February 09, 2010, 04:10:39 pm
-
Hi all,
I'm trying to transfer a model into a sql server database. I've done it before on a local sql server db but now I'm having a go into a more secure environment.
EA 7.5.850
SQL Server 2008
MDAC 2.8
client: Win XP SP3
server: dunno
The error I get is
Microsoft OLE DB Provider for SQL Server [-2147217900]
Cannot find the object "t_package" because it does not exist or you do not have permissions.
Now, some other tables have rows transferred successfully. It pops the error message up twice then crashes. That is, EA shuts down abruptly.
The DB admin has run the database setup script from Sparx and the tables all appear to be there. I can add data manually via a connection in visual studio.
Anyone seen this before?
Andrew.
-
Do you have db_ddladmin permission? It's needed for data transfer.
-
Thanks Henk,
that did it.
BTW, is there are document describing the necessary permissions for the various stages of deployment to a dbms repository and subsequent use of the model?
I have to make a submission of sorts to our database admins. We're going to deploy our repositories into a tightly controlled production environment.
It would be good to be able to lock down the permissions as far as possible and to allocate such permissions as are required using windows resource groups.
Cheers,
Andrew.