Sparx Systems Forum

Enterprise Architect => Bugs and Issues => Topic started by: Modesto Vega on January 15, 2022, 04:07:17 am

Title: Link Element Features
Post by: Modesto Vega on January 15, 2022, 04:07:17 am
Just found a bug while linking element features in v15 (Build 1559). I can link element features as shown in this video https://www.youtube.com/watch?v=zB2fz5M4NbA&t=9s. But if change the Style from Custom to anything else and rearrange the line to make it look nicer, after performing these 2 operations the connector is no longer linking element features, some of the meta-data gets lost.
Title: Re: Link Element Features
Post by: Geert Bellekens on January 15, 2022, 04:22:28 am
Yeah, link to element features is only allowed in custom style; I've noticed that too.

Geert
Title: Re: Link Element Features
Post by: Modesto Vega on January 17, 2022, 10:08:18 pm
It ain't very customisable. You cannot do anything to that line.
Title: Re: Link Element Features
Post by: Geert Bellekens on January 17, 2022, 10:38:37 pm
It ain't very customisable. You cannot do anything to that line.
Sure you can. You can add as many corners as you like, and then drag those around (Ctrl-Q)

Geert
Title: Re: Link Element Features
Post by: Modesto Vega on January 17, 2022, 11:17:25 pm
It ain't very customisable. You cannot do anything to that line.
Sure you can. You can add as many corners as you like, and then drag those around (Ctrl-Q)

Geert
Thank you Geert, you are right. I cannot remember the last time I used Ctrl-Q to create corners.
Title: Re: Link Element Features
Post by: Paolo F Cantoni on January 18, 2022, 12:40:15 am
Yeah, link to element features is only allowed in custom style; I've noticed that too.

Geert
As Geert implies it has always been thus.  EA has some (to us mere mortals) anomalous restrictions on line drawing.  Not just link to element feature.


Paolo