Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - lynch80516

Pages: [1]
1
PCS General Board / WebEA with openid not working
« on: July 08, 2021, 03:06:17 pm »
I’m trying to configure webea to use openid sso via key cloak. I configured openid in the model and tested successfully with accessing the model using openid. When I try and access the model using webea I get an internal server error after selecting a model and then desktop. The login doesn’t redirect to keycloak. If I uncheck use openid is the users webea works fine with windows and local usernames and passwords. Any help would be greatly appreciated.

2
General Board / Document Generation issue with using & in the model
« on: March 02, 2020, 03:49:39 am »
I have element names and notes that contain & in the description link in a Acronym like TT&C, R&D, etc. However, when crating a document through a template it comes out as TT&ampC, R &amp D, etc. Is there a way to "escape" the & so it comes out correctly?

Thanks,

John

3
General Board / Organizing attributes as columns instead of rows
« on: February 29, 2020, 06:08:59 pm »
I have a number of elements and each element has a number of attributes and each attribute has a number of tagged values

I currently use a query that extracts the attributes and tagged values into tables where each attribute is a row in the table. This approach causes tables to be repeated with most of the same info

What I’d like to be able to do is use the tagged values properties as the table columns and have the values of the tags along with the attribute names as the rows.

Is this possible

John


4
General Board / SQL Query Issue
« on: February 29, 2020, 12:03:28 pm »
I have a query that I use to gather up attributes. The query is below.

select obj.Object_ID, obj.Name as Obj_Name, att.Name, att.Type, att. as 'Value'
, tv1.VALUE as Tag1, tv2.VALUE as Tag2
, att.Notes as Notes
From t_object obj, t_attribute att
left join t_attributetag tv1 on att.ID= tv1.ElementID
                     and tv1.Property = 'Unit of Measure'
left join t_attributetag tv2 on att.ID = tv2.ElementID
                     and tv2.Property = 'MsgColumn'
inner join t_object on  att.Object_ID = t_object.Object_ID   
where att.Object_ID = obj.Object_ID

This query works but searches the entire model, if I substitute #OBJECTID# for obj.Object_ID in the last line the query fails with Invalid Column #OBJECTID#

Has anyone seen this before and found a solution.

John

5
General Board / Audit Records - Deleting a single record.
« on: February 29, 2020, 09:39:12 am »
Does anyone have experience with deleting a single audit record. I have a model that has auditing enabled and I we found a problem with one of the elements text. We fixed the text, but the original text still is present in the audit record for that element.

What I would like to be able to do is delete that single audit record without completely eliminating all the record logs and starting over.

Any suggestions would be appreciated.

John

Pages: [1]