Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - skiwi

Pages: [1] 2 3 ... 23
1
Bugs and Issues / Applying legend autocolour to Hyperlink entities
« on: December 22, 2023, 09:39:32 am »
I appear to be able to apply fill, line colour, and line width to some types of hyperlink entities, e.g. those with external hyperlinks, but not those linking say to diagrams (which is weird in itself).


When I try to do this using legend autocolour based on tagged value tyles (defined in UML types) nothing happens
- bug or feature?

2
Bugs and Issues / Images with transparent background.
« on: December 13, 2023, 07:28:02 am »
When an image with a transparent background (e.g. .png)s is pasted from the clipboard to a diagram the transparent background displays as black. (16.1).
Does this happen for you?


The images is pasted as a boundary, so I tried setting the boundary to solid with a white background, to no effect.


The same thing happens when I paste as an image asset, changing the fill colour has no effect.


Any ideas?





3
Bugs and Issues / Diagram display of connector alias and name
« on: December 12, 2023, 10:59:03 am »
In diagrams properties  we have set
  • use alias if available
In preferences Diagram Behaviour we have set
  • Alias usage: alias and name
This means that enties display the (alias) and name,
but connectors, do not,
is this a bug or a feature?
How can I get both the connector (alias) AND name to display?


4
Bugs and Issues / SVG and WEBP as image asset
« on: December 08, 2023, 06:38:01 am »
When I drag a .svg, or .webp file to create an image asset the menu item is missing.
Is it possible that EA does not support SVG or .webp as a format?

5
Suggestions and Requests / Adjusting Diagram matrix rows and columns
« on: November 16, 2023, 11:55:29 am »
Noticing more things about EA 16.

In a diagram, when using Swimlanes and Matrix - as a matrix,
I like the fact that when I adjust the with of a column or height of a row the items contained move in their 'cell',
but I've got some questions:
  • is it possible to changed (reduce) the width of the Title Column?
  • is it possible to change (reduce) the height of the Title Row?
  • is it possible to drag an internal column or row line to change the width or height of only the two adjacent row or columns without changing the overall width or height of the matrix (.e.g. perhaps by shift drag)
I note that "hiding" Title 2 or Title 3 makes no difference to widths or heights.

I appreciate being able to change the background colour of a title cell
  • is it possible to set the background colour for non-title cell
  • is it possible to set the background colour for a full row or column
  • is it possible to set the background colour for the entire matrix?
I like being able to use the empty cell which in the intersection of the Title Row and Column as a heading, but
  • how do I get the Heading Title to wrap in the Heading cell? It writes over (if it is long enough) the column headings?
  • how do I get the Column Titles to wrap?
  • how do I get the Row Titles to wrap?


Why does the BB editor keep changing my text to size=2?

6
Bugs and Issues / EA 16 panes opening out of view ports
« on: November 14, 2023, 01:10:14 pm »
I've just started using EA 16 and I'm not sure if these are new issues, or I'm just re-noticing them.


Using two screens of different resolutions (2880x1920, 1920x1200) I find that sometime EA opens a pane, e.g. diagram properties, either completely off both screens, or only provides a glimpse of an edge that I cannot move or resize.


It doesn't seem to matter on which screen EA is, although with finessing the size and position of the main EA screen I can gain access to the errant pane.


Should I report this?

7
General Board / OCLS and Sharepoint
« on: September 27, 2023, 07:00:57 am »
Does Pro Cloud Server have any integrations with SharePoint?


I've had a squiz at, and search of, the user guide and nothing jumps out at me.




tia


Simon

8
General Board / Wanted: diagram reuse ideas
« on: July 25, 2023, 06:30:33 am »
I have a diagram for which there are different views (copies) produced by the use of an autofill legend. Separate tagged values (type=enum) for each view highlight the entities on the diagram.
Rather than duplicate (shallow copy) the same diagram multiple times, each with a different autofill legend, and incur the overhead of updating multiple copies whenever there is a change, is there a method of having a "clone" of the diagram (e.g. like a diagram frame) where the legend can be applied to the clone or diagram frame?
Or is there another way perhaps of achieving this?




9
General Board / Tagged value Type formats
« on: July 20, 2023, 01:55:22 pm »
I'm delving into some old area of the model.
In UML Types > Tagged Value Types


for a defined tag type I see
Type=List;
Values=Undefined,
Reference Architecture,
Strategic Architecture,
Segment Architecture,
Capability Architecture,
Solution Architecture


This type=list is not documented any more Predefined Structured Types | Enterprise Architect User Guide (sparxsystems.com)

Is "Type=List" a synonym for "Type=Enum "   
?

thanks

10
General Board / Pre setting default diagram properties
« on: July 06, 2023, 01:00:19 pm »
There has been some conversation over the years, for example
Changing default properties for a set of diagrams (sparxsystems.com)
Changing default diagram properties (sparxsystems.com)
Set default values for diagram properties (sparxsystems.com)


I wonder what the state of the art is now.
For example I would like all new diagrams to have preset
  • use alias if available
  • (unset) show additional parents)
  • (unset) show namespace
  • display element lock status
  • (unset) show element stereotypes (Elements)
  • (unset) stow stereotype labels (Connectors)

11
General Board / Collaboration chat and mail
« on: June 02, 2023, 08:18:35 am »

I've been reading the documentation (desperate eh!)

Collaboration Support in Diagrams | Enterprise Architect User Guide (sparxsystems.com)
because we want to trial mail and chat.


In the above its not obvious to me how to set up a user "For each Actor element, in the 'Alias' field of the Properties window, type the user ID of the user that the element represents." What is a user Id, in settings users I see Surname (aka Family name) and Firstname (aka Givenname) and Login, but no User ID.


Corollary question. How do I, in a chat, insert a reference (aka hyperlink) to a model element, diagram, or folder?

12
I've just updated our schema from some historic version to the latest and transferred the data (it wasn't seamless, and it was very slow, don't ask).


During the process I've released all the block on the model, and an recreating the group locks.


I noticed the very handy "Hide for other groups" tick box - which only appears in specific contexts.
Then I lost it again.
Finally I realised it only appears at the root level, not at the project level.


Have I missed something? This would be very handy to have at a project level.

13
Bugs and Issues / Auto color Legend Apply to element
« on: May 29, 2023, 07:19:49 am »
Using a Legend on a diagramm
With Apply auto color selected,
for a specific element
I can choose fill color; line color; line width; (but not text attributes such as colour, size, or font style)


Unexpectedly, the Apply Line, Apply Fill; Apply width do not apply to the specific element, they apply to all elements.


Am I missing something?


I want to apply fill colour only to some elements, and line colour only to other elements using the same Legend.

14
Bugs and Issues / Mini diagram images in generated documents
« on: December 22, 2022, 11:28:28 am »
I've just generated my first document using 16.1 (32 bit as it crashes less frequently) and an existing document.


I notice that the diagram images are all small, e.g. 50% the width of the text area on a page, rather than the 100% I expected.


Has anyone else seen this?
Is it a bug, or is there some configuration that I am missing?


thanks

15
PCS General Board / Web EA diagrams
« on: December 22, 2022, 11:12:03 am »
Diagrams shown in Web EA have a nice feature (in v4) that implements clickable areas so that clicking on an entity or boundary in the diagram shows the entity and the notes.


However clicking on a connector does not show the connector or its notes.
Before I submit a feature request has this been implemented in V5?, and would you support it


meri kirihimete

Pages: [1] 2 3 ... 23