Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Lalabox

Pages: [1]
1
Automation Interface, Add-Ins and Tools / Batch trigger EA Client
« on: June 01, 2022, 08:22:50 pm »
Hi @All
I know there are Issues running the EA Client "headless", but maybe someone knows a way around:

What I succeeded in:
- Create Task in Windows Task Planner with "Auto-User" context
- to trigger a batch script that will call
- a parametrised xy.exe that will
- call the ea.exe to perform spectial automated operations on some repository.
--> Task --> Batch --> xy.exe --> ea.exe --> Happyness!

This works perfectly, but ONLY when the Auto-User is (remotely) logged in.

What my problem is:
- When NOONE is logged in at the server, the task fails: the ea.exe won't run (Error 800401a).
- When ONE OTHER user (e.g. Admin-User) is logged in at the server, the task runs perfectly, but ea.exe does not run in the context of "Auto-User", but is owned by the currently logged in "Admin-User". Although, it was initially triggered by the Task-Planner from a task configured to run in the context of the "Auto-User"...

So:
- How can this even be happening?!?
- What can be done to get the ea.exe to a) run and b)in the context of the configured "Auto-User" when c) NOONE is logged in at all?

Hint: Someone told me this has to do with Windows "Services" triggering "Desktop", whatever thsi means, but I have not further details.

Ideas?

Regards
Christian

2
PCS Bugs and Issues / WebEA Curly Braces Error
« on: April 24, 2021, 07:16:50 am »
Hi,
I updated PCS to latest .65 and my WebEA produced lots of errors. I Run the WebEA in an XAMPP Apache and so I also updated that one to latest. It seems there ist a Problem with a new PHP Version not supporting curly braces any longer?

How can I fix this?

Redargs
Chris

Pages: [1]