Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - OpenIT Solutions

Pages: 1 2 3 [4] 5 6 ... 8
46
General Board / ole db connection string for auto failover?
« on: September 12, 2011, 09:58:38 pm »
Hi,

Does anyone know if the 'FailoverProvider=xxx' connection option can be made for an sql server (ole db connection) in EA ?

Thanks,

Jon.

47
General Board / 8.0 - diagrams blacked out ??
« on: September 08, 2011, 01:06:45 am »
HI All,

Has anyone seen this - i have a user that intermitently will open a diagram and find it blacked out in ea v8. This is a multi user env using sql server db ? Still happens if i get her to refresh/load the project...

Thoughts ?

Regards,

Jon.

48
General Board / Tagged Values
« on: September 07, 2011, 03:05:42 am »
Hi All,

Anyone know which table holds tagged value data...doesn't look like t_taggedvalue...?

Thanks,

Jon.

49
General Board / How does EA model BPMN under the hoods?
« on: August 24, 2011, 09:49:54 pm »
Hi,

I have a question about how EA models BPMN under the hoods. Specifically i need to understand how EA associates a BPMN Pool/Lane with a contained Activity/Process on a diagram? Does anyone know which tables/column in the EA database tell EA that the activity is contained within the pool on the diagram?

I ask a i need to write a report that lists all activities used by a role (ie a Lane in BPMN). The problem is that we have a libary (ie seperate directory in EA of all roles - a bunch of BPMN Lane elements/objects in a directory) of roles/Lanes that is reused across diagrams. Each diagram is in its own package (representing the process being modeled), which also contains the activities associated with the package.

The only relationship (used loosly here) that i can see is at the diagram level - as the Activity just sits in the Lane - its not a child or embeded element. There is also no formal relationship (connectors) between the two elements - so how does EA know that the Lane contains the activity on the diagram? I can see a ObjectType column in the DiagramObjects table and see the the Lane is dockable, so my assumption is that when a move a Lane (dockable element) on a diagram EA looks at the coordinates of all elements on the diagram and moves any that are within the dockable element - problem is that i can't search for this in SQL etc....so can't report upon it...any clues or suggestions?

Appreciate any help,

Jon.

50
General Board / rtf report equivalent to ctrl-u ?
« on: September 01, 2011, 06:48:38 pm »
Hi All,

Struggling with this one :- how would i create an rtf report that lists the name of all diagrams that each element appears in - the equivalent to ctrl-u in the project browser ?

Thanks,

Jon.

51
General Board / ActivityPartition / Pool / Lane - instances ?
« on: August 31, 2011, 07:11:29 pm »
Hi All,

For various reasons i need to create "as Instance Element (Object)" instead of "as Simple Link" when i drag and drop an ActivityPartition, Pool or Lane onto a diagram.

EA prompts me on the "Paste Element" dialogue to select "as Simple Link" or "as Instance Element (Object)" however it ignores my selection and always adds the element to the diagram "as Simple Link".

Is there a known work around ?

What tag in a uml profile tells EA to allow creation of the element "as Instance..." ? If i can figure this out ill be able to create a profile for myself that fixes the issue...thoughts?

Thanks,

Jon.

52
General Board / Merging Elements
« on: August 24, 2011, 10:59:15 pm »
Hi,

Is there an automated way to merge two or more elements (in different packages) into a single new element. My users have created duplicates of elements in various packages and i now need to merge them into a single new element....would be nice to have a tool / feature to do this in EA - but i can't find one. Any external tools/Add-ins provide this capability?

Regards,

Jon.

53
General Board / OLE DB error when connecting to SQL Server
« on: August 25, 2011, 08:35:38 pm »
Hi All,

I have a user that is getting an OLE DB connection error when we try to connect to an SQL Server database. The connection test is fine. Does anyone know how to trace/debug OLE DB connections? Can EA be run in a debug mode where details of errors are output to a log file?

Thanks,

Jon.

54
General Board / rtf document created by tag ?
« on: August 30, 2011, 09:37:21 pm »
Hi,

Does anyone know if there is a way to automatically add the details of the EA user that generates an rtf document in EA - is there a field that can be added ?

Thanks,

Jon.

55
General Board / Customising Model Validations
« on: August 17, 2011, 01:57:10 am »
Hi,

Anyone know if its possible to extend/customise model validations - specifically i need to run validations against BPMN diagrams but the built in BPEL validation is a little to strict. Also is there an easy way to include the output in an rtf report ?

Thanks,


Jon.

56
General Board / How to change the type of an element?
« on: August 11, 2011, 07:27:26 pm »
Hi All,

Is there an easy way (other than sql) to change all instances of the use of a given "Stereotype" to another?

Some of our users have used the wrong stereotype in the model.

Thanks,

Jon Ridgway.

57
General Board / Modelling transition plans...
« on: July 15, 2011, 01:47:02 am »
Hi,

Is there a recommended way to model transition plans in EA. Ie model current state architecture, target/future state and critically the transitional steps/major mile stones that get you their?

I would like to be able to use EA to select a point in time and run reports that highlight the difference between the current state architecture and the architecture at that point in time.

I could use baselines, but am i right in thinking that in a shared model, all users have to work on a baseline once selected (as the model is shared) ? Could you use source control branching features ? Can users work against multiple branches (each representing a point in time) - if so how would you report on differences between branches ?

Hope this make sense, i'm sure its a common question - but i couldn't find any advice on this forum....

Regards,

Jon.
  

58
General Board / UML Profile XSD
« on: April 01, 2011, 03:28:10 am »
Hi,

I'm putting an UML Profile together and wondering if there is an XSD that list allowed values?

Thanks,

Jon.

59
Bugs and Issues / Error 1316 when installing CloudService
« on: May 09, 2015, 02:27:37 am »
Hi,

I get error 1316 the specified account already exists - when trying to install CloudService. I've checked and I don't already have CloudService installed....

Any ideas ??

Regards,


Jon.

60
Bugs and Issues / BPMN Lane resizes when zooming in !
« on: July 30, 2013, 09:34:21 pm »
Hi,

We have a major issue with BPMN lanes re-sizing. Lay three lanes out next to each other (with their borders touching). Add a long name to each lane (so it spans two lines on the lanes header). Then pan in and out, eventually Sparx will take it upon itself to re-size the lane so that they now overlap ! Most painfully of all Sparx will also then adjust any Sequence Flows - so that all the carfull alignment you might have added is shot !

This is a new *feature* in v10 - has anyone else come across it ? Can anyone suggest a fix - other than rolling back to v9 until Sparx fix ?

Regards,


Jon.

Pages: 1 2 3 [4] 5 6 ... 8