Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - OpenIT Solutions

Pages: 1 ... 5 6 [7] 8
91
Hi,

I've got a vbscript in Sparx that creates an element. I then want to open its properties dialog so the user can populate some tagged values...Can this be done via scripting ? If so how ?

Thanks,

Jon.

92
Hi,

Is it possible to change the orientation of text when using a shapescript. I want to write a shapescript for Lanes/Pools in BPMN that will replace the name if its blank with the content of the participantRef tagged value. All works fine in the script, but i can't figure out how to make the text vertical when the lane/pool is horizontal - any clues ?

93
Hi,

I can see its possible to create a fragment that's source is an SQL query. If i add the fragment within an Element section within an RTF template is it possible to access the associated Element ID within the SQL query ? Is there some sort of tag like #Branch# that can be used to access the element id, ie somthing like #ELEMENT_ID# that i can add to my sql where clause ?

Regards,

Jon.

94
Hi,

I'm sure this has been asked before (i suspect by myself). But my search hasn't turned up a result.

Using the RTF Report Generator in 9.3 (can't upgrade for fragments in v10 due to bugs in v10) is it possible to have a title page and intro section based on the selected package. Then to have all other sections repeat for each child package.

It looks like the RTF Report Generator wants to apply the "package" section to all "childpackages", ie the childpackages will be presented as the current/top level package. Any way around this ? Any guide/notes etc anywhere - this seems like such an obvious requirement. Can it be acheived without ModelDocuments ?

Does anyone know if eaDocX supports this capability ?

Appreciate any pointers,

Regards,

Jon.

95
Automation Interface, Add-Ins and Tools / RunModelSearch
« on: February 13, 2013, 03:56:19 am »
Hi,

Is it possible to use RunModelSearch from the automation interface to run a model search and send the result to a file ?

It looks from the docs that output will always go to the Model Search screen ?

Thanks,

Jon.

96
Hi,

I've got a Collection of Elements by running the repository.GetElementsByQuery. This works fine i have a collection with the element i want in it.

I then try to invoke Collection.Delete or DeleteAt - both give me an "internal application exception". So how do i delete an Element ?

Does delete not work against a collection retreived via a query ?

Any ideas ? Is there a common/known reasons for this error when deleting ?

Appreciate any help,

Regards,

Jon.

97
Hi,

Is there a way via the automation interface to Add Related Elements to a diagram ? I'd then want to apply a Layout, again is there method to apply a layout ?

Regards,

Jon.

98
Hi,

Really hoped this had been finally solved. I'm using 9.31 and i'm facing the age old problem of a repeating header on a table that i don't want. Followed all the normal guidelines by can't seem to solve...see segment of template below...i'm guessing it may have something to do with the fact that i'm only including the connector target element in the table ???

connector >
target >
element >
....the table...2 by 2 with header row (set to header)
< element
<target
< connector


? Any ideas - known bug (still?)

Regards,

Jon.

99
Hi,

Has anyone else noticed a marked performance difference using the Java API's Collection.GetByName as opposed to Iterating through the Collection. I want to do the latter as i want to compare Alias not Name fields. However the interator approach appears to run an order of magnitude slower (5 mins to update 2000 elements usign GetByName - over an hour using an iterator).

Any advice appreciated....

Regards,

Jon.

100
Hi,

I've posted and had a reply to this before - but as the search on this forum doesn't seem to work (?) i need to respost.

I'm struggling with base 64 en/de code of the shapescript section of an mdg technology XML file. I suspect its because i'm using Windows...when i select the base64 encoded text in the xml file, copy to a seperate (new file) tab in notepad++ and select decode base 64 - i'm given some binary output, i save this to temp.zip. However when i try to open the zip it fails with an unexpected end of archive message...Any ideas what i'm doing wrong ???

101
Automation Interface, Add-Ins and Tools / Web based reporting ?
« on: August 08, 2012, 08:36:04 pm »
Hi,

Has anyone seen/created a web based reporting option that can be integrated with the generated html. My users would like the ability to select a diagram/package on the generated html and select/click a Report option which would list RTF report (templates defined in Sparx) that they can select to generate. I appreciate that the html generated is not server side, but i'm has anyone looked at this ? Any products ? Or any pointers if we wanted to approach this ourselves.

Question for Sparx  - is this capability slated for any future release (don't want to invest time/money building - if its on the cards)....

Regards,

Jon.

102
Automation Interface, Add-Ins and Tools / Shape scripts
« on: August 01, 2012, 12:49:02 am »
Hi,

is it possible to determine if an element has a specific relationship in a shape script ?

Thanks,

Jon.

103
Automation Interface, Add-Ins and Tools / quick link in excel
« on: June 19, 2012, 07:38:10 pm »
Hi,

Anyone tried copying a quick link in a supplied mdg file such as the bpmn mdg into a seperate csv file for editing in Excel ?

When i open in Excel its treated as one record, ie all on one row. The record separator (&#xa;) seems to be ignored.

Any suggestions on a fix so i can edit the quick link easily in Excel ?

Regards,


Jon.

104
Hi,

Anyone had experiance / tips for using the VB automation interface in a Citrix environment - the issue i'm seeing is that the EA.TLB is not registered and as EA.EXE is not physically installed on the citrix desktop i can't register it.

Sparx is started from my Windows "Remote Desktop Connection" using a command like this;

"C:\Program Files (x86)\Microsoft Application Virtualization Client\sfttray.exe" /launch "Enterprise Architect 9.0.0.908"

Any ideas ??

Regards,

Jon.

105
Automation Interface, Add-Ins and Tools / Quicklinker
« on: May 01, 2012, 10:17:51 pm »
Hi,

I want to add the built in "BusinessRule" to the BPMN 2.0 quicklinker so my users can form a dependancy between an Activity and a BusinessRule. I added the following to the quicklinker in my MDG (an extension of the standard bpmn2.0) xml file...

Activity,Activity,BusinessRule,BusinessRule,BPMN2.0::Business Process;BPMN2.0::Choreography;BPMN2.0::Collaboration;BPMN2.0::Conversation;BPMN2.0::BPEL;,,,Dependancy,,to,,,TRUE,TRUE,TRUE,TRUE,Common,0,,,TRUE,,&#xA;&#xA;

This quicklinker still works - but it doesn't provide a link to a BusinessRule as i'd expect...any ideas why ? Could it be something to do with the "BusinessRule" being a type that is not defined in the same mdg file as the quicklinker in question ? In which case is there a way around ?

Regards,

Jon.

Pages: 1 ... 5 6 [7] 8