Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - m2i7c9k

Pages: 1 2 3 [4]
46
Technically I don't know. On my private notebook, my add-in works well.
But I have a local account, and in the company, I have a domain user account, and EA is installed from
active directory group.

I thought that is maybe a problem? So I reinstalled my EA from local HDD and hoped that replace some references?
No idea how it makes it words :/

47
Hi Guys,

I have word 2016 add-in (VB2017) and it works on a local account (win10pro), but on the user with domain it shows error:

The exception thrown: 'System. Exception' in Microsoft.VisualBasic.dll
Cannot create an ActiveX component.


Imports EA

Module Module1
    Sub Main()
        Try
            Dim vRep As EA.Repository
            Dim vApp As EA.App = GetObject(, "EA.App")
            vRep = vApp.Repository
            Debug.Print(vRep.ConnectionString)
        Catch ex As Exception
            Debug.Print(ex.Message)
        End Try
    End Sub

So, it is a domain problem, or something different?

Thanx 4 all advice.

Mick

48
Dear Greet,

Yes, you did! My appology, I was blind :)
Once again thank you too.

Mick

49
For .NET projects you should be referencing Interop.EA.dll, not EA.tlb.

Thanx 4 Sprax support from Aaron Bell.

50
Have you tried first removing it and then reselecting it? = Yes.
In a C# project  = Same :/

I've only used VBA (from within Word or Excel) and C# recently... Yes I know, I learn from your VBA code, and the other posts here,
and from EA books...

And I have working Add-In based on Visual Studio 2018 [VB] + EA 12.1.1230, and it works fine but 13.5 and also BEAT 14 not working :/

anyway, thank U 4 your time

51
Yes, I did. Without any effect. [My project >> Open >> Compile >> Target CPU:x86] if is it that?

Under References is: <The system can not find the reference specified>
It's a little confusing because I found EA.tlb and browse it. And I seeing it in Solution Explorer
with little yellow examination symbol.


52
Hi Greet,

here are warnings:

Warning   #1
IDE0006   
Error encountered while loading the project. Some project features, such as full solution analysis
for the failed project and projects that depend on it, have been disabled.   
WordAddIn_EA13      1   Active


Warning   #2   
The referenced component 'EA' could not be found.   
WordAddIn_EA13         


Warning   #3   
Cannot find wrapper assembly for type library "EA".
Verify that (1) the COM component is registered correctly and (2) your target platform is the same as the bitness of the COM component.
For example, if the COM component is 32-bit, your target platform must not be 64-bit.   
WordAddIn_EA13   


I deregistered /registered EA.EXE


Thanx a lot 4 help :)

Mick

53
Hi Guys!

I am trying do the same thing as  "Access Sparx Ea from Visual Basic" by Robert Glover Jr but with EA 13.5.
I made it with EA 12.1.1230, but with 13.5 I don't.

https://uloz.to/!OEkAqM6Von7X/sparx13-4-errorvs2017-png

I am trying to create Word 2016 Add-In for importing diagram element and update them. With EA 12.1 it works perfectly :)

Thanx for advice.

Mick



Pages: 1 2 3 [4]