Here are the scenarios that could lead to this error and steps to handle it:
EA database on Microsoft SQL server:Is the
Data Type ntext rather than
nvarchar in the attribute table? (Refer below screenshot).

If it's
ntext, you need to upgrade the schema to the latest version and this issue should be resolved.
We have two options to resolve this issue.
Option #1:
- Take a backup of the EA repository without fail
- Visit this link and download the database schema under Updating earlier DBMS schemas section. Ensure to choose the right schema!
- Run the upgrade schema
- Do an integrity check
- Check if you are able to access this model using EA and Prolaborate without any issues
Option #2:
- Create an empty database
- Visit this link and download the database schema under Enterprise Architect Schema Creation Scripts section. Ensure to choose the right schema
- Run the latest DB schema
- Do a project transfer from existing DB to this one (EA should be handling all the conversions smoothly)
- Configure this DB in PCS and Prolaborate. Check if everything is working fine
EA Database on PostgreSQL serverRun this query on each of your EA databases:
create extension hstore EA database on Firebird serverIt will not work in Prolaborate as that database server is not supported yet.
You can host your EA models on a
supported database server.
No elements present in the selected packgesEnsure there are indeed objects available inside the packages that you have selected on the left.