Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - qwerty

Pages: [1] 2 3 ... 13
1
Bugs and Issues / DAO.Recordset [3159] / Not a valid bookmark.
« on: December 05, 2018, 09:57:24 pm »
Anyone came across this during exporting a diagram to a file?

Yes, I ran PI check. It gives me two "invalid link geometry" messages: Missing Connector and Diagram. Those will not go away even after multiple PI checks. Notably this diagram has a connector to a connector (though I think it once exported without issues). Most likely it's just one of those bugs that never will get fixed. But if someone has an idea...

q.

2
Bugs and Issues / Unsafe form when searching Help
« on: November 15, 2018, 11:39:25 pm »
When I type text in the magnifying glass field (e.g. here) and press enter my browser (Safari under OS X as well as Chrome under Windoze) tells me that I'm using a non-safe form and wether I want to proceed. This can't be intended behavior, can it?

q.

3
General Board / RefGUID for diagrams
« on: November 15, 2018, 11:32:43 pm »
I guess it's simply not possible :-X but is there a trick to have RefGUIDs that are limited to diagrams so a tagged value can reference a diagram?

q.

4
Bugs and Issues / Project Menu lost
« on: June 20, 2018, 08:22:17 pm »
I'm currently playing around with using EA over wine which works ok. However, I had an issue with the main menu which hovered to a separate window and somehow the Project menu was dragged out of it. I immediately re-installed EA12.1 (yes, I still use it) but the menu is still lost. I assume I have to clear the registry and/or the appdata for EA (comes to mind while typing this). Probably that will solve the issue, but is there a way to recover a lost menu item the "normal way"?

q.

5
Uml Process / Creating deployment
« on: June 08, 2018, 09:56:20 pm »
On p. 654 of the UML 2.5 specs (fig. 19.7) there's a <<deployment spec>> attached (like an association class) to a deployment connector. How can this be created in EA?

q.

6
General Board / The forum has been updated!
« on: May 12, 2018, 08:25:00 pm »
What does that mean? This message appears there for ages.

Further: Enterprise Architect 13.5 Released! Hmm. Aren't we already at 14?

q.

7
Bugs and Issues / Log file from XMI import
« on: April 13, 2018, 12:51:00 am »
There's a check mark "Write Log File" in the XMI import dialog. Fine! But where the hell is that log written???

q.

8
Suggestions and Requests / Connectors GUI
« on: March 19, 2018, 10:38:13 pm »
- When editing connectors I usually need the Roles tab open. It would be nice to have that done optionally/automatically.
- I'm using the IsOwned property regularly. Unfortunately it's placed light years away. If the properties window would be a bit larger, the "Advanced" tab could be open all time.
- Instead of True/False drop downs, would you please implement check boxes?? Generally???

Not asking for a style guide since I will not wait until hell freezes over.

q.

9
Bugs and Issues / Help Page tabs wrong
« on: March 16, 2018, 08:24:49 am »
Apparently the Tabs "Website" and "User Guide" seem to be swapped. While "Website" lists PDFs, "User Guide" lists web sites. It might well be connected to Sparxian logic, though.

q.

10
Uml Process / {query} constrained operations
« on: March 15, 2018, 02:43:40 am »
I had imported OMGs UML metamodel and just realized that most (all?) operations are suffixed with {query}. I don't see anything in EA that lets me set this. But going into the Post tab I find an OCL constrained which has written "Body" in the Type drop down. It's not possible to set that in EA manually. Could anyone from Sparx enlighten me what that is?

q.

P.S. The metamodel seem to have a property  isQuery : Boolean = false

11
Uml Process / Tagged values
« on: December 01, 2017, 09:47:55 pm »
I was pointed to this by a recent question in StackOverflow: tagged values do no longer exist in the UML 2.5 specs. The only real mention is on p. 205
Quote
When a Stereotype is applied to a model element, the values of the Properties have traditionally been referred to as tagged values.
That's it!

Now, what would that mean to EA? A concept that is used vastly in MDG does basically not exist in UML. How does that fit?

q.

P.S. Also, there is a constraint regarding stereotypes on p.278
Quote
/profile : Profile [1..1]{}
which EA obviously ignores.

12
General Board / Help with the help
« on: October 18, 2017, 09:09:32 pm »
Now that from time to time I have to work with V13 I have the need to consult the former help. Up to V12 the object model was reachable from a side bar directly. The new unhelpful layout (http://www.sparxsystems.com/enterprise_architect_user_guide/13.5/index/index.html) does not longer have the side bar. It even seems to miss a link to the object model. Or I can't find it. Where is it now. No longer needed???

q.

13
Bugs and Issues / hasProperty("concurrency")
« on: October 03, 2017, 11:18:45 pm »
According to the help this is listed under elements. I have not found any element with such a property. However, messages in SDs do have that property and the shape script reacts correctly. So I guess this is simply a faulty documentation here?

q.

14
Bugs and Issues / To rectangle or not to rectangle?
« on: September 28, 2017, 05:45:24 pm »
I'm trying to switch between MDG stereotyped rendering and rectangle notation. So what I did is this:

- Create a BPMN2.0/Business Process/Data Store which renders a nice disk cylinder shape
- Now from the context menu Appearance/Select Default Image
- Leave NONE in the menu (why the hell does the dialog pop up at all since it promises to set the "Default Image" and not the "Alternate Image" like the menu option below)
- The element renders rectangular

Now, that's nice and what I wanted to achieve. But how can I switch back to the MDG stereotype display again? It seems that I can't. First, I can't find any option for that. Second, when I delete the diagram objects and drag it once again from the browser I get the rectangle notation. Why? Because t_object.StyleEx now has DefalutImage=0; which forces the element to appear as rectangle each time you drag it onto a diagram.

Bug (not) reported (after Paolo).

q.

P.S. I tried sending a bug report but the form refused to give a Version dropdown entry while requiring an entry right there. Oh My God!

15
Suggestions and Requests / Role name vs. attribute
« on: July 07, 2017, 06:59:44 pm »
It has beed discussed formerly and Geert has a nice blog entry about the usage of role names and attributes. Recently I came upon this once again. If I have a diagram where a typed attribute is shown in the compartment of a class, this is a useful information. However, if this attribute is typed with some class and on another diagram I show both classes with an association, I want to show the role name at the end of the association instead of the attribute in the class' compartment. Having some (global) diagram option for this would really be nice.

One drawback with the current connector implementation with EA is that if you have multiple associations, there is no connection between the association and the attribute. EA offers the attributes from a drop down in the role fields. But once chosen they are no longer connected. That means one would have to set and maintain role names. Only in case there's just a single association, the role name could be derived automatically from the attributes.

q.

Pages: [1] 2 3 ... 13