Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - KP

Pages: 1 ... 3 4 [5] 6 7 ... 169
61
General Board / Re: 'Link' Connector type - did I imagine it ?
« on: May 09, 2018, 08:33:51 am »
Thanks @KP  - good to know how to (probably) make things backwards compatible. Could we have a note somewhere in the final V14 documentation to say that this has changed?

Nothing has changed. Except possibly the labels in the quicklinker (used to say "Link" or "Directed Link", now says "Association", but they're all Associations).

62
General Board / Re: Glossary plural terms
« on: May 08, 2018, 11:17:09 am »
So the Pareto Principle suggests that if 80% of plurals are formed by adding 's' to a noun then finding a simple solution to 's' plurals could be an easy win.

First attempt: If a word ends in 's' and it's in the glossary, show that glossary item. If a word ends in 's' and it isn't in the glossary, look for an entry with the 's' removed and show that glossary item. This only fails when there is a glossary term 'xyz' for which 'xyzs' is a real word that isn't the plural of 'xyz', and isn't itself a glossary term. Probably not too many of those, but enough to be annoying?

That only works for the sub-set of English that is Germanic in origin, is"regular", or has been completely Anglicized (verandah).  It's not going to work for the parts of English which are derived from Latin (fungus, vox) or Greek or any of the other loan languages the English empire gifted us with.

Yeah well don't blame me, blame that Pareto bloke  ;)

63
General Board / Re: Glossary plural terms
« on: May 07, 2018, 11:58:12 am »
So the Pareto Principle suggests that if 80% of plurals are formed by adding 's' to a noun then finding a simple solution to 's' plurals could be an easy win.

First attempt: If a word ends in 's' and it's in the glossary, show that glossary item. If a word ends in 's' and it isn't in the glossary, look for an entry with the 's' removed and show that glossary item. This only fails when there is a glossary term 'xyz' for which 'xyzs' is a real word that isn't the plural of 'xyz', and isn't itself a glossary term. Probably not too many of those, but enough to be annoying?

64
General Board / Re: 'Link' Connector type - did I imagine it ?
« on: May 07, 2018, 11:02:47 am »
I think it's always been the case that a Link is represented internally in EA as Connector_Type='Association'. If the two ends are instances then by duck typing it's an Association instance (aka Link).

65
If you save a profile from a diagram, the stereotype elements are processed in Z-order. If you save a profile from a package, the stereotype elements are processed in project browser order.

66
General Board / Re: export attributes of a class
« on: April 06, 2018, 04:41:17 pm »
On the diagram properties dialog, go to the Features page and set "Show Attribute Detail" to "Name Only". You may also want to switch off "Show Qualifiers and Visibility Indicators" on the same page.

67
Sorry Paolo I don't think you can be successful in this one

Did you mean to address Mats, not Paolo?

68
It is probably case-sensitive. Try "ArchiMate3::Business".

69
General Board / Re: Problem with hyperlinks to EA models
« on: March 20, 2018, 01:08:41 pm »
Now, if there was a way of opening a specific package or diagram in an external model via a hyperlink...

Have a look at the Save as Shortcut command. That allows you to choose diagrams to open on launching the shortcut.

70
General Board / Re: Custom Tag Search
« on: March 14, 2018, 12:23:09 pm »
I suspect what's happened is that you have also selected a package or branch to limit the search, so EA tries to add 'AND t_object.Package_ID IN (...)' to the where clause but it doesn't work because you have aliased t_object. Try re-writing your query without the table aliases.

71
Bugs and Issues / Re: v14 Beta: Dialogs losing file references
« on: March 09, 2018, 02:32:48 pm »
Is it the old "nothing is true till you save the diagram" problem?
Yes

72
Bugs and Issues / Re: v14 Beta: Dialogs losing file references
« on: March 09, 2018, 02:17:14 pm »
In v13.5 and before the dialogs remembered their last values so one would just "Hit Return".  The Save as Profile... Dialog is particularly bad!
In 13.5 on the Save as Profile dialog, just hitting return was extremely prone to overwriting the wrong file because it would put up the same file name as the previous time, even when you were saving a different profile. The dialog now remembers its settings per diagram and per package. Save one diagram, then save a different diagram and you won't overwrite the first. The dialog also remembers things like whether the Color and Appearance checkbox needs to be ticked.

Quote
I've already overwritten the wrong file once!
Then you presumably have two diagrams both writing to the same file.

Quote
Not to mention the added keystrokes to set up the file reference each time!
It's not each time, it's first time only.

You can of course write a build script. See the commands Repository.SavePackageAsUMLProfile, Repository.SaveDiagramAsUMLProfile, and Repository.GenerateMDGTechnology

73
Bugs and Issues / Re: v14 Beta: Advanced>Save as Profile... Missing
« on: March 08, 2018, 02:51:23 pm »
ribbon | Design | Diagram | Edit | Advanced | Save as Profile

74
General Board / Re: BPMN: Invalid Target for the Message flow.
« on: March 08, 2018, 02:23:50 pm »
Is the target an Intermediate Event? I get the same message as you if the target is either a Start Event or an End Event.

75
Bugs and Issues / Re: v14 BETA: Docked windows tabs icons missing
« on: March 08, 2018, 09:01:15 am »
ribbon | Start | View | Preferences | Window Behavior | Show Tab icons

Pages: 1 ... 3 4 [5] 6 7 ... 169