Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - PeterHeintz

Pages: 1 ... 35 36 [37] 38 39 ... 50
541
Bugs and Issues / Re: Setting _lineStyle has no effect
« on: June 08, 2016, 04:52:39 pm »
This makes me crazy!
Now I removed all stuff from the stereotype and I used again the profile helper to get this:
Code: [Select]
<Stereotype name="FTA Connector" metatype="FTA Connector" notes="" cx="90" cy="70" bgcolor="-1" fontcolor="-1" bordercolor="-1" borderwidth="-1" hideicon="0" strictness="profile">
<AppliesTo>
<Apply type="Association">
<Property name="_lineStyle" value="treeV"/>
<Property name="_SourceNavigability" value="Navigable"/>
<Property name="_TargetNavigability" value="Non-Navigable"/>
<Property name="compositionKind" value="none"/>
<Property name="direction" value="Source -&gt; Destination"/>
</Apply>
</AppliesTo>
</Stereotype>
What leads to linestyle Orthogonal - Square and SourceNavigability = Non-Navigable and TargetNavigability = Navigable.
Changing the Navigability types in the configuration seem to have no effect at all.
So it is just what I had before.
The features that should work seem to do not work at all, and the features that should not be there (Stereotype-Tags) somehow works with side effects.

542
General Board / Re: Experience with model validation?!
« on: June 07, 2016, 10:09:21 pm »
I try to rephrase this.
Is anyone using the model validation with own written non-primitive validation rules?
If so, does it work without problems?

543
General Board / V13 Packages in Kanban diagrams
« on: June 07, 2016, 10:03:41 pm »
I used in V12.1 a Kanban diagram to show the status of packages.
In V12.1 the package was shown as just a rectangle but in V13 it is show as the typical package shape including package content.
This makes the diagram created in 12.1 quiet “corrupt” when looking on that in in V13.

What can I expect to see in the final V13?

544
Bugs and Issues / Re: Setting _lineStyle has no effect
« on: June 07, 2016, 09:36:06 pm »
This is my generated stereotype fragment:
Code: [Select]
<Stereotype name="FTA Connector" metatype="FTA Connector" notes="" cx="90" cy="70" bgcolor="-1" fontcolor="-1" bordercolor="-1" borderwidth="-1" hideicon="0" strictness="profile">
<AppliesTo>
<Apply type="Association">
<Property name="compositionKind" value="none"/>
<Property name="direction" value="Source -&gt; Destination"/>
</Apply>
</AppliesTo>
<TaggedValues>
<Tag name="_lineStyle" type="" description="" unit="" values="" default="treeV"/>
<Tag name="_SourceNavigability" type="" description="" unit="" values="" default="Navigable"/>
<Tag name="_TargetNavigability" type="" description="" unit="" values="" default="Unspecified"/>
</TaggedValues>
</Stereotype>

In my  profile I added the attributes _lineStyle,... to the FTA Connector what leads to the generated tags.

545
Bugs and Issues / Re: Setting _lineStyle has no effect
« on: June 07, 2016, 08:04:33 pm »
Now I realized the _lineStyle attribute is represented as a tag as expected/ as I was afraid?.
However now I cannot change the the line style with the context menu any more, only by changing the attribute value I can do that. :'(

546
Now I realized the _SourceNavigable and the _TargetNavigability attribute is represented as a tag as expected/I was afraid?.
I can even change the Navigability within the properties roles dialog, however now this settings are out of sync with the tags. :'(

547
Ok!
Setting the attribute on the stereotype rather than on the meta class works.

I will issue a bug because neither user guide not profile helper does what is implemented at the end.

548
Bugs and Issues / Re: Setting _lineStyle has no effect
« on: June 07, 2016, 06:09:48 pm »
Ok!
Setting the attribute on the stereotype rather than on the meta class works.

I will issue a bug because neither user guide not profile helper does what is implemented at the end.

549
General Board / Re: SysML allocated note
« on: June 07, 2016, 05:52:24 pm »
I have not used that feature yet, but I am interested in your investigation results.
SysML in EA is sometimes mystic. ::)

550
General Board / Re: SysML action pin info on diagrams
« on: June 07, 2016, 05:47:56 pm »
Yes that is as it is.  :'( :'(
I remember a post also raising the action pin direction information issue and I would also very much appreciate to have EA showing the direction as done for ports.

551
As I remember yes.
But I did not find any response from Sparx in my mailbox.
So I will post it again.

552
On meta class “Association" I set _SourceNavigable to "Navigable" and _TargetNavigability  to "Unspecified" but when using my stereotype extending the meta class _SourceNavigable is set to "Non-Navigable" and _TargetNavigability  is set to to "Navigable".

553
Bugs and Issues / Setting _lineStyle has no effect
« on: June 06, 2016, 07:39:07 pm »
On meta class “Association I set _lineStype to treeV but when using my stereotype extending the meta class the line style Orthogonal-Square is used instead.

554
General Board / Re: An element several times on a diagram?
« on: June 06, 2016, 06:49:37 pm »
Hello Paulo,
I appreciate those discussions, sharing opinions, agreements and disagreements very much.
According to your definition I have not tree and probably even not a lattice as well.

This is because I do not have a parent child relation (at least from my perspective), it is basically boolean algebra connection events to logical gate (and, or,...).

In some other thread I read something like “Any model is wrong but some are useful” what fits very much to my mind set. According that, we could say on a very dogmatic way, all of us are lying.
So for instance what the project browser shows of EA is wrong as well, but useful.

For me a diagram arranging elements in a tree style way even if the elements do not have a tree relation, is ok as long as it is useful instead of confusing.

I decided to arrange the elements tree style but allowing cross branch connections is the way I intent to go (only one element link per diagram).

555
Well, I did neither use BPMN not Archimate ut to now.
But I assume that you will find all this relations as well, but maybe not with the right wording of your links.
Just figure it out.

Pages: 1 ... 35 36 [37] 38 39 ... 50