Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - skiwi

Pages: 1 ... 17 18 [19] 20
271
Bugs and Issues / Notes paste does not work as expected.
« on: November 06, 2009, 10:06:13 am »
I copy something from the clipboard into the notes field.
Viz


After it looks good,
but next time the field is opened no formatting is preserved (and some html appears). Ahem



Is this just an 850 problem?

272
Bugs and Issues / Website documentation links
« on: November 02, 2009, 09:41:49 am »
On page http://www.sparxsystems.com/uml_tool_guide/reporting_in_enterprise_architect/rtfdocuments.html

there is a link as follows:

More Information
A tutorial on using the RTF Generator and creating RTF documentation is provided on the Sparx Systems website. Click on the following link:
http://www.sparxsystems.com/resources/whitepapers/

However despite its blue colour the link isn't clickable.


273
Bugs and Issues / RTF generated documents - style and layout changes
« on: October 30, 2009, 09:52:27 am »
Here's something that bugs me:
  • why does document generation add the style Auto:Left 0.38cm in a lot of places
  • why are all tables indented by 0.19cm?
  • It also appears that the before and after spacing of paragraphs is changed in some instances, why?
These are not the styles I have loaded in normal.rtf, WHY ARE THEY CHANGED?

Also, why does the RTF editor use the names heading 1, heading 2, etc instead of Heading 1, Heading 2, etc. A minor point, but pointing to inconsistencies.

These are issues when it comes to producing a quality document.

274
Bugs and Issues / RTF Editor and page headers and footers
« on: October 22, 2009, 06:49:03 am »
I have been struggling to determine where the page header and footer comes from.
That is

  • does it come from the Documentation package RTFTemplate
  • does it come from the first model document RTFTemplate
  • does it come from the current model document RTFTemplate?
  • does it come from the previous or current document artefact?

It seems that the page header and footer come from the Documentation package RTFTemplate.

If Documentation package RTFTemplate does not have a header or footer it seems that the header and footer comes from the first model document RTFTemplate that does have a header and footer (ignoring any document artefacts that are previously part of the document that have a header and footer.

My issue: this is neither clear or expected. Why are not document artefacts equivalent to model documents for participating in, and generating documents.
Neither does it seem documented clearly what the behaviour is or should be.

My request: document clearly the expected behaviour of header and footers.

Make all document parts equal.

275
Bugs and Issues / RTF Editor and fields
« on: October 22, 2009, 07:12:53 am »
I create a field { FILENAME } in an external document and import it so the file will correctly contain the file name after generation on printing.

After importing, saving, and generating the document I see {MERGEFIELD FIELNAME }.
This doesn't do the same thing at all.

My issue is: Why are things in the document changed under my feet.

My request:
  • Minimise the changes made to documents (eg fields, styles)
  • maximise the features of RTF supported (eg style options, table otpions)
  • enhance the round trip capability and of externally generated or modified RTF documents and document artefacts and documents templates
  • fix or improve the function of numbered styles across document artefacts and model documents (ie numbering does not continue)

276
Bugs and Issues / Enable upload of images directly to the Forums by
« on: September 23, 2009, 12:13:35 pm »
To make these forums more usable, and useful, please enable the upload of images.
If necessary this could perhaps be restricted to registered (paying) EA customers.

Please, anything to make describing problems and issues quicker and easier.

277
Bugs and Issues / Spell check then EA not responding
« on: September 23, 2009, 01:46:58 pm »
In recent 7.5 versions of EA is anyone else having an issue with the spell check (project or package) getting a long way into the check, then hanging (100% CPU on one core) and not responding to user input (eg Cancel), and having to be killed (I hate to think what this does to the repository)


278
Bugs and Issues / Autosave - feature request
« on: September 10, 2009, 01:58:43 pm »
Well I got caught out today,
I left some changes unsaved in EA and came back from my meeting to find my PC had rebooted.

I checked the forum and the help,
and it appears that autosave does not exist.

Well I thought (duh) that in the 21st century this would just happen
a bit like hot water and sliced bread really.


OK, so how about it, a feature that preserves ALL changes made (up to the last key stroke) and offers to restore them after a failure.

Pleease

279
Bugs and Issues / Search on website reverts to "Sparx systems"
« on: September 11, 2009, 06:46:05 am »
When using the website search (top right Search ... Go form) to search the EA user guide I find that the search always reverts to "Sparx Systems" on the subsequent pages.

It should be sticky, and stay set to "EA user guide" once I have selected it, until such time as I change it.

280
Bugs and Issues / RTF Template: after changes fields not substituted
« on: July 29, 2009, 07:53:11 am »
After some seemingly minor changes to my RTF template (where everything looks fine with the template)
I find that some substitutions do not occur during generation.
(I would have provided a copy and paste here, but the copy from the RTF editor does not paste to the browser or a text editor).

Please see the images below.
I'd appreciate any suggestions for how I can rectify this (and an explanation of what is wrong).

I'd upload the exported template if I could, but the Board Administrators have disallowed this possibility.

I also note that there is no undo when specifying or unspecifying a section, surely this is a mistake.
When unspecifying a section in the RTF editor not only do all the tags go, but so does all the customised content ! This is really frustrating.

The template is


The generated document is


281
Bugs and Issues / RTF: Import and Export
« on: July 28, 2009, 12:35:44 pm »
When a document template is exported and edited externally, then reimported, (and again)
table indents are changed from 0 to 0.19",
column widths are lost
table widths are lost.

It appears impossible to preserve table formatting across repeated import/export round trips.


282
Bugs and Issues / Usability: skin breaks readability
« on: July 24, 2009, 02:03:56 pm »


Using this skin means
  • the axis labels can't be read,
  • the close button has disappeared (it shows vaguely in the image, but on a screen its just not there).

when can we have the ability to upload images related to issues?

283
Bugs and Issues / Usability: Visual style name length
« on: June 25, 2009, 10:07:57 am »
I wanted to create a visual style for a diagam element.
Once I found the Format Tool toolbar I was able to proceed.

I have the following feedback

    [*]the maximum style name is 12 characters, it should be much longer than this
    [*]there is no "Rename style" menu item
    [*]it is too easy to change the default style
    [*]there appears to be no means of editing a style once it is created
    [*]from the menu item Element | Appearance the option 'apply style' should be available
    [/list]

    284
    Bugs and Issues / Usability: Tools | Manage .EAP File | Re
    « on: June 25, 2009, 08:13:37 am »
    EA disappeared on me (maybe I should run ADPlus to trap these, but thats not this post).

    I was advised to check the repository (file based, not database).

    So I open the .EAP file. then use the menu
    Tools | Manage .EAP File | Repair .EAP files ...

    A prompt to open a file appears.
    I think, OK so it want to save the repaired file elsewhere (not unreasonable).

    I give it a new name, but of course EA can't open the file. (obviously I don't know what I am doing)
    So I try again, and give EA the name of the file I want to repair, but it won't because it is open (because I have it open!)

    OK, so I close the project. Then go to the menu
    Tools | Manage .EAP File | Repair .EAP file ...
    but it is greyed out [highlight](bug alert) [/highlight]

    This is odd I think, why does EA behave like this?

    It turns out I have to open ANOTHER file, to give me access to the menu item, so I can repair a closed file (shades of Catch-22)

    Could I suggest that this menu item be available when NO project is open

    thanks

    Simon

    Does anyone else think that this is odd?

    285
    Bugs and Issues / Data model export to PowerDesigner
    « on: March 16, 2009, 07:50:48 am »
    I need to export a datamodel from EA to PowerDesigner and vice versa.

    I've searched the forums, and the EA help,
    but its not clear to me if this is possible.

    If it is possible I'd dearly like to know what the process is to achieve this

    tia

    Simon

    Pages: 1 ... 17 18 [19] 20