Author Topic: EA 15.2 Native XML Import requires credentials  (Read 2977 times)

mbabos

  • EA Novice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
EA 15.2 Native XML Import requires credentials
« on: August 04, 2021, 10:46:48 pm »
Hi everyone!

We created a XML export/backup of our main (cloud-based) project and I wanted to create a local copy of the project based on this backup, for testing some automation stuff.
So first of all I created an empty local project, performed the native XML import, and directly afterwards I can open the project as expected, content seems OK. Only after I reopen the project, EA requires login/password credentials.
I am not sure what to enter here, because I created the local project and it should not require any authorization. Does anyone know how to handle this, bug or feature? :) I tried the cloud login credentials, but that doesn't help...

Thanks in advance and kind regards,
Martin

qwerty

  • EA Guru
  • *****
  • Posts: 12730
  • Karma: +361/-295
  • I'm no guru at all
    • View Profile
Re: EA 15.2 Native XML Import requires credentials
« Reply #1 on: August 04, 2021, 11:17:52 pm »
Probably you have to turn off security in the transferred model.

q.

Sunshine

  • EA Practitioner
  • ***
  • Posts: 1179
  • Karma: +105/-10
  • Its the results that count
    • View Profile
Re: EA 15.2 Native XML Import requires credentials
« Reply #2 on: August 05, 2021, 11:09:34 am »
If its an eapx file then here is a Hack.
Open it in MS Access and open t_secpolicies and change the values to disable security.
Happy to help
:)

mbabos

  • EA Novice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: EA 15.2 Native XML Import requires credentials
« Reply #3 on: August 05, 2021, 09:35:13 pm »
I don't think security is enabled, because if I go to CONFIGURE -> Administer, it shows me the option to enable security. Unfortunately I don't have MS Access at the moment, to check it directly in the eapx...

mbabos

  • EA Novice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: EA 15.2 Native XML Import requires credentials
« Reply #4 on: August 05, 2021, 09:50:33 pm »
It was a good hint though  :) Instead of disabling security in the model after import, I changed the t_secpolicies.xml backup file accordingly, prior to import. Thanks guys!

qwerty

  • EA Guru
  • *****
  • Posts: 12730
  • Karma: +361/-295
  • I'm no guru at all
    • View Profile
Re: EA 15.2 Native XML Import requires credentials
« Reply #5 on: August 06, 2021, 06:56:37 am »
I don't think security is enabled, because if I go to CONFIGURE -> Administer, it shows me the option to enable security. Unfortunately I don't have MS Access at the moment, to check it directly in the eapx...
Well, this is Sparxian logic. It shows that same message when it's on or off. Sent a bug report many, many years ago. Never got fixed.

q.