Author Topic: Which PHP version is recommended for WebEA 4.x?  (Read 13336 times)

wivel

  • EA User
  • **
  • Posts: 129
  • Karma: +9/-1
  • Driven by Models
    • View Profile
Which PHP version is recommended for WebEA 4.x?
« on: October 22, 2021, 11:11:27 pm »
Hi

Think the subject says it all  :)

Henrik

skiwi

  • EA Practitioner
  • ***
  • Posts: 1976
  • Karma: +44/-82
    • View Profile
Re: Which PHP version is recommended for WebEA 4.x?
« Reply #1 on: October 27, 2021, 07:57:40 am »
I asked support about upgrading to PHP 8 on 2021-07-20 (from 7.4) and got the following response
Quote
[There have been issues with the latest PHP so I recommend you stay with the current one for the present.
Noting that PHP has active support for 7.4 until 28 Nov 2021   and security support until 28 Nov 2022.
Orthogonality rules
Using EA15.2 (1555) on Windows 10 Enterprise/64 bit. Repositories in SQLServer2019 & Access2003/JET4.0. WebEA on Pro Cloud Server 4.2.64

wivel

  • EA User
  • **
  • Posts: 129
  • Karma: +9/-1
  • Driven by Models
    • View Profile
Re: Which PHP version is recommended for WebEA 4.x?
« Reply #2 on: October 27, 2021, 11:30:59 pm »
Thanks for your reply. We had discussed upgrading to PHP 8, but will put in on hold for now.

Henrik