Author Topic: Invalid combination....  (Read 4407 times)

qwerty

  • EA Guru
  • *****
  • Posts: 13525
  • Karma: +395/-300
  • I'm no guru at all
    • View Profile
Invalid combination....
« on: March 05, 2022, 02:54:41 am »
Well, it's Friday and the frustration level high. Now I defined tons of meta-relationships and somehow I get the hang of it. Definition itself is a PITA. You need to draw lots of connectors in separate diagrams (else you could not possibly read anything in the normal metaclass definition diagrams). Setting the diagram to matrix is pointless since a) you can't read anything since all needed info is abbreviated or not shown and quite some connectors are not shown at all (another half baked thing Sparx got up with, yeah...). Now, the QL seems to show the relations I wanted it to show (at least after some short look). But when I select one of them EA croaks with that dreaded message (see title). What? It offers to create something and when it's going to work it tells me NO? What is that? Something to spoil my day? Well done then :-( Don't tell me I have to disable the Strict Connector option. Would you please fix that? Onve a year I wonder why I pay license fee.

I don't expect any nice answer. Weekend calls.

q.

Eve

  • EA Administrator
  • EA Guru
  • *****
  • Posts: 8018
  • Karma: +118/-20
    • View Profile
Re: Invalid combination....
« Reply #1 on: March 07, 2022, 08:46:47 am »
It's probably just as well you don't expect a nice answer. You haven't given anyone enough information to help.

I think you're talking about an error creating one of your own connectors, but I'm not even sure of that.

If you do want an answer, provide:
  • The definition of the connector you're trying to create
  • What elements you're trying to create it between
  • The build of EA

PS. I would not recommend turning off strict connectors except as a temporary workaround for a confirmed issue.

qwerty

  • EA Guru
  • *****
  • Posts: 13525
  • Karma: +395/-300
  • I'm no guru at all
    • View Profile
Re: Invalid combination....
« Reply #2 on: March 07, 2022, 07:22:27 pm »
Well, as I wrote it was under a high frustration level. I will come up with details asap...

q.

qwerty

  • EA Guru
  • *****
  • Posts: 13525
  • Karma: +395/-300
  • I'm no guru at all
    • View Profile
Re: Invalid combination....
« Reply #3 on: March 14, 2022, 10:51:46 pm »
As usual I could not reproduce the issue after the weekend. However, now I do have an example (something completely different...). My profile contains
Quote
      <Metamodel>
         <Metaclass name="stereotype" notes="">
            <stereotypedrelationships>
               <stereotypedrelationship stereotype="myProf::represent" constraint="NamedElement"/>
            </stereotypedrelationships>
         </Metaclass>
      </Metamodel>
and the QL shows the Represent connector when dragging from a stereotype towards a named element. But when I release the button t croaks with the Invalid combination. Why?? (Honestly I was astonished that I could create the stereotyped relationship from the profile-orphaned Stereotype!)

q.