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Time Aware Models
The Time Aware Modeling feature allows analysts to create incremental versions of their models by providing easy
access to tools that facilitate the migration of elements through multiple versions. It is now easy to see the evolution of a
model over different versions, and create new versions of model elements automatically without altering the underlying
structure of the 'As-Is' model.

Background
Models by definition are an abstraction of things that exist in the real world. Just as time is an important dimension in the
physical world, it is also an important concern with models that represent that world. These are some common situations
where time and the evolution of versions is important in modeling:
·

Architects use models to document the current state and then move on to the more challenging and rewarding task of
defining what the future state will look like, often in a series of transitions

·

When new customers are acquired, a Business Analyst is often challenged with describing how a base product
should be configured for these different customer groups, resulting in different versions of the same product

·

Business Strategists typically prescribe what a Capability model will look like for the organization of the future,
resulting in at least two versions of the Capability model

·

During mergers and acquisitions, Business Architects are tasked with describing the possible states of the enterprise
after the takeover is complete

·

Engineers are required to develop better or more efficient solutions to meet the challenges of the future, so define
newer and better versions of the solution

·

Testers need to be aware of different versions of a product when designing and running test cases

·

Infrastructure engineers have to define future environments in response to performance or security concerns,
creating multiple versions of servers, devices and even whole facilities

All of these situations require that time is incorporated into the models so that it can be reasoned and made explicit.
Enterprise Architect's Time Aware modeling facilities can be used in all these situations, to ensure that time is included
as a first class citizen in the models. Time is not measured or modeled in absolute or relative terms, but by representing
any number of future states or differences in the form of versions.

Introduction
Time Aware modeling is based on using tools to clone a Package structure (Packages and diagrams only) as a new
version, and then selectively over-riding parts of the old version with new elements and relationships using either the
'Clone as New Version' capability or simply adding new material to the model as required. This method allows a highly
selective and incremental revision or development of a model, whilst maintaining traceability to both earlier and later
development.
Time Aware modeling is not dependent on Version Control or Baseline functionality, but is an entirely separate
capability that helps analysts manage multiple versions or revisions of a model in a consistent and fully traceable
manner. Conceptually it is analogous to the branching and merging in a Version Control system but as stated it is a
separate and unrelated mechanism.

Benefits
·

Easily compare 'As-Is' and 'To-Be' models

·

Make changes to subsequent versions without altering the underlying structure of the 'As-Is' diagram

·

Get greater control over the evolution and traceability of your overall model
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Create Traceability diagrams that outline each stage of the elements' evolution

Time Aware Model
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Clone Structure as New Version
When using Time Aware modeling, you will typically want to create a new version of a group of elements that are
collected together in one or more Packages, and so will need to create a new version of a whole Package structure.
Creating a clone of your current model structure is a simple migration process driven by version number. The structure
migration process builds a clone of your current Package hierarchy, including diagrams, and updates the Packages and
diagrams with a user defined version number. You can also change the structure name, if necessary. All diagram
elements translated to the clone diagram are included as linked elements (references) to ensure their encapsulation is
maintained with the 'As-Is' model.
As the 'To-Be' model evolves, linked diagram elements from the previous version can be selected and automatically
cloned into the new Package structure as required. This ensures model assets continue to develop seamlessly between the
'As-Is' and the 'To-Be' model without crossing over.
The facility can operate on Model Packages, Views and lower-level Packages regardless of their location in the Project
Browser.

Access
Ribbon

Design > Package > Edit > Clone Structure as New Version

Context Menu

Project Browser | Right-click on Package | Clone Structure as New Version

Create new clone structure
Step

Action

1

On the 'Enter Name and Version' dialog, the 'Name' field defaults to the currently-selected Package name;
if necessary, overtype this with a new name.
Type in the version number for the ('To-Be') clone of the selected structure, and click on the OK button.
The 'Select Structure destination' browser displays.

2

Select the Package in the project under which to create the clone structure. The current location of the
structure is highlighted until you select the clone location.

3

Click on the OK button. The clone structure is inserted under the target Package, and the clone diagrams
are all opened within the Diagram View as separate tabs.

Example
Start with selecting the root of your 'As-Is' model structure.
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Select the 'Design > Package > Edit > Clone Structure as New Version' ribbon option.
(Alternatively, right-click on the Package and select the 'Clone Structure as New Version...' context menu option.)
Specify the name, version number and the target Package for the structure clone.
Finish with the new 'To-Be' model structure.

Notes
·

All Packages in the new structure will be updated with the newly entered version number

·

All diagrams in the new structure will be updated with the newly entered version number

·

Project Browser elements in the new structure are linked elements from the 'As-Is' source Package and retain their
'As-Is' version status

·

Note, Text and Boundary elements are cloned into the new version with the diagram

·

Object and Sequence elements are copied into the new structure as new elements with the new version number, and
with Trace connectors to the original version elements

·

On the 'Select Structure destination' dialog, you can either select an existing Package as the destination, or create a
new Package
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Clone Diagram as New Version
There will be circumstances when a modeler needs to clone a diagram on an ad-hoc basis. Even when the modeler has
used the 'Clone Package Structure' facility, a diagram might have subsequently been added to the original structure and
this diagram can then be cloned separately to ensure the two versions of the Package structure are kept synchronized.
Creating a clone of your current model diagram is a simple migration process driven by version number. The diagram
migration process builds a clone of your selected diagram and updates it with a user defined version number. All diagram
elements contained on the clone diagram are migrated as linked elements to ensure their encapsulation is maintained with
the 'As-Is' model.
As the new diagram version evolves, linked diagram elements can be selected and cloned into the new diagram's location
as required. This ensures model assets continue to develop seamlessly between the 'As-Is' and 'To-Be' models without
crossing over.
As you can have a sequence of cloned diagrams in separate Packages, it might not be apparent that a diagram is one of a
line of clones. You can check whether a diagram has clones using the 'Show Diagram Versions' dialog.

Access
Ribbon

Design > Diagram > Edit > Clone as New Version

Create new clone diagram
Step

Action

1

On the 'New version number' dialog, type in the version number for the ('To-Be') clone of the selected
diagram, and click on the OK button.
The 'Select Diagram destination' browser displays.

2

Browse for and select the destination ('To-Be') Package for the clone diagram, and click on the OK button.
The diagram is cloned to the destination Package, and automatically opened in the Diagram View.

Example
Select a diagram to clone.

Select the 'Design > Diagram > Edit > Clone as New Version' ribbon option.
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Specify the version number and the target location for the clone diagram. Review the clone diagram when it is
automatically opened.

Show Diagram Versions
When a diagram is cloned, a custom reference is added to the diagram (in the t_xref table). This custom reference
provides information on the clone, through the 'Show Diagram Version' dialog.
To display this dialog, right-click on the diagram in the Project Browser and select the 'Show Diagram Versions' option.

Where there is more than one clone in a sequence, the versions are listed with the most recent first and the original clone
last.
You can open either the clone diagram (the source) or the diagram it was cloned from (the target) by clicking on the
Open Source button or Open Target button.
You can also right-click on a diagram entry and select from there context menu options:
·

Open Source Diagram - display the clone diagram in the Diagram View

·

Open Target Diagram - display the cloned diagram in the Diagram View

·

Find Source Diagram - highlight the clone diagram in the Project Browser

·

Find Target Diagram - highlight the cloned diagram in the Project Browser

Notes
(c) Sparx Systems 2018
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·

Clone diagrams will be updated with the newly entered version number

·

Project Browser elements in the new structure are linked elements from the 'As-Is' Package source and retain their
'As-Is' version status

·

Note, Text and Boundary elements are cloned into the new version with the diagram

·

Object and Sequence elements are copied into the new version, with the new version number, and with Trace
connectors to the original version elements

·

You can either select an existing Package or create a new destination Package in the 'Select Diagram destination'
dialog
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Clone Element as New Version
Cloned elements are the core of the Time Aware modeling capability. When a clone is made, a new element is added to
the 'To-Be' model and a trace relationship is added that connects the new element back to its 'protege' in the 'As-Is'
model. This allows details to be added to the cloned element leaving the 'As-Is' element in its original state. Creating
clone elements helps maintain seamless development between the 'As-Is' and 'To-Be' model, ensuring changes are well
defined, encapsulated and traceable.
Creating a clone of the linked elements on a diagram is a simple migration process driven by version number. The
element migration process builds a clone of your selected element and updates it with a user defined version number. In
addition to duplicating their base version, the necessary relationships between the clone and the original are created to
ensure the logical consistency and traceability of the new model. When cloning an element as a new version, Enterprise
Architect intelligently determines where to route the new element's relationships to correctly reflect the intent of the new
model version.
Where a relationship exists to another model element in a previous version, the model is examined to see if there is a new
version of the target element first and, if so, that element is now used as the target of the relationship. If there is no
over-ride, the relationship is set to the existing element. This behavior is extremely useful when studying the impact of
making changes to elements in base versions that are expected to remain unchanged throughout multiple versions of a
model's lifecycle.

Access
On a 'To-Be' clone diagram containing an external element (an element held in a different Package) to be cloned, click on
the element.
Ribbon

Design > Element > Edit > Clone Element as New Version

Context Menu

On a diagram, right-click on element | Clone Element as New Version

Create a new clone element
Step

Action

1

On the 'New version number' dialog, the 'Enter Value' field defaults to the version number of the current
diagram as the version number to apply to the clone element. You would tend to use this number but, if
necessary, you can overtype it with a different one.

2

Click on the OK button. The external element becomes a clone in the diagram's parent Package, with the
specified version number.

Example
Select a linked element on the 'To-Be' diagram clone.
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Select the 'Design > Element > Edit > Clone Element as New Version' ribbon option.
Alternatively the option can be found in the diagram context menu.

Finish with the new 'To-Be' element.

Update linked diagram objects
When an element has been updated to the current version, update diagrams might still contain linked diagram object
references to the old version of that element. If you want to make one of these diagram objects the same version as the
updated element:
1.

Right-click on the object linked to the old version and

2.

Select the 'Update Element to Version '%s' option from the element context menu

This will update the old linked diagram object with the new version of the diagram object.

Notes
·

The clone element will be created in the same Package as the current diagram

·

When cloning an element, all parent and child elements will also be cloned to maintain element hierarchy

·

The 'Clone Element as New Version' menu option is not available for elements contained in the diagram's parent
Package

·

Package, Note, Text and Boundary diagram elements are excluded from this feature

·

The clone element will maintain relationship links with previous version elements
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·

A Trace relationship link is created between the clone and the source element

·

Use the 'Filter to Version' option in the diagram 'Properties' dialog to filter elements by version on the diagram
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Traceability
Time Aware models are powerful but it quickly become difficult to understand all the connections between new and
existing elements particularly over multiple versions. Enterprise Architect is a collaborative platform and excels at
creating visualizations of the relationships and traces between different parts of the model. There are a range of powerful
and compelling tools that can be used to visualize these relationships.

The Traceability Window
You can use the Traceability window to trace element relationships. Access the window using the 'Design > Impact >
Traceability' ribbon option.

Insert Related Elements
You can use the Insert Related Elements feature to create a Traceability diagram that outlines each stage of the element's
evolution.
Step

Action

1

Create a Custom diagram with the name 'Traceability'. (Use 'Technology Type': 'Extended' and 'Diagram
Type': 'Custom'.)

2

Drag the subject element from the Project Browser onto the diagram.

3

Right-click on the element in the diagram and select the 'Design > Element > Insert > Insert Related
Elements' ribbon option. The 'Insert Related Elements' dialog displays.
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On the dialog:
·

Select 'Trace' in the 'Connector types' panel

·

Set the 'Find Relationships to' depth level

·

Click on the Refresh button

In the list of results, select the checkbox against each required diagram element, and click on the OK
button. The elements are added to the diagram.

Example
Drag the required element onto the diagram.

Click on the element and select the 'Design > Element > Insert > Insert Related Elements' ribbon option, or right-click
and select the context menu option 'Insert Related Elements...'
Configure the 'Insert Related Element' dialog.
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Finish setting the diagram layout and property options, and click on the OK button.
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Relationships
The docked Relationships window is a powerful tool for viewing the relationships between 'As-Is' and 'To-Be' models.
Selecting the 'Source Version' and 'Target Version' report columns brings clarity of relationships.
In the Relationships window, right-click on a selected relationship to open the context menu; you can view properties,
find element usage and locate source and target elements.

Version Filtering
When working on a diagram containing elements from different versions of your model, you can easily select to filter out
elements not in the current version.
Step

Action
Right-click on the diagram background and select the 'Properties' option to display the diagram
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1

'Properties' dialog.

2

The 'Version' field displays the diagram version number; all elements having a version number different
from this will be grayed out.

3

Select the 'Filter to Version' checkbox to enable the diagram filter feature, and click on the OK button.

Filter Example
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