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File Based Projects

Enterprise Architect provides a convenient light-weight, low-barrier and portable file-based repository out-of-the-box,
which is ideal for modelers who want to start work immediately; with the file-based repository you can be modeling
within a few minutes. When a number of colleagues want to contribute to the models, the file can be moved to a
file-share and it is possible to work with this setup even when the model becomes quite large and the number of users
increases to ten or more. All editions of Enterprise Architect support this type of repository in the form of a .eap file in an
Access database, or a .feap file in a Firebird repository.

You can create your own repository from scratch, but a default repository (EABase.eap) is conveniently supplied, located
in the Enterprise Architect installation directory. The file acts as a template for creating new projects and can be copied
to give you a head start in creating a repository. You can tailor this repository to suit your organization or create your
own base repository. A File Based Repository can be easily transferred to a DBMS based repository using the Project
Transfer feature, allowing a project to be scaled up when the team increases in size or when organizational policy
dictates it.

File-based project tasks

Task Detail

Create .EAP Project Files Select one of:

 > New Project menu option·

'Local File | New Project' option on the 'Manage Projects' dialog, or·

'Create a new project' option on the Start Page·

All of these options display the 'New Project' dialog; select a directory and enter a
file name for your project (.eap under JET 3 or .eapx under JET 4).

Once the project has been saved, the Model Wizard displays, which makes a
selection of Model Patterns available; select the Model Patterns to use.

Enterprise Architect adds a model containing the selected Model Packages to the
Project Browser.

Create .FEAP Project Files As for a .eap/.eapx file, except that in the 'New Project' dialog, in the 'Save as Type'
field, click on the drop-down arrow and select the .feap file extension.

Enterprise Architect will check your input and display an error message if:

Your Firebird repository is not located on the local drive; a Firebird repository·
is not appropriate for a network shared project

The file path contains characters that are not in the system codepage·

Location of default
(EABase.eap) repository
template

The default installation directories, depending on which version you have installed,
are:

Registered version: C:\Program Files\Sparx Systems\EA·

Trial version: C:\Program Files\Sparx Systems\EA Trial·

Lite version: C:\Program Files\Sparx Systems\EA Lite·

A base project contains templates and reference data from which you can quickly
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develop your own project.

Note that in addition to deriving a new model from EABase.eap. it is also possible
to start a new project by copying an existing one. While it is possible to simply
'copy' the .EAP file at the file system level, this results in two identical models and
should only be used when that is the required behavior; for example, when
distributing a model to a client for verification. If you use the built in functions of
Enterprise Architect to create a new model based on an existing one, Enterprise
Architect will modify the unique identifiers (GUIDS) for all elements and related
constructs so that the new model is essentially unique, and not a simple copy of the
existing one.

Configure Project Having created your project, you can set a range of project parameters to define
defaults, tailor the project to particular coding languages, and ensure consistent
development and use of the project.

Create Custom Templates You can customize any Enterprise Architect project as a template project with
company standards, tutorials, frameworks and any other common piece of modeling
already in-built; with careful planning you can save yourself many hours of work at
project start-up.

Best Practices for File Based Repositories

Single User Simple file based repositories (.eap and .feap files) are best suited to single user
development with the model file placed on the modelers local drive. This is fast,
very efficient and provides a powerful means of getting started in modeling a
particular solution. Many models will start out as single user repositories and only
later be migrated into a DBMS or Cloud based scenario for larger team access. If
you need to quickly start work on a project and do some exploratory work, or you
are working alone as a consultant, the .eap or .feap file format is ideal.

Small Workgroup With all versions of Enterprise Architect it is possible to share a .eap file at the
network file level. This is really only a suitable solution for small workgroups (up
to, say, five members) who are collaborating on a shared model. This solution is
very much at the mercy of the quality of the network connection and could be less
than ideal if collaborating users increase in number and/or the model grows very
large. As Enterprise Architect on the user's machine is still running all the queries
and performing all database operations on a network file, a slow network will result
in less than ideal performance. As team size and model size increases it is best to
upsize to either a DBMS or Cloud-based architecture.

In Conjunction with
Version Control

One additional scenario in which file based repositories can be used to great effect
is with a Version Control system such as SVN. If the SVN system holds the master
content, then individual developers/modelers can check out the material of interest
to them into a local .eap or .feap file. When they have made their changes they can
migrate their work back into the shared master. This style of development is quite
effective, and as the import and export of model material from the Version Control
system works best with single user local project files, it is a good match and a good
use of the two technologies.

Copy of Repository for
Storage or Review

A further use of the single file repository is for distribution to clients and others for
review and comment, where the original model(s) is located in a DBMS or Cloud
that the recipient would not have access to. As it is relatively easy to bulk copy a
DBMS model to a local .eap file, this is a good method for passing on a model to a
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client or another interested party. If some of the material is restricted, it is possible
to delete sections from this single file repository after the bulk copy is complete and
before passing it on.

Replication If network access is limited and DBMS and Cloud based solutions are not possible,
another (less than optimal but still effective) team based solution is to use the built
in replication features of the .EAP file format. By creating a design master and
distributing replicas to other modelers, it is possible to effectively share and
contribute to a model without having direct shared access to the common model.
On the down side, someone will have to perform the model merges as required and
if there are replication conflicts (two changes to the same item) this will require
manual resolution.

Notes

You can also add Model Packages to a project by clicking on the Project Browser header bar and selecting the 'New·
Model From Pattern' menu option
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Copy a Base Project

When you create a new project, you can use the Model Wizard to define the structure and contents. Alternatively, you
can copy an existing template or base project which is already largely set up, containing company standards, tutorials,
frameworks and any other common modeling structures. You can also copy an operational .EAP or .FEAP project file to
a new file location under a new name to, for example:

Provide separate copies for individual team members·

Create an evaluation or distribution version of the project·

If you intend to use an existing project file as the template for a new project, it is important to use this method rather than
simply copying the .EAP file using Windows Explorer. This process provides the option to reset all the unique identifiers
for Packages and elements, so that your new project is truly unique - otherwise you create an exact copy of the original
project.

Access

Open the template project or existing operational project then;

Ribbon
: Save Project As

Create a new project from a base project

Option Action

Target Project Type the new project filename.

You can either type in the file path as well, or click on the Browse button and
browse for the required file path.

If this is to be a shared project, store the file on a shared network resource such as a
Network Server or Workgroup Server.

Source Project Defaults to the path and name of the currently-open template or project.

Reset New Project GUIDs If the target project is to be a different project from the source (such as when you
copy a base template), select this checkbox to replace all GUIDs from the base
model with fresh GUIDs in the new model.

However, if the new project is to be a direct copy of the source, or based on a
project that is under Version Control, we recommend that you deselect this
checkbox to prevent duplication of Packages when the 'Get Latest' facility is used.

Save As Click on this button to save and open the new project.
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Sharing File Based Projects

Enterprise Architect offers a diverse range of functionality designed specifically for sharing projects in team-based and
distributed development environments, through network deployment of model repositories, DBMS based repositories,
Cloud based models, replication and XMI Import/Export.

Features

Feature Detail

Network Deployment Network deployment is possible under three different schemas:

File based repositories·

DBMS server based repositories, or·

Cloud based deployment (recommended)·

DBMS server based repositories offer better:

Response times than files on networks, due to the inherent structure of the·
DBMS

Solutions when networking problems are encountered, as they have the ability·
to backtrack transactions caused by external breakdowns

Replication Replication enables data interchange between .EAP based repositories and is
suitable for where many different users work independently in parallel
development.

Modelers merge their changes into a Design Master only as required; it is
recommended that a backup is carried out prior to replication.

Replication cannot be performed on repositories stored on a DBMS server.

XMI Import and Export XMI Import/Export can be used to export and share discrete Packages between
developers; XMI enables the export of Packages into XML files that can then be
imported into any model.

Package control can be used to set up Packages for Version Control and to enable
batch export of Packages using XMI; Version Control enables a repository to be
maintained by a third-party source code control application that is used to control
access and record revisions.

Notes

DBMS Repository support is available with the Corporate, Unified and Ultimate editions of Enterprise Architect·
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Share Enterprise Architect Projects

The most efficient way of using Enterprise Architect to manage a team development is to share a project amongst a team
of designers, developers and analysts.

Facilities

Facility Detail

By Sharing a project Many people can work on the model at the same time and contribute their·
particular skill

Team members can always see what the latest changes are, keeping the team·
informed and up to date with the project status

You can share a project in
three ways

Place the project in a shared network directory·

Use replication·

Use a shared DBMS-based repository·

Notes

Project Sharing and Replication are available in the Professional, Corporate, Unified and Ultimate editions of·
Enterprise Architect

DBMS repositories are supported in the Corporate, Unified and Ultimate editions of Enterprise Architect·
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Refresh View of Shared Project

When a user of a shared model checks out a Package and makes changes, other users can see those changes by refreshing
their view of the Package or the changed diagram within the Package, in a number of ways.

Refresh the view

Object Options

Project Right-click on the Package name in the Project Browser and select the·
'Contents | Reload Current Package' option, or

Press F5 to refresh the Package, or·

Select the  (Reload Project) icon in the Project Tools toolbar, or·

Press Ctrl+Shift+F11, or·

Close the project and reopen it·

Diagram Select the 'Start > View > Workspace > Manage Views > Reload View' ribbon·
option, or

Right-click on the opened diagram tab in the Diagram View, and select the·
'Reload <diagram name>' option
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Share a Project

The easiest way to share a project amongst a work group of developers and analysts is to place the project file on a
shared network drive, to which people connect from their workstations.

Individual developers and analysts can then open and work on the project concurrently.

Network Issues

Enterprise Architect accepts a number of concurrent connections without issue; however, there are points you should
consider:

Issue Description

Lock Outs There can be occasional 'lock-outs' when one user tries to access or update
something another user is in the process of modifying.

Other Changes Changes to the Project Browser (and other project views) are not automatically
updated; to compensate for this, users must occasionally reload their project to see
changes made by other users.

Diagrams If two or more people work on the same diagram concurrently, unexpected results
can occur; it is best to allow only one analyst to work on a diagram at a time.

System crashes (.EAPX/.EAP files only) If a user's machine crashes, the network suffers an outage
or a machine is turned off unexpectedly, the project file might require repair to
compensate for the sudden inconsistency; a repair facility is provided ('Configure >
Model > Integrity Check> Manage .EAPX/.EAP File > Repair .EAPX/.EAP File')
to carry out this task.

Notes

Firebird-based projects (.feap files) are not suitable for sharing over a network·
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Distributed Development

Enterprise Architect supports distributed development using two different techniques.

Replication

Using replication, geographically separated analysts can update and modify parts of the model in replicas, then merge
these back together at a central location.

XMI Import/Export

Using XMI-based import/export, you can export discrete Packages to XML to share among the development team; this
has several benefits over replication:

You can assemble a model from only the parts necessary to get your job done·

You can assemble a full model if required·

You can assemble a model from different Package versions for different purposes (such as customer visible, internal·
release only)

You can roll-back parts of a model as required·

There is less chance of 'collisions' between developers if each works on a discrete Package·

The process is controllable using a Version Control system, or through Package control·

XMI based import/export is UML1.3 / XMI1.1 compliant; you can also write XML based tools to manipulate and extract
information from XML files to enhance the development process.

XMI-based Import/Export is accessed through the 'Publish > Model Exchange > Export XMI' and 'Import XMI' ribbon
options.
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Replication

Apart from sharing Enterprise Architect projects in real time over a network, you can also share projects using
replication.

Guide

Facility Detail

Replication Replication is a powerful means of sharing projects between isolated or mobile
users; it enables different users to work independently of one another, and to merge
their changes at a later time.

In Replication:

A project is converted to a design master, then replicas are made of the master·

Users take the replicas away, modify the project, then bring their replicas back·
to be synchronized with the master file

Use Replication To use replication:

Convert the base project to a design master.1.

Create replicas from the design master.2.

Take the replica away and work on it as required, then bring it back for3.
synchronization with the design master.

Synchronize the replicas, during which all changes to both the master and the4.
replica are propagated in both directions, so they both finally contain the same
information.

Enterprise Architect Merge
Rules

Enterprise Architect follows these rules in merging:

Additions are cumulative; that is, two replicas each creating three new Classes·
result in six new Classes after merging

Deletions prevail over modifications; if one replica changes a Class name and·
other deletes the Class, merging replicas results in both files losing the Class

Conflicting modifications appear in the 'Resolve Replication Conflicts' dialog.

Upgrades and Replicas When you upgrade your version of Enterprise Architect, you must not open a
replica until you have opened the design master and then synchronized the replicas
with the master; you cannot directly upgrade a replica.

Avoid Change Collisions If two or more people make changes to the same element, Enterprise Architect
arbitrarily overwrites one person's change with the other's; to avoid this, different
users should work on different Packages.

However, since Enterprise Architect does not enforce this rule, it is possible for
users' work to conflict; to minimize difficulties, please note these guidelines:

If users are likely to have worked in the same area of the model, they should·
both witness the synchronization and confirm that they are happy with the net
result

If small pieces of information have been lost, they should be typed into one of·
the merged models after synchronization

If a large piece of information has been lost (for example, an overwritten large·
Class note) use the 'Resolve Replication Conflicts' dialog

(c) Sparx Systems 2018 Page 12 of 22 Created with Enterprise Architect



File Based Projects - File Based Projects 16 January, 2019

Disable or Remove
Replication Features

If you have converted a project to a design master but now want to disable the
replication features, you can remove Replication; ensure that you back up all your
files first.
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Design Masters

A design master is the first converted Enterprise Architect project that supports replication. You create the master project
from which you create replicas that can be modified independently of the master project and re-merged later.

Access

Ribbon Configure > Model > Integrity Check > Manage .EAPX/.EAP File > Make Design
Master

Create a design master

Step Action

1 Take a back-up of the required Enterprise Architect project.

2 Select the project in the Project Browser.

3 Select the 'Make Design Master' menu option and follow the on-screen instructions.
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Create Replicas

A replica is one of several copies of the design master of an Enterprise Architect project. You create the copy of the
master project for you or another user to modify independently and re-merge later.

Access

Ribbon Configure > Model > Integrity Check > Manage .EAPX/.EAP File > Create New
Replica

Create a replica

Step Action

1 First create a design master, then select the 'Create New Replica' menu option and follow the on-screen
instructions.

2 Edit the replica over time and, when required, return the file for merging with the design master.

Notes

In the Corporate, Unified and Ultimate editions of Enterprise Architect, if security is enabled you must have·
'Manage Replicas' permission to create a replica
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Synchronize Replicas

Synchronizing replicas combines the changes made to each file. You can:

Merge the changes made to each replica with the design master, so that a new set of replicas with all changes can be·
generated and distributed

Combine the changes made to two replicas, should it be necessary for two team members to combine their work·

Access

Ribbon Configure > Model > Integrity Check > Manage .EAPX/.EAP File > Synchronize
Replicas

Synchronize replicas

Step Action

1 Open the design master project file (or the first required replica).

2 Select the 'Synchronize Replicas' menu option.

3 Locate and select the (second) required replica to merge the open project and the replica.

Notes

Information is copied both ways, including deletes, updates and inserts; both projects end up containing identical·
information

If this process generates 'conflicting changes' errors, you should review and, if necessary, resolve these conflicts·

In the Corporate, Unified and Ultimate editions of Enterprise Architect, if security is enabled you must have·
'Manage Replicas' permission to create a replica
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Remove Replication

Replication makes many changes to the database structure of your model, so the model file becomes considerably larger
with additional information; you might, therefore, decide not to use the replication feature any more.

Access

Ribbon Configure > Model > Integrity Check > Manage .EAPX/.EAP File > Remove
Replication

Remove replication from your model

Step Action

1 Open a .EAP file (any .EAP file, other than the one having replication removed) - the menu option is not
available if no file is open.

2 Select the 'Remove Replication' menu option.

The 'Remove Replication Wizard' dialog displays.

3 Enter the full path and file name of the project to have replication removed.

Click on the Next button.

If the project displays Version Number 7.0 this indicates that Auditing is enabled. Auditing should be
disabled before proceeding (see Notes).

4 Enter the full path and file name of the base Enterprise Architect model (with no replication) to act as
template.

Click on the Next button.

5 Enter the full path and required file name for the output file.

Click on the Next button.

6 Select whether to have a log file created and, if so, enter a file name for the log file.

7 Click on the Run button to begin removing replication.

Enterprise Architect creates a new project containing all the model information.

Your model has now had replication removed, and should be considerably smaller.

Notes

You cannot remove replication from a model with Auditing enabled - if you want to remove replication:·

Disable Auditing.1.
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If prompted to do so, allow Enterprise Architect to roll back the database version.2.

Remove replication.3.
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Upgrade Replicas

A new release of Enterprise Architect might contain changes to the underlying project structure, such as more tables or
changed queries. If you use Replication, you must take care with your upgrade.

Considerations

Consideration Detail

Open Design Master
Project first

After installing the new version of Enterprise Architect, it is very important that
you open the design master before opening any of the replicas with the updated
version.

Changes to the database
design

Changes to the database design in a replicated project can ONLY be done to the
design master; trying to update a replica at best does nothing, and at worst causes
the update of the master to fail.

Propagate Changes Design changes are propagated through to the replicas the next time the replicas are
synchronized with the master.

Alternatively One other strategy is to remove replication from a copy of the replica set, upgrade
that project and convert it into a new design master from which new replicas are
created.
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Resolve Conflicts

If two or more people each work on the same model object in their respective replicas between synchronizations, the
replication engine has problems in resolving which change is the master. You need to select which of two conflicting
changes you should save to the Design Master and/or replicas, where a substantial piece of information has been
overridden by a user and you want to retrieve it.

Access

Ribbon Configure > Model > Integrity Check > Manage .EAPX/.EAP File > Resolve
Replication Conflicts

Considerations

Consideration Detail

Avoid the problem Ensure that each team member always works in a separate area of the model within
their replica.

Check for conflicts After synchronizing replicas, open the 'Resolve Conflicts' dialog (see next table)
and check if there were any conflicts.

Response to conflicts When a project record has been modified in different ways by different users, the
replication engine selects one of the conflicting values based on rules within the
JET replication manager.

However, the replication engine stores the discarded changes and flags the conflict
on the 'Resolve Conflicts' dialog so that you can choose to roll in the discarded
change instead.

Normally it is not necessary or desirable to examine conflicts, since they represent
relatively inconsequential pieces of information that can very easily be modified
through the normal Enterprise Architect interface; for example, by moving a
diagram element.

The only case in which the 'Resolve Conflicts' dialog should be used is where a
substantial piece of information has been overridden by a user, and you want to
retrieve it.

Resolve conflicts in changes to the same model object in two separate replicas

Step Action

1 Synchronize a replica with the Design Master, and display the 'Resolve Conflicts' dialog.

2 In the 'Table with Conflicts' list, click on the entry that is likely to contain the lost information.
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3 Click on each entry in the Conflicting Records list.

When the lost information appears in the Conflict Details list, click on the Overwrite with Conflict button.

4 In the 'Conflicting Records' list, you can also copy each Row ID to the clipboard by right-clicking on the
row and selecting the 'Copy to Clipboard' menu option.

You can locate the object that is in conflict in the Project Browser or diagrams, by right-clicking on it and
selecting the 'Find in Project Browser' or 'Find in Diagrams' option.
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