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Document Reports

The documentation engine allows you to create high quality,
professional documentation that can completely replace the
need to create handcrafted documents. Enterprise Architect
provides an extensive set of templates that will be useful in
many situations. These templates can be adjusted or new
ones created to completely customize the documentation to
the reporting requirements of a particular project or
methodology, including cover pages and styles. The
standard documentation facility helps you to report on any
Package or element in the repository, and with the Virtual
Documents facility you can selectively pick content from
any section of the model and style and order it as you
require. There is also a set of built-in reports with
pre-configured content and styles that give you immediate
information on specific groups of elements or properties in
the model. You have the options of:

Generating one of a set of system-provided reports on·

specific aspects of your model

Generating a report from a system-provided template,·

with control of the report output through Stylesheets,
add-in cover pages and tables of contents, filters and a
wide range of dialog options

Creating your own templates, Stylesheets and add-in·

pages from which to generate reports, applying an even
greater degree of control over the contents and format of
the output
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The document formats are common to many word
processors, so you can also work on the reports in other
word-processing tools to, for example, integrate the report
into a larger, externally-created document.

Documentation Solutions

Feature Detail

Document
Generation

The Document Generator features a
powerful WYSIWYG Document editor
that you can use to:

Import and export document templates·

using XML
Customize copies of the basic,·

system-provided templates
Create entirely new templates of your·

own design
Test templates as you design them, by·

generating ad-hoc reports within the
designer
Create and customize independent·

Stylesheets, Tables of Contents and
Cover Sheets to apply to any of your
reports

It also features a documentation generator
that:
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Provides a wide range of simple·

options for filtering and modifying the
report output
Generates detailed and comprehensive·

documents based on the templates
Has an embedded viewer for reading·

the generated documents directly
within Enterprise Architect

A tutorial on using the Document
Generator and creating document reports
is available on the Sparx Systems
website.

Virtual
Documents

If you want to create very focused and
specific documents, with a greater
complexity and presenting different
views of your model data, you can do so
using virtual documents. For these, you
set up a Report Package element and/or
Model Document elements, and link
Packages or model searches (for
elements) into the document in whatever
order or combination is most appropriate
to your requirements.
You can select Packages from different
areas of the model, arrange them in any
order, and edit or delete the Packages; the
virtual document automatically
incorporates the changes each time you
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generate it.

Word Master
Documents

As an alternative to virtual documents,
you can link a number of document
reports into a single MS WordTM master
document. This is quite possible with the
current report generator but is of greater
use with the original Legacy RTF Report
Generator.
Typically you create a Word master
document, then in Enterprise Architect
generate some reports that you link back
into sub-sections of the master document
and refresh as required during project
development. In this way the project
document becomes an easily-managed
and feature-rich work product.
You can also populate a Word document
from specific sections of reports, based
on bookmarks - for example, a Word
document might have a section for a
small part of your component model;
using bookmarks you can generate a full
component model, and then link into just
one section of the report.
This way you can maintain a complex
Word document from parts of Enterprise
Architect reports; the Document
Generator performs one pass for one

(c) Sparx Systems 2021 Page  11 of 416



Document Reports 2 September, 2021

template, but using a Word master
document and Enterprise Architect
bookmarks you can incorporate material
from several documents with different
formats based on different templates.
By adding tables of contents, figure
tables, sections, and headers and footers,
you can manage a complex document
with relative ease; simply update the
Enterprise Architect reports then refresh
the links in Word.

Notes

In the Corporate, Unified and Ultimate Editions of·

Enterprise Architect, if security is enabled you must have
'Generate Documents' permission to generate document
reports

You can have several reports open at the same time, as·

separate tabs in the central view area of the Enterprise
Architect work area; you can also close the reports
individually or all together, leaving views of other types
(such as diagrams or code editors) still open
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Generate Document Reports

When you want to generate a document report on part of
your model, you have a number of options for selecting the
object to document, and for defining how your document is
to be generated.

A document report describes an element or, more usually, a
Package in the model; therefore, your first step is to select
the Package or element to generate the document for, from
the:

Browser window·

Diagram·

Package Browser·

Specification Manager·

Diagram List or·

Model Search·

For a Package, you can also define how the diagrams in the
Package are to be set out in the document; you do this in the
diagram 'Properties' dialog for each diagram. When you
have prepared and selected your Package, you open the
'Generate Documentation' dialog and configure the
parameters for generating the document.

A tutorial for quickly creating a basic document from the
Example model is provided in the second of these two
tables. Repeat the tutorial with different selections in the
drop-down fields, to see what the system can generate for
you automatically.
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Access

Select a Package or element for which to generate
documentation, then open the 'Generate Documentation'
dialog using one of these methods.

Ribbon Publish > Model Reports > Report
Builder > Generate Documentation

Browser
window
Toolbar

  | Documentation | Generate
Documentation (RTF/PDF/DOCX)

Keyboard
Shortcuts

F8

Generating reports

Option Detail

Alternative
ways to open
the 'Generate
Documentati

Use one of these methods:
In the Specification Manager, click on·

the 'Specification - Specify > Element
> Documentation > Generate
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on' dialog Documentation (RTF/PDF/DOCX)'
ribbon option
In the Diagram List, Package·

Browser or Model Search, select one
or more items, right-click and select
either 'Documentation | Generate
Documentation for each selected Item'
or 'Documentation | Generate
Documentation for selected Items'

Generate
report on
elements
from Package
Browser or
Model
Search

When you select to create a report from
the Diagram List, Package Browser or
Model Search tools, you can generate an
element-level report rather than a
Package-level report, and you have
additional flexibility in selecting:

The type of element to report on·

The specific elements to report on,·

together or separately, whether in the
same Package or not

For example, you might want to find all
elements with test cases, with the
intention of reporting on some or possibly
all such elements; with the Diagram List
or Package Browser, you would identify
these elements yourself within the list of
all elements in a selected diagram or
Package, but with the Model Search you
can automatically pick out the elements
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across a section of the model or across
the whole model, as required.
The search filtering could be for specific
test cases; however, the results are by
element so if there are test cases outside
the range in any element that has a
filtered test, these elements are listed as
well.
Having generated the list of elements,
you can select individual elements,
blocks of elements, or all elements from
it and then use the context menu to
generate one report on all of the selected
elements, or a separate report on each
element.

Generate and view an example report
immediately

Ste
p

Action

1 Open the EAExample project.

2 In the Browser window, expand the Testing View
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and click on the Testing Package.

3 Select the 'Publish > Model Reports > Report
Builder > Generate Documentation' ribbon option.
The 'Generate Documentation' dialog displays.

4 In the 'Output to file' field, click on the  button and
browse for a convenient file location in which to
hold the generated report. Include the appropriate
file extension to set the document format (PDF,
RTF, DOCX) of the generated report.

5 In the 'Template' field, click on the drop-down
arrow and select 'Basic Report'.

6 In the 'Table of Contents' field, click on the
drop-down arrow and select 'TOC (portrait)'.

7 In the 'Stylesheet' field, click on the drop-down
arrow and select 'Styles - Print Medium'.

8 In the 'Cover Page' field, click on the drop-down
arrow and select 'Cover Page (portrait)'.

9 Click on the Generate button.

10 When the report has been generated, click on the
View button and examine the report.
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Notes

Reports can be configured to include all Packages within·

a parent Package, or just the top level
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Generate Documentation

It is possible to specify a wide range of parameters to
control how your document report is generated and output.
You can specify, for example, where the document file is
written to and what format it is generated in, what language
it is generated in, and what elements are included in the
document. You set these options on the 'Generate
Documentation' dialog, in which the options are provided on
a number of tabs.

The first, and default, tab is the 'Generate' tab, on which you
define how and where the document is generated. After you
have set options on any or all of the other tabs, you return to
the 'Generate' tab and click on the Generate button to
produce your document.

Access

Select a Package or element for which to generate
documentation, then open the 'Generate Documentation'
dialog using one of the methods outlined here.

Ribbon Publish > Model Reports > Report
Builder > Generate Documentation >
Generate

Keyboard F8 | Generate
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Shortcuts

Set Report Generation Options

Option Action

Model
Document
Root Element
Root Package

Check the name of the element selected
from the Browser window, diagram,
Diagram List, Specification Manager
or Model Search.
If this is the specially-created Model
Document element for a virtual
document, the field is 'Model Document'.
Otherwise, this field identifies the
selected element of the hierarchy to be
reported on; that is, the Root Element or
Root Package.

Output to
File

Type or select the location and filename
for the generated documentation.
Click on the  button to navigate to the
location.
Enter the appropriate file extension for
the document format in which to generate
the report - PDF, RTF or DOCX.
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Template Click on the drop-down arrow and
select the name of the template to use for
your document report.
You can select any template from the
drop-down list, which is divided into
Custom (or user) templates and System
templates. If you have loaded an MDG
Technology containing document
templates, those are also listed under the
Technology name.
You can also immediately create a new
template, by selecting the '<new
template>' option.
The system checks all template folders
for the specified template, in the order
Custom Templates > Technology
Templates > System Templates. If there
are different templates available under
the same name, the system uses the first
found in this sequence.

Cover Page Click on the drop-down arrow and
select the name of the cover page
definition to apply to your document
report.
You can select any definition from the
drop-down list, whether a standard format
or a user-designed page.
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Use the default value <none> to not
include a cover page, or to use a cover
page built in to the selected user-defined
template.

Table of
Contents

Click on the drop-down arrow and
select the name of the Table of Contents
definition to apply to your document
report.
You can select any definition from the
drop-down list, whether a standard TOC
format or a user-designed format.
Use the default value <none> to not
include a Table of Contents, or to use a
table of Contents built in to the selected
user-defined template.

Stylesheet Click on the drop-down arrow and
select the name of the Stylesheet to apply
to your document report.
You can select any Stylesheet from the
drop-down list, whether a standard
definition or a set of user-designed styles.
Use the default value '<none>' to not use
a Stylesheet and instead apply the styles
defined in the template you have selected
in the 'Template' field.

Diagram Click on the drop-down arrow and
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Theme select a Diagram Theme to apply the
color, line thickness and font style to
diagrams of elements in the report, if
those elements are using default values.
If an element has a tailored appearance
assigned using, for example, the 'Default
Appearance' dialog, that appearance
overrides the Theme settings.
The default option is the Diagram Theme
you have currently set in your 'Local'
options. You can, however, select any
other Theme just for this report. The field
setting reverts to your default Theme
after the report is generated.

Suppress
Sections

Click on the drop-down arrow and
select from a list of Suppress Profiles that
you or other users of the model have
created on the 'Suppress Section' tab of
the 'Generate Documentation' dialog.
Each Suppress Profile defines report
sections that can be omitted when you
generate the current report. This helps
you to tailor the report for a specific
audience on generation.
(You can also omit child Packages from
any report generated on the parent
Package; see the Exclude Package from
Document and HTML Report Help topic.)
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Watermark Type in the location of the image to use
as a watermark on the document, or click
on the  button to browse for the
location.

Wash image If you have selected a watermark image,
select this checkbox to apply a wash to
the image before applying it to the
document. This makes the image lighter
so that it does not detract from the report
content printed over it.

Language Click on the drop-down arrow and
select the language in which to generate
the document. The list of available
languages is defined by the Model
Administrator on the 'Translations' page
of the 'Manage Project Options' dialog.
When the document is generated, the
generator includes in the document all
Notes, object names and aliases that have
translations into the selected language. If
any fields do not contain a translation for
that language, the corresponding
document field remains blank.

Image
Quality

Click on the drop-down arrow and
select the level of scaling required to
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reproduce the diagram images in the
report. This determines the visual quality
of the image.

Draft·

Standard (the default)·

High Resolution·

Very High Resolution·

Regardless of the image quality, all
images are reproduced at a consistent
size.

View
Document
On
Completion

Select this checkbox to open the
document report as soon as it has been
generated.

Use
Language
Substitutions

Select this checkbox to switch custom
language word substitutions on.
Deselect the checkbox to switch custom
language word substitutions off.

Markup
Glossary
Terms

Select this checkbox to apply, throughout
the generated RTF report, any styles
applied to any Glossary terms through the
Notes text of an element.
A style is applied to a Glossary term
according to its Glossary term type.
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Use Glossary
Substitution

(Available if Markup Glossary Terms
is selected.)
Click on the drop-down arrow and
select a term type. For all glossary terms
of that type, wherever a term occurs in
the report it will be replaced by its
meaning.
For example, if you select a term type of
'edition', in the report the terms 'Corp',
'Uni' and 'Ult' would be replaced by the
meanings 'Corporate', 'Unified' and
'Ultimate', respectively.

Batch Click on this button to display the 'Batch
Document Generation' dialog, to generate
reports in a batch process.

Use Internal
Viewer

Select this checkbox to enable the View
button to launch the generated document
in the Enterprise Architect internal
viewer.
Deselect this checkbox to enable the
View button to launch the generated
document in the MS Windows default file
viewer.

Include all
Diagram
Elements in

Select this checkbox to include elements
in the report from external Packages that
are referenced from a diagram, for every
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Report diagram searched by the report; the
checkbox defaults to selected.
To include the external elements in the
document, also select the
'Package.Diagram.Element' and
'Package.Element' checkboxes in the
current template.
If external elements are to be included
only for specific diagrams, deselect this
checkbox and - only for the diagrams for
which you want to include external
elements in the report - for each diagram
select the 'Add each contained element in
Documentation' checkbox in the diagram
properties.
When both options are deselected, or
when neither of the
'Package.Diagram.Element' or
'Package.Element' checkboxes are
selected in the template, only elements in
the current Package are documented.

Progress Indicate the progress of document
generation with status messages and an
increasingly filled status bar.

Resource
Document

Click on this button to save the
currently-set options as a document
definition.
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Open
Template

Click on this button to edit the
currently-selected template using the
Document Template Editor.
You can only edit user-defined templates,
not the standard templates provided with
the system. If you have selected a system
template, this button is grayed out.

Generate Click on this button to generate the
document (after you have set all the
options you require, on all tabs of the
dialog).

View Click on this button to launch the
generated document in:

The MS Windows default file viewer,·

or
The Enterprise Architect internal·

viewer, if you have selected the 'Use
Internal Viewer' checkbox

Abort Click on this button to cancel report
generation; a prompt displays to confirm
cancellation of the report.
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Notes

For an introduction to generating document reports, see·

the Document Reports Help topic

The second tab on the 'Generate Documentation' dialog,·

'Templates', is used to develop and maintain custom:
-  Templates
-  Stylesheets
-  Tables of Contents and
-  Cover Pages
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Selecting a Template

You use report templates to generate reports on your model
that present specific information in a particular format, and
to help you generate those reports repeatedly and
consistently. You can select from a range of system
templates on the Document Generator, to immediately
generate reports from your model, or you can select custom
templates designed by your project team members
specifically for the purposes of your project.

A template principally defines the type of content of the
report, so that if you generate a report, say, on a Package
you will extract and present information on a specific set of
structures such as:

the elements and their features and connectors, or·

the elements at the top of the Package hierarchy, or·

all elements in the Package, or·

all elements in the diagrams whether they are in that·

Package or from other Packages

A template also presents the report information in a specific
format and style, initially based on a set of standard styles.
Your report designers can redefine the styles in a custom
template to whatever extent they need, but it is better to
select the alternative styles from a Stylesheet so that you can
choose to apply that set of styles to a report or not,
independent of which template you are using, as you need.

The initial range of system templates and Stylesheets give

(c) Sparx Systems 2021 Page  30 of 416



Document Reports 2 September, 2021

you a great deal of flexibility in quickly and easily
determining the content and presentation of the reports you
want to generate, and you can further increase this flexibility
with additional templates and Stylesheets developed
in-house, customized to the requirements of your
organization.
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System Document Templates

When you generate reports on your model, you select one of
the report templates to extract information on specific key
aspects of your model. There are several system templates
available to use, either to generate a report straight away or
to copy and customize to suit your own requirements. Each
of the system templates supports a specific aspect of
modeling or model management.

You usually generate reports on Packages selected from the
Browser window; these can be used to produce great
hierarchical reports on parts of your model, or the whole
model if you prefer. There are also system templates for
reporting the diagrams in a Package, which you can use to
report on elements returned in search results - such reports
are non-hierarchical, as they extract specific information
from different areas of the model.

Access - copy existing templates for editing

Display the Document Template editor window, select a
template, then click on the 'Save As New' toolbar icon.

Ribbon Publish > Model Reports > Templates :
select a particular template >  (toolbar
icon)
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Access - select a template for report
generation

Use one of the methods outlined here to display the
'Generate Documentation' dialog at the 'Generate' tab,  then
use the 'Template' field drop-down list to select which
template to use for generating the report.

Ribbon Publish > Model Reports > Report
Builder > Generate Documentation >
select from the 'Template' drop-down list.

Keyboard
Shortcuts

F8 | select from the 'Template' drop-down
list.

Available Predefined Templates

Template Description

Audit Report
- Detailed

Incorporates information from the latest
Audit runs.

Data Used for reporting on Physical database
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Modeling
Report

models of any of the three types - UML
DDL, Information Engineering and
IDEF1X.
With data modeling, a Class represents a
Table and its attributes represent Table
fields. In the Data Modeling template, the
section and field names are selected to
represent the Tables, Columns (fields)
and specific Column attributes.

Diagram
Report

Extracts information on the diagrams for
a Package. It is primarily used for
outputting diagram graphics and titles.
A common use of this template is where
diagrams linked into an external Word
master document (where Virtual
Documents are not being used) are to be
refreshed. Using the bookmarks
generated with the documents, you can
refresh the master document diagrams.

Glossary Extracts the Glossary terms and their
types, defined in the Project Glossary.
This is commonly used in Virtual
documents for appending the Glossary to
a larger document.

Maintenance
Report

Extracts the Change, Defect, Document
and Issue details for all elements in a
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selected Package. This is the information
defined on the Maintenance window.

Model
Report

The most generalized template, which
includes all of the commonly used
Sections and fields. It is more appropriate
in its use of field names to UML Classes.
This template provides table formatting
for most of the element's sub-groups,
such as Scenarios, Constraints, Attributes
and Operations.

Project Issues Extracts information on the set of issues
that are logged globally in the repository.
To report on the non-global,
element-specific issues, see the Element
> Issue section in the Model Report
template.

Project
Management
Report

Shows the Resource allocation, Effort,
Metric and Risk details for each element
in the selected Package.

Requirements
Report -
Details

Extracts full information on the external
Requirements of the selected Package,
including the model structure each forms
a part of, and the internal responsibilities,
scenarios and project management and
resource records that might exist to
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support requirements management.

Requirements
Report -
Summary

Provides a brief description of each
Requirement element in the selected
Package.

Specification
Manager List

Lists the elements and sub-Packages, and
their subordinate elements, under the
current Specification Package in the
Specification Manager. Items within a
level are listed in alphabetical order.

Test Report Extracts the Test details for all elements
in a selected Package, as defined on the
Testing window, and the test data
generated by xUnit testing and Testpoint
code testing.

Use Case
Details

Extracts information on the Use Cases in
a selected Package, including the details
of any scenarios. This template also
excludes child structures.
If you want to include sub-element Use
Cases, select the Element > Child
Elements section.

Use Case
Summary

Extracts basic element description
information on the Use Cases in a
selected Package. This excludes scenario
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details and child structures (to filter out
the information on any Sequence
diagrams set as child diagrams of the Use
Case elements).

Notes

The facility to use the 'Diagram > Element' section to·

report elements contained in a diagram but defined in
another Package, is inactive in system templates
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Selecting a Cover Page

A cover page defines the text, styles, graphics and layout of
the front page of a document. Enterprise Architect provides
two standard cover pages, one for portrait documents and
one for landscape documents, which you can apply to your
document reports independent of the report template and
Stylesheet you are using. Your report designers can copy
these standard cover pages as the bases for custom cover
pages that reflect your corporate styles, logos and document
naming conventions.

The cover page templates can contain fields that
automatically extract and display data such as:

The report type·

The Package or element being reported on·

The version of the report·

The status of the report·

The date on which the report was generated·

The name of the person who generated the report·

The location of the report file·

Any logos or graphics to be displayed on the front page·

In using a cover page, you do not need to spend time
defining the inclusion and display of the report title and
provenance - it is already prepared for you. You can access
the cover page templates from the 'Cover Page' drop-down
list on the 'Generate' tab of the 'Generate Documentation'
dialog.
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Notes

If you have custom report templates that already contain·

the cover page definitions you want, you can still apply
them by just setting the 'Cover Page' field on the
'Generate' tab to '<none>'
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Selecting a Table of Contents

A very useful feature of any documentation is the inclusion
of a Table of Contents. This can, however, be quite
demanding to create, especially when you have to set up a
Table of Contents for individual documents. Even setting up
Contents Lists within templates can still be very time
consuming, when you have a number of templates to
maintain. It is far quicker and easier to apply a specific
Table of Contents template to your document reports
independent of which report you are generating and which
content template you are basing the report on.

Enterprise Architect provides two TOC templates - one for
landscape documents and one for portrait documents - that
have the appropriate styles, formatting and numbering
system already defined. You can access these templates
through the 'Table of Contents' field on the 'General' tab of
the 'Generate Documentation' dialog.

Your report developers can copy the two system-provided
templates as the bases for custom Tables of Contents,
tailored to the requirements of your organization. These
customized templates are also directly available to you
through the drop-down list for the 'Table of Contents' field.

Notes

If you have a Table of Contents defined in any of your·

custom report templates, and you want to use it, just set
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the 'Table of Contents' field on the 'General' tab to
'<none>'
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Selecting a Stylesheet

Using Stylesheets is an effective method of applying
consistent format and appearance standards to categories of
documentation, independent of the templates or other
methods of defining document content you use. Stylesheets
increase the flexibility of your documentation generation, in
that you can:

Provide a suite of documents generated from different·

templates with the same style standards, using one
Stylesheet, and

Deliver the same document content in different styles for·

different customer audiences by applying different
Stylesheets to documents generated from one template

Enterprise Architect provides six standard Stylesheets -
three for printed documentation and three for online
documentation. Your report designers can copy these as the
bases for custom Stylesheets, reflecting the corporate
standards of your organization. Each custom Stylesheet can
define a totally different page layout and document styles to
other Stylesheets and to the Normal.rtf Stylesheet. You can
access both system and custom Stylesheets from the
'Stylesheet' drop-down list on the 'General' tab of the
'Generate Documentation' dialog.

Style Hierarchy
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Stylesheets are the top level of a hierarchy of styles across
the system.

Initially, all documents and templates, whether for Linked·

Documents or report documents, reflect the global styles
defined in the Normal.rtf file; you can edit this file to
provide new global styles for all documents and templates
created after the update

In a specific document or template, you can edit the styles·

for that document or for all documents generated from
that template; these edited styles override those of the
same name in the Normal.rtf file, but any styles that have
not been changed still reflect the definitions in the
Normal.rtf file

You can use a Stylesheet to apply a set of style definitions·

to a generated document, independent of the template you
use; these styles override any styles of the same name
defined in the document templates and/or the Normal.rtf
file

Notes

If you have custom templates that contain all the style·

definitions you need, or if you want to just use the
Normal.rtf styles, you can continue to apply those simply
by setting the 'Stylesheet' field on the 'General' tab to
'<none>'
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Document Options

When defining the contents of your document, you can set a
wide range of options for selecting the reported items by
type and property, and you can organize the information
within each type in order of position in the Browser
window or by created or modified date. These document
options are provided in two different ways:

On the 'Options' page on the 'Generate Documentation'·

dialog, to be set for a specific instance of a report; the
options are reset when you exit the dialog or select a
different template

On panels on the 'Document Options' dialog, to be·

configured in a template as the default settings to be
applied to every report generated using that template;
these settings can be overridden by the 'specific instance'
settings on the 'Generate Documentation' dialog

The listed options are the same for both dialogs, except that
the 'Document Options' dialog:

Includes the 'Exclude Filters', 'Element Filters' and 'Other·

Filters' pages from the 'Generate Documentation' dialog

Includes the 'Custom Query' page (for 'Template·

Fragments')

Does not provide these options (as found on the 'Options'·

page of the 'Generate Documentation' dialog):
     -  The Switch generator button
     -  The 'Disable large OLE file support' option
     -  The 'Insert page breaks when generating a Master
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Document' option
     -  The 'Indent Linked Document Headings' option
     -  The 'Hide diagram borders' option
     -  The 'Hide non-printable objects' option

Access -  'Generate Documentation' dialog

Display the 'Generate Documentation' dialog, then select the
'Options' page

Ribbon Publish > Model Reports > Report
Builder > Generate Documentation >
Options

Keyboard
Shortcuts

F8 | Options

Access -  Template Editor 'Document
Options' dialog

Display the Document Template editor window, select a
template, then display the 'Document Options' dialog.

Ribbon Publish > Model Reports > Templates :
select a particular template >  (toolbar
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icon)

Options

Field Action

Packages by Click on the drop down arrow in the first
field and select to organize Packages in
the generated documentation by Name,
Tree Order, Modified Date or Created
Date.
Click on the drop down arrow in the
second field and select to list the
Packages in either Ascending or
Descending order.

Elements by Click on the drop down arrow in the first
field and select to organize elements in
the generated documentation by Name,
Tree Order, Modified Date or Created
Date.
Click on the drop down arrow in the
second field and select to list the
elements in either Ascending or
Descending order.
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Diagrams by Click on the drop down arrow in the first
field and select to organize diagrams in
the generated documentation by Name,
Tree Order, Modified Date or Created
Date.
Click on the drop down arrow in the
second field and select to list the
diagrams in either Ascending or
Descending order.

Hide
'note-less'
elements

Select this checkbox to exclude all
elements without notes from the
documentation.

Propagate
Package
Filters

Select this option to apply a top-level
Package filter to all child templates and
fragments, overriding any filters set on
those child templates.

Hide
'note-less'
connectors

Select this checkbox to exclude all
connectors without notes from the
documentation.

Hide
<Anonymous
> elements

Select this checkbox to hide anonymous
elements in the documentation.

Disable large
OLE file

Select this checkbox to disable support
for large Object Linking and Embedding

(c) Sparx Systems 2021 Page  48 of 416



Document Reports 2 September, 2021

support (OLE) files.

Use style
defined in
template for
notes

Select this checkbox to override the
character formatting specified in your
'Notes' fields with the formatting set for
the field in the template.

Insert page
breaks when
generating a
Master
Document

Select this checkbox to insert a page
break after each Model Document in a
Report Package.

Include child
elements
even if the
parent
element is
filtered out

Select this checkbox to document all
child elements that are not otherwise
filtered out by the restrictions, even if the
parent elements are filtered out.

Indent
Linked
Document
Headings

Select this checkbox to adjust the heading
levels of any Linked Document included
in the report so that they match the
heading levels of the report. The
adjustment is made on the assumption
that the first heading level in the Linked
Document starts at 1.

Hide Select this checkbox to hide the diagram

(c) Sparx Systems 2021 Page  49 of 416



Document Reports 2 September, 2021

Diagram
Borders

frame on all diagrams included in the
generated document.
When selected, this option overrides the
'On Saved Images' checkbox on the 'Start
> Desktop > Preferences > Diagrams'
page.

Hide
non-printable
objects

Defaults to selected to hide all objects
that have been flagged as non-printable,
in any diagrams in the report. Objects are
flagged as non-printable through the
element context menu on a diagram.
To show the non-printable objects in this
report, deselect the checkbox.

Show status
colors

Select this checkbox to display the status
colors of each object in any diagrams in
the report, regardless of the settings of the
'Show status colors on diagrams' option
on the 'Objects' page of the 'Preferences'
dialog.

Convert
Element
hyperlinks to
Help
hyperlinks

Select this checkbox to covert hyperlinks
in the element Notes to hyperlinks
between document sections, when the
document is generated using the template.

No Select this checkbox to prevent document
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bookmarks bookmarks from being inserted into the
generated document.

Skip root
package

Select this checkbox to exclude the parent
Package from the documentation and
include only the child Packages.

Diagram
Format

Click on the drop-down arrow and
select the diagram format for the images
included within the documentation; either
Metafile or Bitmap.

Adjust
Heading
Levels

Click on the drop-down arrow and
select the lowest heading level that can be
generated for nested sub-Packages in the
document
The Document Generator reproduces
heading levels down to the value you set;
for example, if you have four nested
levels of sub-Packages and you set this
field to:

Heading 2, all sub-Packages in the·

report are documented under level 2
headings
Heading 4, the first level of·

sub-Packages are documented under
level 2 headings, the next level under
level 3 headings, and the remainder all
under level 4 headings
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Heading 6, the first level of·

sub-Packages are documented under
level 2 headings, the next level under
level 3 headings, the next under level 4
headings, and the next under level 5
headings; if you added further levels of
sub-Package they would all be
documented under level 6 headings

The field defaults to Heading 9 to
accommodate the maximum number of
levels of nested sub-Packages.

Switch
generator

Click on this button to switch from this
'Generate Documentation' dialog (the
Enhanced Template Driven Generator) to
the 'Rich Text Format Report' dialog
(Legacy Generator).
This button is not available if you
displayed the dialog from the Diagram
List, Package Browser or Model
Search.

Only include
objects

Filter elements according to the date they
were created or last modified. In the:

First field, click on the drop-down·

arrow and select the value 'Modified'
or 'Created'
Second field, click on the drop-down·

arrow and select the value 'After' or
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'Before'
Third field, select the checkbox, click·

on the drop-down arrow and select the
appropriate date

Where
Package
Phase

Filter elements according to the value of
the Package 'Phase' field.
In the first field click on the drop-down
arrow and select the qualifier, and in the
second field type the required phase (or
leave the default value 'All').

With element
status

Filter elements according to status.
In the first field, click on the drop-down
arrow and select the qualifier ('like', 'not
like', 'in', 'not in') and in the second field
type the value to be used.
Values should be enclosed in quotes; for
example:
     "Proposed".
If you type more than one value, separate
them with a comma; for example:
     "Proposed", "Implemented"

Connector
Direction

Click on the drop-down arrow and
select the connector direction to include
only connectors having that direction.
If you select 'Both', the connector is
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documented twice; once for the source
element and once for the target.
For the remaining two values, the
connector is documented only for the
source or target element, as appropriate.

Except where
Query
excludes
Package

This option excludes the selected
Package or a child Package from the
report, where that Package is specifically
identified by a Custom SQL Query or a
Custom Script.
Click on the appropriate radio button for
the type of query and:

If you have selected 'Custom SQL',·

type the query into the window beneath
the radio buttons
If you have selected 'Custom Script', a·

new field displays; click on the
drop-down arrow and select the
script, then type the entry point of the
Script into the window beneath the
radio buttons
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Exclude Package Query and Script

On the 'Document Options' dialog (Template Editor) or
'Options' tab (Document Generator) you can enter a
custom SQL Query or select a custom Script to tailor the
report in a specific way. One possibility is to exclude the
selected Package or a child Package from the report. You
can base your Query or script on the examples provided
here.

The two parameters you use in excluding a Package are:

#PACKAGEID# - the Package_ID of the current record in·

t_package being processed on the exclusion condition

#OBJECTID# - the Object_ID of the current Package·

element record in t_object being processed on the
exclusion condition

Custom SQL Query

To exclude the Package from the report using a Custom
SQL Query, you can create the Query based on the
t_package columns. For example:

     SELECT  Package_ID AS ExcludePackage

     FROM   t_package

     WHERE Package_ID = #PACKAGEID#

     AND      Name = 'Test'

Alternatively, you can create the Query based on the
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Package object columns in the t_object table:

     SELECT  t_package.Package_ID AS ExcludePackage

     FROM   t_package,t_object

     WHERE t_package.Package_ID = #PACKAGEID#

     AND      t_object.Object_ID =#OBJECTID#

     AND      t_object.Stereotype = 'NoDoc'

Custom Script

If you have selected the 'Custom Script' option and want to
exclude the Package from the report, you can create a script
and enter a call to it, such as:

     ExcludePackage(#PACKAGEID#)

This is a sample of the XML returned by the script:

     <?xml version="1.0"?>

          <EADATA version="1.0" exporter="Enterprise
Architect">

          <Dataset_0>

               <Data>

                    <Row>

                         <ExcludePackage>

                         89

                         </ExcludePackage>
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                    </Row>

               </Data>

          </Dataset_0>

          </EADATA>

This is an example of JScript for excluding the Package:

     !INC Local Scripts.EAConstants-JScript

     /*

     * Script Name: RTF Exclude Packages Script Sample

     */

     function ExcludePackage(packageID)

     {

          var xmlDOM = new
ActiveXObject("MSXML2.DOMDocument.4.0");

          xmlDOM.validateOnParse = false;

          xmlDOM.async = false;

          var node =
xmlDOM.createProcessingInstruction("xml", "version='1.0'
encoding='ISO-8859-1'");

          xmlDOM.appendChild(node);

          var xmlRoot = xmlDOM.createElement("EADATA");

          xmlDOM.appendChild(xmlRoot);

          var xmlDataSet =
xmlDOM.createElement("Dataset_0");

          xmlRoot.appendChild(xmlDataSet);
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          var xmlData = xmlDOM.createElement("Data");

          xmlDataSet.appendChild(xmlData);

          var xmlRow = xmlDOM.createElement("Row");

          xmlData.appendChild(xmlRow);

          var package as EA.Package;

          package = Repository.GetPackageByID(packageID)

          if(package.StereotypeEx == "NoDoc")

          {

               var xmlName =
xmlDOM.createElement("ExcludePackage");

               xmlName.text = "" + package.PackageID;

               xmlRow.appendChild(xmlName);

          }

          return xmlDOM.xml;

     };
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Suppress Sections

A Suppress Profile defines report sections that can be
omitted when you generate the current report. This helps
you to tailor the report for a specific audience on generation.
You can define Suppress Profiles on the 'Suppress sections'
tab of the 'Generate Documentation' dialog; you can also use
the tab to delete profiles that you or other users have created
in the model.

Access

Ribbon Publish > Model Reports > Report
Builder > Generate Documentation >
Suppress sections

Keyboard
Shortcuts

F8 > Suppress sections

Create a Suppress Profile

To create a Suppress Profile, select the checkbox against
each section to exclude from the report.

When you select a section, all its child sections will also be
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excluded by default. For example, selecting the Diagram
section will exclude the child 'Element', 'Connector',
'Messages' and 'Audit History' sections. If you want to
exclude only some of these, you select the appropriate
checkboxes directly.

Having selected the sections to exclude, type a profile name
in the drop-down field to the right of the Save button, and
click on that button.

To clear the selected checkboxes, click on the Clear button.
To clear the profile name, click on the drop-down arrow at
the end of the name field and select the blank entry.

Delete a Suppress Profile

To delete a Suppress Profile, click on the drop-down arrow
at the end of the profile name field, click on the name of the
profile and then on the Delete key.

A prompt displays to confirm the deletion. Click on the Yes
button.

Clear the name field, by clicking on the drop-down arrow
and selecting the blank entry.
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Exclude Filters

As you specify the output of your report, you might want to
exclude objects of a specific type. You can do this using the
'Exclude Filters' tab, through which you can select to
exclude from your report one or more:

Types of element·

Types of connector, and/or·

Types of diagram·

You can select the objects in one of two ways:

Click on the All button underneath the appropriate panel,·

to exclude every type of element, connector or diagram,
and then Ctrl+click on the individual types that you DO
want to include in the report, or

Click on the None button underneath the appropriate·

panel to clear all selections (which includes the objects of
every type in the report) and then Ctrl+click on each type
of object that you do NOT want to show in the report

Notes

If you want to specifically include or exclude elements on·

the basis of their specific properties or features, rather
than their type, use the 'Element Filters' and 'Other Filters'
tabs

Filters set in a template operate only on that template, and·

do not operate on subtemplates and template fragments
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inserted into the template; to filter the subtemplates, set
the filter within each one
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Element Filters

As you specify the output of your report, you might want to
include only elements that have specific properties, rather
than every element encountered. Using the 'Element Filters'
tab, you can define which element properties to report on,
and which fields and field values. You can also delete the
element filters if you no longer want to apply them.

The 'Element Filters' tab is provided in two different ways,
as a tab of:

The 'Generate Documentation' dialog, to set filters for a·

specific instance of a report; the filters are reset when you
exit the dialog or select a different template, or

The 'Document Options' dialog, to set filters in a template·

as the default settings to be applied to every report
generated using that template; these settings can be
overridden by the 'specific instance' settings on the
'Generate Documentation' dialog

The options and behavior are the same for both dialogs,
except that the 'Document Options' dialog provides a facility
for importing a previously-defined set of Model Search
filters from within your model or from an external file
(created by exporting a Model Search from another model).

The facilities are also provided through the 'Element Filters'
page of the 'Properties' dialog for a Standard Chart element.
This page most closely resembles the tab of the 'Document
Options' dialog in the Document Template editor.
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Access -  'Generate Documentation' dialog

Display the 'Generate Documentation' dialog, then select the
'Element Filters' page.

To open the 'Generate Documentation' dialog, use one of the
methods outlined here.

Ribbon Publish > Model Reports > Report
Builder > Generate Documentation >
Element Filters

Keyboard
Shortcuts

F8 | Element Filters

Access -  Template Editor 'Document
Options' dialog

Display the Document Template editor window, select a
template, then display the 'Document Options' dialog and
finally select the 'Element Filters' page of that dialog.

To open the 'Document Options' dialog, use one of the
methods outlined here.

Ribbon Publish > Model Reports > Templates :
select a particular template >  (toolbar
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icon) > Element Filters

Review Element Filters

Column/Butt
on

Action

Search In Shows the type and name of each element
property field to search on.
Select the checkbox against a property
field to include it in the current search.

Condition Displays the condition of the search
parameter.
The possible values are Contains, Equal
To, Not Equals and One Of.

Look For Displays the search term to perform the
conditional search on.
This value is specific to the selected field;
for example, the value could be a date for
'DateCreated' or a text or numerical value
for other fields.
The search term can contain multiple
values, separated by commas.
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Required Indicates that the search results must
include elements with the search term in
that field; these checkboxes are set on the
'Add Filters' dialog.
When no 'Required' checkboxes are
selected, the fields listed as filters have an
OR relationship; that is, if the search term
is found in any one of those fields, then
the element is displayed.
Any field having the 'Required' checkbox
ticked overrides fields where the
'Required' checkbox is not ticked.

Element
Features
- Optional
- Required

Specify whether element features are
optional or required; these appear as a
new branch underneath the root element
term in the 'Search In' column.
If you scroll down the 'Search In' column,
you might see sub-branches such as
Attribute, Change and Custom Property;
these are the element features. You can
add these features using the 'Add Filters'
dialog.
Select the:

'Optional' radio button to generate a list·

of elements that have one of the
element features (Element Type =
Object), or one of the feature filters
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(Attribute Name = Att1); for example,
if your search is:
     Element Name = Class11, Attribute
Name = m_Att1 or Scope = Public
the search results list all the elements
that have the name of Class11 and all
the elements that have an Attribute
Name of m_Att1 or a Scope of Public
Required radio button to generate a list·

of elements that must have the element
features; for example, if your search is:
     Element Name = Class, Attribute
Name = m_Att1 or Scope = Public
you would get elements that must have
the name of Class AND have an
attribute with a name of m_att1 OR a
Scope of Public

Import
Search

Click on this button and select to import
the filters defined within a search, from
either:

An external XML file exported from·

another project, located on a browser
dialog, or
A list of the standard and custom·

Model Searches within your
installation of Enterprise Architect

Add Filter Click on this button to display the 'Add
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Filters' dialog, to add a new set of
parameters to filter the search on.

Edit Filter Click on this button to display the 'Edit
Filters' dialog, to change the search
parameters.

Remove
Filter

Click on this button to immediately
remove the selected filter from the
search.

Notes

Check that the values you provide for the 'Look for' fields·

are exactly what is contained in the element data fields to
be searched; for example, the Unit, Integration, System,
Acceptance, Scenario and Inspection TestClasses are
represented by attribute values 1 - 6, not by their
respective tab names

Filters set in a template operate only on that template, and·

do not operate on subtemplates and template fragments
inserted into the template; to filter the subtemplates, set
the filter within each one
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Other Filters

As you specify the output of your report, you might want to
include only specific features of elements (sub-element
components such as attributes, responsibilities or
constraints). If the feature does not have the defined
characteristics, it is not reported for the element. Using the
'Other Filters' tab, you can define which features to report
on, and which fields and field values. You can also delete
the filters if you no longer want to apply them.

The 'Other Filters' tab is provided in two different ways, as a
tab of:

The 'Generate Documentation' dialog, to set filters for a·

specific instance of a report; the filters are reset when you
exit the dialog or select a different template

The 'Document Options' dialog, to set filters in a template·

as the default settings to be applied to every report
generated using that template; these settings can be
overridden by the 'specific instance' settings on the
'Generate Documentation' dialog

The options and behavior are the same for both dialogs.

Access -  'Generate Documentation' dialog

Display the 'Generate Documentation' dialog, then select the
'Other Filters' page.

To open the 'Generate Documentation' dialog, use one of the

(c) Sparx Systems 2021 Page  69 of 416



Document Reports 2 September, 2021

methods outlined here.

Ribbon Publish > Model Reports > Report
Builder > Generate Documentation >
Other Filters

Keyboard
Shortcuts

F8 | Other Filters

Access -  Template Editor 'Document
Options' dialog

Display the Document Template editor window, select a
template, then display the 'Document Options' dialog and
finally select the 'Other Filters' tab of that dialog.

To open the 'Document Options' dialog, use one of the
methods outlined here.

Ribbon Publish > Model Reports > Templates :
select a particular template >  (toolbar
icon) > Other Filters

Manage Other Filters
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Column/Butt
on

Action

Search In Shows the type and name of each element
feature field to search on.
Select the checkbox against a field to
include it in the current search.

Condition Displays the condition of the search
parameter.
The possible values are Contains, Equal
To, Not Equals and One Of.

Look For Displays the search term to perform the
conditional search on.
This value is specific to the selected field;
for example, the value could be a date for
'DateCreated' or a text value for other
fields.
The search term can contain multiple
values, separated by commas.

Required Indicates that the search results must
include element features with the search
term in that field; these checkboxes are
set on the 'Add Filters' dialog.
When no 'Required' checkboxes are
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selected, the fields listed as filters have an
OR relationship; that is, if the search term
is found in any one of those fields, then
the element is displayed.
Any field having the 'Required' checkbox
ticked overrides fields where the
'Required' checkbox is not ticked.

Add Filter Click on this button to display the 'Add
Filters' dialog, to add a new set of
parameters to filter the search on.

Edit Filter Click on this button to display the 'Edit
Filters' dialog, to change the search
parameters.

Remove
Filter

Click on this button to remove the
selected filter from the search.

Notes

Filters set in a template operate only on that template, and·

do not operate on subtemplates and template fragments
inserted into the template; to filter the subtemplates, set
the filter within each one
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Project Constants

As you develop your report, you can incorporate flags that
represent project-wide terms and values. The flags - or
Project Constants - are replaced with the actual text during
document compilation. Using this facility, you can use a
particular text string or number extensively throughout your
project documentation, whilst maintaining the value in a
single location. You define Project Constants on the
'Generate Documentation' dialog; they are then available to
be inserted into all custom document report templates in the
text, section headers, end-notes, page headers or page
footers, using the 'Document Template Designer' context
menu.

Access

Ribbon Publish > Model Reports > Report
Builder > Generate Documentation >
Project Constants

Keyboard
Shortcuts

F8 | Project Constants

(c) Sparx Systems 2021 Page  74 of 416



Document Reports 2 September, 2021

Manage Project Constants

Field/Button Action

Add Click on this button to add a new Project
Constant to the list.
A prompt displays for the name and
value; type these in and click on the OK
button.

Delete Click on this button to remove the
selected Project Constant from the list.
A prompt displays to confirm the
deletion; click on the OK button to
complete the task..

Import Click on this button to import a set of
fields from an external XML file.
A browser displays to select the source
file and location.

Export Click on this button to export all fields to
an external XML file.
A browser displays to specify the target
file and location.
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Word Substitution

In generating document reports, you will call in many
English technical terms that are used across the system, in
particular field names. It is possible to replace these field
names in your generated documents with other terms that
might be more meaningful to the readers, such as a
translation of each term into your own language.

Access

Ribbon Publish > Model Reports > Report
Builder > Generate Documentation >
Word Substitution

Keyboard
Shortcuts

F8 | Word Substitution

Add a translation for a term

Ste
p

Action
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1 Double-click on the term in the 'English' column; the
'Enter Value' field displays.

2 Type the substitute text in the 'Enter Value' field, and
click on the OK button.
The text displays in the 'Substitute' column, against
the English term. This substitute will display in your
generated reports in place of the English term.

Notes

To put the word substitutions into effect in a generated·

report, select the 'Language Substitution' checkbox on the
'Generate' tab
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Language Substitution

If you want to generate and export document reports from
Enterprise Architect in languages or dialects other than US
English, you can customize the codepage, default language
ID and character set that the system uses when generating
the documentation. This makes it much easier to generate
documentation appropriate to your country or location.

Access

Ribbon Publish > Model Reports > Report
Builder > Generate Documentation >
Codepage

Keyboard
Shortcuts

F8 | Codepage

Notes

If you want to generate reports in a language that requires·

Unicode support, please note that Enterprise Architect
.eap files default to using JET 3.5 as the database engine,
which does not support Unicode character sets (see the
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Startup topic); to provide Unicode support in your project,
either upsize to a DBMS repository or set JET 4.0 as the
database engine, and download a copy of the Jet 4.0
EABase model from the Sparx Systems website and do an
EAP to EAP transfer of your model into the Jet 4.0 file

The codes that you select remain set for all reports you·

generate, until such time as you specifically change them
again

You can transport these language tag definitions between·

models, using the 'Configure > Model > Transfer > Export
Reference Data' and 'Import Reference Data' ribbon
options

Set Reporting Language

Field/Button Action

Language Click on the drop-down arrow and
select the language code appropriate to
the language you want to generate reports
in.

Codepage Click on the drop-down arrow and
select the codepage appropriate to the
language you want to generate reports in.

Charset Click on the drop-down arrow and
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select the character set appropriate to the
language you want to generate reports in.

English Tag Lists the default US English language
code tags within Enterprise Architect.

Substitute
Tag

(For advanced use only.) If you want to
apply a different language code tag in
place of a US English tag, double-click
on the item line. A prompt displays for
the substitute tag code; type in the code
and click on the OK button.
To clear a substitute tag, double-click on
the item and delete the code value.
When you generate your document
reports, the substitute tags are used in the
output.
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Diagram Options

When generating reports on a Package that includes
diagrams, you can set options in each diagram's 'Properties'
dialog to define whether that diagram is to be included in
the report and, if so, how it is to be represented.

Access

Ribbon Design > Diagram > Manage > Properties
> Diagram

Context
Menu

Right-click on diagram background |
Properties > Diagram

Document Options

Option Action

Exclude
Image from
RTF
Documents

Select this checkbox to exclude the image
of this diagram from any document
reports.
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Document
Each
Contained
Element in
RTF

Select this checkbox to include, in the
report, details of any elements that belong
in other (external) Packages but that form
part of this diagram within the Package
being reported on; the report includes
external elements in each diagram on
which you have selected the checkbox.
On the 'Generate Documentation' dialog,
the 'Include all Diagram Elements in
Report' checkbox defaults to selected to
include external elements for every
diagram checked by the report; therefore,
to include external elements only for
specific diagrams, deselect that checkbox.
In either case, you must enable the
Package.Diagram.Element and
Package.Element sections in your
(customized) document generation
templates in order to include this external
element information in the report.

Divide
Diagram Into
Multiple
Pages

If the diagram is large, select this
checkbox to divide the diagram into
separate pages in the document report.
This option is only effective when the
'Scaled Printing' option on the 'Print
Advanced' dialog is set to 'None'.
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Rotate
Images

Select this checkbox to rotate each
diagram image by 90 degrees in the
document report; this is only valid for
bitmap (.bmp) images.

(c) Sparx Systems 2021 Page  84 of 416



Document Reports 2 September, 2021

Resource Documents

When you set the parameters on the 'Generate
Documentation' dialog to define an output document as you
need it, you might want to re-use that configuration to
obtain a consistent view of changes to your model over
time. You can capture the configuration as a Resource
Document, which saves the:

Package name·

Output file destination and extension (which determines·

the output format)

Template·

Options page settings·

Exclude Filters·

Element Filters and·

Other Filters·

The document is saved into the Document Publishing >
Report Library folder of the 'Resources' tab of the Browser
window. Saving your often-used report configurations as
Resource Documents can simplify future document
generation, both in producing specific documents and in
batch-generating all documents or a selection of documents.

Access

To save the current settings as a Resource Document:
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Ribbon Publish > Model Reports > Report
Builder > Generate Documentation >
Generate : Resource Document

Keyboard
Shortcuts

F8 > Generate : Resource Document

Access

To load a Resource Document and use the settings it has
saved;

Ribbon Start > Desktop > Share > Resources >
Document Publishing > Report Library >
Right-click on a document > Generate
Document

Keyboard
Shortcuts

Alt+6 | Document Publishing | Report
Library | Right-click on a document |
Generate Document

Manage Resource Documents
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Task Action

Create a
Resource
Document

On the 'Generate Documentation' dialog,
click on the Resource Document button
and, in the 'Enter Value' field, type a
name for the document.
Click on the OK button. The document
is added to the Document Publishing >
Report Library folder in the 'Resources'
tab of the Browser window for easy
future access.

Open,
Generate or
Delete
Documents

In the 'Resources' tab of the Browser
window, expand the Document
Publishing > Report Library folder (and,
if necessary, the appropriate Document
Group subfolder) and right-click on the
required document.
Select the appropriate context menu
option:

'Edit Name' - Open the 'Edit Item'·

dialog and type over the current name
to correct or change it; click on the OK
button to save the change
'Open Document' - Open the·

corresponding .document file, as
specified by the document template
'Filename' property
'Generate Document' - Open the·
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'Generate Documentation' dialog,
loaded with the specified template
'Auto Generate Document' - Generate·

documentation, with the document
located at the path specified by the
template's 'Filename' property
'Delete Document' - Remove the·

specified document

Batch-genera
te a number
of documents

Right-click on the Report Library folder
name and select the 'Generate
Documents' option; the 'Batch Document
Generation' dialog displays.
The dialog lists all resource documents in
the Report Library folder, whether or not
they are contained in Document Groups.
All the documents default to selected;
deselect the checkbox against each
document that you do not want to
generate (or click on the Deselect All
button to clear all selections, then select
those you require).
Click on the OK button to generate each
of the remaining reports into their
respective target file locations.
Alternatively, to automatically generate
every document in the Report Library
folder (again, whether or not they are in
Document Groups), without displaying

(c) Sparx Systems 2021 Page  88 of 416



Document Reports 2 September, 2021

the 'Batch Document Generation' dialog,
click on the 'Generate All Documents'
context menu option.

Manage Resource Document Groups

As you create more Resource Documents, you might find it
convenient to group them by category, such as model area
or purpose. This helps you locate the required document
quickly, and also refines the facility of generating multiple
documents either through quick manual selection from the
group or by generating the whole group automatically.

Task Action

Create a
Document
Group

In the 'Resources' tab of the Browser
window, within the Document Publishing
folder, right-click on the Report Library
subfolder and select the 'New Generation
Group' option. The 'Enter generation
group name' dialog displays, in which
you type the name of the Document
Group. Click on the OK button to create
the group.
You can subsequently change the group
name by right-clicking on it and selecting
the 'Edit Name' option, and then
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overtyping the name in the 'Edit item'
dialog.

Add
Resource
Documents
to Group

To add a Resource document to a
Document Group, simply drag it from its
current location (in another group or
under the Report Library subfolder) into
the required group.

Delete
Document
Group

To delete a Document Group and all the
Resource documents it contains,
right-click on the group name and select
the 'Delete Document Group' option. A
warning message displays; if you want to
continue and delete the group and
documents, click on the OK button.

Generate
selected
Documents
from the
Group

To generate some - but not necessarily all
- of the Resource Documents in the
group, right-click on the group name and
select the 'Generate Documents' option.
The 'Batch Document Generation' dialog
displays, with all documents in the group
selected.
Deselect the checkbox against each
document that you do not want to
generate (or click on the Deselect All
button and reselect the checkboxes
against the documents to generate). Click
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on the OK button to generate the
selected documents to their defined target
files, and to close the dialog.

Generate all
Documents
in the Group

To generate all the Resource Documents
in the group as a batch, right-click on the
group name and select the 'Generate All
Documents' option. The system
immediately starts to generate the
documents in sequence.
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Exclude Package from Document and
HTML Report

When documentation is generated for a selected Package, all
child Packages of the selected Package are by default
included in the documentation. It is quite common to want
to exclude one or more Packages in this hierarchy from the
report, and this can be achieved by marking the Packages
for exclusion. When a Package is marked for exclusion, all
its child Packages are also excluded from the report. In this
way you can customize the content of a report, ensuring that
only the relevant information is included. The excluded
Packages will be omitted from any document and/or HTML
report generated from the same Package hierarchy.

Access

Ribbon Design > Model > Manage > Report
Options

Mark a Package to be excluded from
reporting
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Ste
p

Action

1 On the 'Generated Report Options' dialog, select the
'Exclude Package from Generated Reports' radio
button.
(Select the 'Include Package in Generated Reports'
radio button to add the Packages to the reports
again.)

2 Click on the OK button.
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System Documents

As well as tailoring the output generated from standard or
custom report templates, you can generate a number of
pre-set reports that are each provided to meet a specific
modeling requirement.

Pre-set Reports

Report

Testing Details report - extracts the test details for all
elements in the selected Package hierarchy that have test
items lodged against them.

Implementation Details Report - lists, for a specified
Package, the elements that require implementation,
together with any source elements in Realize
(Implements) relationships with those elements.

Dependency Details Report - shows a list of any elements
that are dependent on (having a Dependency connector
to) another element for their specification.

Maintenance Report - extracts the maintenance details for
all elements in the selected Package hierarchy that have
maintenance items lodged against them.
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Diagram Report - lists only the diagrams from the target
Package.

Resource Report - shows how your resources are
deployed in your project, displaying a list of all elements
that have resources allocated to them.

Testing Report - outputs the test scripts and results you
have entered against elements in the model.
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Testing Details Report

As you manage the test program for your model, you can
monitor the status of tests run on the elements within a
Package hierarchy by generating a Testing Details report on
the Package. You can filter the report to show tests of a
certain type, having a specific status, run by a specific
person and/or checked by a specific person.

When you select an item line in the Testing Details report,
the notes and properties for that item are displayed in full in
the docked Notes window and Properties window.

Access

Ribbon Construct > Project Management > QA >
QA Reports > Testing Details

Generate a Testing Details report

Field/Button Action

Root Package Displays the name of the Package
selected from the Browser window. All
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elements and Packages under this
Package are included in the report.
If you want to change the Package, click
on the new Package in the Browser
window and then click on the  icon at
the end of the field. The replacement
Package name displays in the field.

Run By Click on the drop-down arrow and
select a name to filter for tests run by that
person. Click on the x button to clear the
field. (Values are derived from the
Project Author definitions in the 'People'
dialog - 'Configure > Reference Data >
Model Types > People > Project
Authors'.)

Checked By Click on the drop-down arrow and
select a name to filter for tests checked by
that person. Click on the x button to clear
the field.

Test Type Select the radio button for the required
test class - Unit, Integration, System,
Scenario, Inspection, Acceptance, or All
types.

Status Select the radio button for the required
test status - Passed, Failed, Not Run, or
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All statuses.

Refresh Click on this button to re-run the report
query on the Package currently selected
in the 'Root Package' field.

Print Click on this button to print a summary of
the test results.

Notes

The Testing Details report provides a summary of the test·

status and who ran and checked the test; the Testing report
is an alternative option, providing a detailed description of
how each test executed, what the input and acceptance
criteria were, and what the results were

You can restructure the output of the report using the List·

Header facilities for reported information
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Implementation Details Report

Using the Implementation report, you can list all elements in
a Package (selected from the Browser window) that require
implementors, together with any source elements that are in
Realization (or Implements) relationships with those
elements.

Access

Ribbon Construct > Project Management > QA >
QA Reports > Implementation Details

Generate Implementation report

Field/Button Action

Root Package Displays the name of the root Package;
all elements and Packages under this
Package are included in the report.
If you want to change the Package, click
on the replacement in the Browser
window and click on the Refresh List
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button.

Set Target
Types

By default the Implementation report
includes only a limited number of
element types, such as Use Cases and
Requirements.
If you want to include other element
types, click on this button and select the
additional types on the 'Implementation
Targets' dialog.

Refresh List Click on this button to run the report and
display the results in the 'Details' panel.

Locate
Object

Click on this button to locate the selected
implemented (or realized) element in the
Browser window.

Show
Unimplement
ed

Select this checkbox to list all elements in
the Package that can be implemented but
currently don't have any other element to
realize them (for example, a Use Case
that has no Component or Class to
implement the Use Case behavior).

Show
Implemented

Select this checkbox to list all elements in
the Package that are implemented; that is,
they have another element associated
with them in a Realize relationship (for
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example, a Use Case that is implemented
by a Component).

Details
Option

Lists the implementation details,
consisting of:

The names of the elements in the·

current Package that can be
implemented
The type of the elements that can be·

implemented
The type of the relationship on the·

elements (Realization)
The name of any element that the·

element is implemented by
The type of the implementor element·

Print Click on this button to print the
Implementation report.

Save Report Click on this button to specify the file
location into which to save the
Implementation report. A prompt displays
for the file path and name.
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Implementation Targets Dialog

When you generate an Implementation report, by default it
includes only certain element types, such as Use Cases and
Requirements. If you want to include other element types,
you can add them to the report parameters using the
'Implementation Targets' dialog.

Access

Ribbon Construct > Project Management > QA >
QA Reports > Implementation Details :
Set Target Types

Include other element types in report

Field/Button Action

Targets -
Active

Lists the types of element that the
Implementation report includes.
If you do not want to include a type of
element in your report, double-click on it
to remove it from the list. The element
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type is then displayed in the 'Targets -
Available' list.

Targets -
Available

Lists the types of element that could be
included in the report but are currently
not.
If you want to include any of these types
of element in your report, double-click on
each one to transfer it to the 'Targets -
Active' list.

Close Click on this button to close the
'Implementation Targets' dialog and
immediately refresh the Implementation
report with details on the additional
element types.
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Dependency Details Report

Using the Dependency report, you can list all elements in a
Package (selected from the Browser window) that are
dependent on another element for their specification. For
example, a Use Case derives its specification from the
Requirement that it realizes. On the report, each of the
elements in the first column is the source or dependent in a
Dependency relationship with the corresponding target
element in the Dependent on column.

Access

Ribbon Construct > Project Management > QA >
QA Reports > Dependency Details

Run the Dependency report

Field Action

Root Package Displays the name of the root Package;
all elements and Packages under this
Package are included in the report.
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If you want to change the Package, click
on the replacement Package in the
Browser window and click on the
Refresh button.

Refresh Click on this button to run the report.

Locate
Object

Click on an element name in the report
and click on this button to locate the
element in the Browser window.

Print Click on this button to print the
dependency details.

Save Report Click on this button to save the report as
a file. A small dialog displays in which
you specify the file location to save the
report to.

Details
Option

Lists the dependency details, consisting
of:

The names of the elements in the·

current Package that have a
dependency
The type of the elements that have a·

dependency
The relationship type·

The names of the elements that they are·
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dependent on
The type of the elements that they are·

dependent on
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Maintenance Report

As you manage the maintenance items against elements in
your model, you can monitor the status of reported features,
changes, documents, issues, defects and tasks by generating
a Maintenance report on the Package. You can filter the
report to show maintenance items of a certain type, having a
specific status, reported by a specific person and/or resolved
by a specific person.

When you select an item line in the Maintenance report, the
notes and properties for that item are displayed in full in the
docked Notes window and Properties window.

Access

Ribbon Construct > Project Management > QA >
QA Reports > Maintenance Details

Generate a Maintenance report

Field/Button Action

Root Package Displays the name of the Package
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selected from the Browser window. All
elements and Packages under this
Package are included in the report.
If you want to change the Package, click
on the new Package in the Browser
window and then click on the  icon at
the end of the field. The replacement
Package name displays in the field.

Reported By Click on the drop-down arrow and
select a name to filter for maintenance
items reported by that person. Click on
the x button to clear the field.

Resolved By Click on the drop-down arrow and
select a name to filter for maintenance
items resolved by that person. Click on
the x button to clear the field.

Maintenance
Type

Select the radio button for the required
item type - Features, Changes,
Documents, Issues, Defects, Tasks or All
types.

Status Select the radio button for the required
item status - New, Verified, Complete or
All statuses.

Locate (After clicking on an item in the Item
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Object Details list.) Click on this button to
highlight the element containing the
maintenance item, in the Browser
window.

Refresh Click on this button to re-run the report
query on the Package currently selected
in the 'Root Package' field.

Print Click on this button to print a summary of
the item maintenance list.

Notes

If you want to edit an item from the report, double-click·

on the item line; the Maintenance window displays, on
which you can update the details

You can re-organize the display of the listed items using·

the List Header facilities for reported information
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Diagram Report

If you want to report on the diagrams in a Package, and only
the diagrams, you can generate a Diagram Report. This is
convenient for printing or handling a lot of diagrams in
batch, rather than exporting or printing each diagram at a
time.

Access

Ribbon Publish > Model Reports > Report
Builder > Simple Diagram Report

Keyboard
Shortcuts

Ctrl+Shift+F8

Produce a Diagram Report

You generate the Diagram Report using a default version of
the 'Generate Documentation' dialog. This dialog will have
been configured with any global settings your organization
might require, so you are likely to only need to pay attention
to the fields described in this table before generating the
report.
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Field/Button Action

Output to
File

Type in or browse for the output location
and file name to create the report in.
Provide the appropriate file extension to
set the document format for the report -
.rtf, .pdf or .docx.

Template Defaults to the required Diagram Report
template.

Generate Click on this button to run the report.

View When the report is generated, click on
this button to display the output
document.
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Testing Report

As you develop the testing environment for your model, you
create and execute test scripts for the elements in the model.
To help you track the status and results of running the
scripts, you can generate a Testing report on a Package
selected from the Browser window. This report can deal
with just the selected Package, or the complete hierarchy of
the Package. You can also report on scripts for specific
types of test, or for all types of test.

Access

Ribbon Construct > Testing > Outcomes >
Report

Generate a Testing Report

Field/Button Action

Root Package Displays the selected Package name.
If you want to run the report on a
different Package, close the 'Generate
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Test Documentation' dialog, select the
replacement Package in the Browser
window, and open the dialog again.

Report on Deselect the checkbox against each type
of test to omit from the report. All
checkboxes default to selected.

Include Child
Packages

Leave the checkbox selected to report on
tests on elements in the subordinate
Packages.
Deselect the checkbox to report just on
the root Package.

Output file Type in or browse for the file name and
path into which to generate the Testing
report.

Generate Click on this button to generate the
report.
A message displays when the report has
been generated. You can then open the
file in your preferred file viewer.

Notes
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In your file viewer settings, set the page layout to·

'Landscape' to display the columns of the report clearly

The Testing report provides a detailed description of how·

each test executed, what the input and acceptance criteria
were, and what the results were; the Testing Details report
is an alternative option, showing a summary of the test
status and who ran and checked the test
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Document Templates

You use report templates to generate reports on your model
that present specific information in a particular format, and
to generate those reports repeatedly and consistently. You
can select from a range of system templates on the
Document Generator, to immediately generate reports
from your model.

A template consists of:

'Sections' that identify the model components to report on·

Fields that identify the type of information to extract on·

each component

Styles and formatting instructions that define the layout of·

the report

Template Fragments containing smaller sub-templates·

The system provides more specialized document templates
for separate Cover Pages, Stylesheets and Tables of
Contents.

You can also design your own custom templates, which
provide the additional advantages of being able to generate
reports tailored to your own organization, and to update
certain aspects of the report without having to re-define
every other specification. The report generator helps you
manage these custom templates; that is:

Review the custom templates available to you for·

generating reports

Create additional custom templates·
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Edit custom templates·

Import templates that were saved to XML files, and·

Delete any custom templates that are no longer required·

Access

Ribbon Publish > Model Reports > Templates

Keyboard
Shortcuts

F8 | Templates

Manage your Custom Templates

Field/Button Description

Custom
Templates

Lists the custom Templates, Fragments,
Stylesheets, Cover Pages and Tables of
Contents currently available to you for
generating reports through the 'Generate'
tab.
Your custom templates can be grouped
within these standard folders (by
Template Type), or in another folder that
you have created to hold specific
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templates.

New To create a new custom template, click
on this button. The 'New Document
Template' dialog displays.
In the 'New template' field, type the
template name.
In the 'Template Type' field, click on the
drop-down arrow and select the type of
template to create.
In the 'Copy Template' field, click on the
drop down arrow and select either:

'None', to create an empty template to·

develop from scratch, or
The name of an existing system,·

Technology or custom template to act
as a base; this list is filtered to show
templates of the type you specified in
the 'Template Type' field

In the 'Template Group' field either:
Select an existing group or·

Enter the name for a new template·

group, or
Leave this field blank, to place the·

template in the appropriate standard
type group

The 'Template Group' determines the
organization of document templates in
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the 'Resources' tab of the Browser
window. You cannot create a template of
a specific type and assign it to the
standard group of a different type. For
example, you cannot specify a Fragment
and select to save it in the Cover Page
folder. It either goes to a user-created
group that you select or is automatically
redirected to the Fragment folder.
Click on the OK button; the template
opens in the 'Document Template
Designer'.

Edit To make changes to an existing template,
click on the template name and then click
on this button.
The template opens in the 'Document
Template Designer'.

Import From
Reference
File

To import custom templates that were
previously saved to batch XML files (that
is, through the 'Export Reference Data'
option), click on this button. The 'Import
Reference Data' dialog displays.
Click on the Select File button and
browse for and select the required source
XML file.
In the 'Select Datasets to Import' panel,
click on the required datasets:
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RTF Document Templates·

Templates - RTF Style Detail·

Templates - RTF Tag & Language·

Options
Click on the Import button to import the
templates. The names of the imported
templates are added to the list on the
'Templates' tab.
If the template you want to import is a
single, external file (not in a batch file)
you can instead open a template and use a
different option to import the file into that
template.

Delete To delete a custom template, click on the
template name and click on the Delete
button.
A prompt displays to confirm the
deletion.
You can select multiple custom templates
for deletion; press Ctrl or Shift as you
click on each template name.

Notes

In the Corporate, Unified and Ultimate Editions of·
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Enterprise Architect, if security is switched on, you need
'Configure Resources' access permission to create
document templates

Whatever template you initially select on the 'Template'·

tab or 'New Document Template' dialog, of whichever
template type and/or group, you can easily switch to a
different template and template type within the 'Document
Template Editor' whenever you need to
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Design Custom Document Templates

If you want to record and document details of your model,
you can do so using a range of document reports, each
generated using a document template. To meet your specific
requirements, it is possible to customize the reports by
developing your own templates; during this process you also
have the option of generating test reports to review the
output from your design as you develop it. The custom
templates you can develop include full-document templates
and independent Stylesheets, Cover Pages and Tables of
Contents.

You create and edit report templates using the Document
Template Designer to define:

The model components to report on·

The information to extract on each component and·

The styles and layout of the report·

It is possible to create a template from scratch or by copying
and editing either another custom template or a system
template. If you want to review the system templates you
can list and display them using the Document Template
Designer, and establish what templates already exist to
either extract the information you require, or act as a starting
point for your own design.

Access
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When you open a template in the Document Template
Designer, the Document - Edit ribbon also opens
automatically.

Ribbon Publish > Model Reports > Templates

Other 'Resources' tab of the Browser window |
Document Publishing | System Templates
| <template group> : right-click on a
template | Copy
'Resources' tab of the Browser window |
Document Publishing | Custom
Templates | <template group> :
right-click on a template | Open

The Document Template Designer

The Document Template Designer consists of:

A Toolbar, through which you create or select a template·

to work on, save your work, and generate and view the
test reports

A 'Sections' panel, on which you select the components of·

the model to report on

A 'Content' panel, in which you develop the content and·

layout of the report, using an extensive range of context
menu options
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Toolbar Options

Icon Action

Creates a new template.
A prompt displays for you to enter the
name of the new template and, optionally,
the name of an existing template to use as
a base.

Saves changes to the current template.

Saves the current template as a new
template.
A prompt displays for the new template
name.

Displays a range of document options
that you can set to apply to all reports
generated using the template. These
options filter and organize the
information presented in the report.

Opens the 'Resources' tab of the Browser
window and/or folder containing the
currently-displayed document template,
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and highlights the template name.

Toggles the Document Generator view
between showing the Sections hierarchy
panel and hiding it.

Displays the Template Group name in
which to locate or save the template;
defaults to 'Model Templates'.
Click on the drop-down arrow and
select the appropriate Template Group
name to search in. This filters the options
in the next field to templates within that
group only. For example, Cover Pages, or
'DavidG Reports'.

Displays a list of the templates in the
Template Group you specified in the
previous field. To view or edit an existing
template, click on the drop-down arrow
and select the template name.

The system templates are protected;·

when you select one all editing options
are grayed out
Custom templates are available to edit·

Displays the path and name of the file
into which to generate the test report from
the template.
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If no file path is shown, you can either
type one in or use the  button.

Displays the 'Browser' dialog, in which
you can locate and select the file to hold
the generated test report.

Generates and displays the test report
based on the template.
To generate a test report, you need to
specify a target file and select a Package,
diagram or element in the Browser
window to run the report on. You could
develop a special test Package for this
purpose.

Displays the report held in the file
specified in the file path field.
You can return to a generated report
many times whilst you review the effects
of different sections of the template you
are editing.

The Sections and Content Panels

Facility Description
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Sections
Panel

Consists of a hierarchy of model
components and their properties, each
with a checkbox. To include information
on a type of component in the report, you
select the checkbox against it.
As you select checkboxes, corresponding
pairs of open/close markers display in the
'Content' panel; for example:
Sections Panel

  
Content Panel

  

Content
Panel

The editing area, in which you develop
the structure and content of the template.
As you add section markers to the
template, text containing hints is
automatically added to provide guidance
between the markers, such as:

Replace the hint text with a range of
fields (that extract information from your
model) and static text that is manually
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entered.

Editing the
template

Most of the work you do in creating and
updating a document template is
accomplished using the facilities of the
'Document - Edit' ribbon, which is
automatically displayed when you open
the Document Template Designer. For
guidance in using these facilities, you can
refer to either:

Document - Edit Ribbon, which·

describes the facilities directly, or
Editing Documents and Templates,·

which describes the document editing
facilities across Enterprise Architect
Custom Template Design Options,·

which identifies editing tasks you
might want to perform and directs you
to the facilities for performing those
tasks

Content
Panel
Context
Menu

If you right-click on the field marker text
or background of the 'Content' panel a
context menu displays, providing a
number of additional options to:

Insert a field selected from the·

displayed list, where the entries are
specific to the section marker you have
selected - you must also delete the text
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prompt between the section markers;
when the report is generated, the field
names are replaced by the
corresponding values from the model
Insert a Project Constant selected from·

those you have defined in the 'Project
Constants' tab of the 'Generate
Documentation' dialog
Insert a Report Constant selected from·

the standard list; these constants derive
values from the element and Package
properties
Update the style sheet used in the·

template to one of those listed in the
submenu, either system-supplied or
user-customized; alternatively, switch
from a tailored style sheet back to the
standard Normal.rtf style sheet
Hide or show the 'Sections' panel,·

either providing guidance on what
sections to add, or giving more space in
which to develop the content of the
report
Cut or copy selected text, and paste text·

held in the clipboard into a new
position
Undo a change - or a series of changes·

- that you have made, in reverse
sequence, or redo undone changes as
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necessary

Notes

A standard file of global document styles, called·

Normal.rtf, is automatically applied to all new templates
you create from scratch; it is possible to edit Normal.rtf to
tailor the styles to your requirements, and to override
these styles within the template

You can also create special customized Tables of·

Contents and Cover Pages to be used optionally on any
document report in place of any Cover Pages or Tables of
Contents built into the report templates, and Stylesheets
that can be chosen to override the Normal.rtf styles or any
edited styles in a report template

You can transport templates between models, using the·

'Configure > Model > Transfer > Export Reference Data'
and 'Import Reference Data' ribbon options
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Setting Sections for Reporting

As part of designing or editing a template for generating a
document report, you define the content to deliver in your
report, specifically:

Which model features to report on (such as elements,·

attributes, Linked Documents and Tagged Values), using
the 'Sections' panel of the Document Template Designer

What information to provide on the instances of each·

feature (such as the name, type, phase, priority or author),
using the 'Content' panel of the Document Template
Designer

The information you define here determines the structure of
the report, what sections it contains and the order of those
sections.

Access

Ribbon Publish > Model Reports > Templates >
Sections
Publish > Model Reports > Templates >
Content

Other 'Resources' tab of the Browser window |
Document Publishing | Custom
Templates | <template type> : right-click
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on a template | Open > Sections
'Resources' tab of the Browser window |
Document Publishing | Custom
Templates | <template type> : right-click
on a template | Open > Content

Select model components to be documented
in the report

Ste
p

Action

1 Expand some or all of the hierarchy in the 'Sections'
panel.

2 Select the checkbox next to the feature name; the
feature name is then displayed as a pair of section
tags in the 'Content' panel of the Document
Template Designer.
element >
< element
For features in the lower levels of the hierarchy,

(c) Sparx Systems 2021 Page 131 of 416



Document Reports 2 September, 2021

selecting a child feature automatically selects the
parent level(s) and adds the parent tags to the
'Content' panel.

3 If you want to change the sequence of sections, click
on the appropriate feature name in the 'Sections'
hierarchy and click on  or  to move the feature
name up or down.
The position of the feature name within the 'Sections'
hierarchy determines the position of the section
documenting that feature in the 'Content' panel, and
hence in the report. You can change the sequence
either before or after you have selected the
checkboxes, it makes no difference.

4 For each selected feature, click between the section
tags in the 'Content' panel and add text, or right-click
and select the 'Insert Fields' option to add fields.

Notes

More specific guidance is provided for selecting these·

features:
     -  Child objects
     -  Embedded elements
     -  Profiled Relationship Matrices
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     -  Constraints and Scenarios
     -  Linked Documents and Document Artifact contents
     -  Elements held in external Packages
     -  Tagged Values
     -  Sections formatted as tables
     -  Using the Custom section for Custom Query
Fragments
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Child Objects

An object in your model can have subordinate objects: for
example, elements have child diagrams and other elements;
Packages contain other Packages, elements and diagrams;
and diagrams contain elements and connectors. When you
set up your document report template to report on these
subordinate objects, you can:

Generate just the information you specify in selected·

fields, such as the object name only; for example, details
of elements could be extracted in a number of places -
Package elements, Embedded elements, source and target
elements on connectors, child elements - and you might
not require full details in all sections in your report, so
you would just set a field for the element name in some of
the sections

Alternatively

Generate the same type of information as is provided for·

the parent-level objects of that type, by not defining any
content (text or fields) between the section tags; for
example, you could generate recursive documentation of
child Packages, getting the same level of detail as for the
parent Package

Access
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Ribbon Publish > Model Reports > Templates >
Sections
Publish > Model Reports > Templates >
Content

Other 'Resources' tab of the Browser window |
Document Publishing | Custom
Templates | <template type> : right-click
on a template | Open > Sections
'Resources' tab of the Browser window |
Document Publishing | Custom
Templates | <template type> : right-click
on a template | Open > Content

Examples of reporting on child objects

Example Detail

Specific
object details

This template has valid content (text and
the 'Element.Name' field) between the
child element tags. Therefore, in the
generated report, the child element
section will show only the element name
and none of the detail shown for the
parent element.
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Default to
parent-level
detail

This template has no valid content
between the child element tags.
Therefore, in the generated report the
child element section will default to the
detail shown for the parent element.

Default
parent detail
for child
objects

Package > Element > Child Element -·

Package > Element
Package > Element > Diagram -·

Package > Diagram
Package > Diagram > Element -·

Package > Element
Package > Diagram > Connector -·

(c) Sparx Systems 2021 Page 136 of 416



Document Reports 2 September, 2021

Package > Element > Connector

Notes

In principle, it is better to leave Child sections blank to·

replicate their parent sections

Child sections do not contain the same sub-section detail
as their parents; Element::Child Element does not contain
sub-sections such as Scenario or Attribute, so where Child
Element sections are populated, these sub-sections are not
rendered

An exception to this is cases where sub-sections are not
required, but different formatting of the section fields is
preferred
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Report on Structural Elements

As part of your model, you might have created structural
elements on an element, such as:

ActivityParameter·

RequiredInterface·

ActionPin·

Port·

EntryPoint·

ExpansionNode·

ObjectNode·

ProvidedInterface·

ExitPoint·

Part·

When you design a document report template, you can add a
section to specifically identify and report on these structural
elements.

Access

Ribbon Publish > Model Reports > Templates >
Sections

Other 'Resources' tab of the Browser window |
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Document Publishing | Custom
Templates | <template type> : right-click
on a template | Open > Sections

Add section to report on structural elements
on an element

Action Detail

Add section Select the 'Package > Element >
Embedded Elements' checkbox. The
embedded elements section markers are
added to the template:
     embedded elements >
     <embedded elements
When the report is generated from the
template, any structural elements are
listed with their parent element.

Notes

The 'Embedded Elements' section does not contain the·
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same sub-sections as the parent 'Element' section, such as
Scenario or Attribute; if you do not define fields in the
'Embedded Elements' section, it defaults to displaying the
same detail as is in the 'Element' section, whereas if you
do add fields, only those field values are shown
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Reporting Profiled Relationship
Matrices

When you are using the Relationship Matrix, you search
on combinations of source and target Packages, element
types, connector type and connector direction. You can save
your frequently-used combinations as profiles, and you can
include the results of using these profiles in your document
report by setting up a section in the report template.

If you have set up matrix profiles directly within the
Relationship Matrix, you do not directly specify a matrix
profile in the report; the Document Generator returns the
Relationship Matrix for all profiles that include the
documented Package as the source or target Package.

You can have more direct control over which matrix profiles
are presented in a report, by creating a Matrix Specification
Artifact element that defines a profile and then reporting on
the Package that contains that Artifact. The profile defined
in the Artifact is independent of the Package that contains
the Artifact element, and therefore could specify source and
target Packages other than the parent Package. The
Document Generator can report on only one Matrix
Specification Artifact per Package, so if you want to include
more than one profile, place each Artifact element in a
separate subPackage of the target Package for the report.

Access
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Ribbon Publish > Model Reports > Templates >
Sections

Other 'Resources' tab of the Browser window |
Document Publishing | Custom
Templates | <template type> : right-click
on a template | Open > Sections

Add section to report on Relationship Matrix
contents

Action Detail

Add section Select the 'Package > Relationship
Matrix' checkbox; the relationship matrix
section markers are added to the
template.
Right-click between the markers and add
the 'Image' field to return the Relationship
Matrix in the report.
     relationship matrix >
     {Matrix.Image}
     < relationship matrix
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You can also insert a number of fields to
identify specific aspects of the profile,
such as relationship name, direction, type,
target element and element type, and
source element and element type.

Notes

You can view a list of the profiles created directly in the·

Relationship Matrix, in the Matrix Profiles folder of the
'Resources' tab of the Browser window

If a reported Package contains a Matrix Specification·

Artifact and is also part of a profile created directly in the
Relationship Matrix, the Artifact element takes
precedence and the report does not include the direct
Relationship Matrix profile

(c) Sparx Systems 2021 Page 143 of 416



Document Reports 2 September, 2021

Report on Constraints and Scenarios

In the Document Template Designer, you can create
sections to include information from your model on:

Constraints on Package Elements, Elements, Connectors·

and Attributes, and

Scenarios for Package Elements and Elements·

You can set additional options in the 'Constraints' and
'Scenarios' sections to define what types of constraint or
scenario are included in your reports.

Access

Ribbon Publish > Model Reports > Templates >
Sections

Other 'Resources' tab of the Browser window |
Document Publishing | Custom
Templates | <template type> : right-click
on a template | Open > Sections

Set sections to extract Constraint and
Scenario details
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Object Detail

Constraints In the 'Sections' panel, you can choose
any or all of these constraint option
checkboxes:

'Constraint-Pre' - to include all·

constraints of the type 'pre-condition' in
this section of the report
'Constraint-Post' - to include all·

constraints of the type 'post-condition'
in this section of the report
'Constraint' - to include all constraints·

that have not been generated in the
'Pre-Constraint' and 'Post-Constraint'
sections of the report

Set any fields you need, between the
section markers.

Scenarios In the 'Sections' panel, you can choose
any or all of these scenario option
checkboxes:

'Element > Scenario' - to include all·

scenarios in this section of the report; if
any of the subsequent sections are also
selected, the report includes all
scenarios that are not exception paths
'Element > Scenario > Exception' - to·
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include all exceptions for each scenario
'Element > Scenario > Structured·

Scenarios' - to include all scenario
steps in the scenario sections of the
report
'Element > Scenario > Structured·

Scenarios > Exception' - to include the
steps for each exception path in the
scenario sections of the report

Set any fields you need, between the
section markers.
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Reporting Linked Documents

If you have large quantities of information to provide on an
element or Package, you can attach it as a formatted
document either as the content of a Document Artifact
element associated with your subject element, or by
attaching the document file directly to the element
(depending on the edition of Enterprise Architect you are
using). In either case, you can include the Linked Document
contents in your document report by selecting one or more
of the 'Linked Document' checkboxes in the report template
definition.

Access

Ribbon Publish > Model Reports > Templates >
Sections

Other 'Resources' tab of the Browser window |
Document Publishing | Custom
Templates | <template type> : right-click
on a template | Open > Sections

Add sections to report on Linked Documents
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Action Detail

Add sections Select the checkboxes for the levels of
Linked Document you want to include in
the report:

'Package > Package Element > Linked·

Document'
'Package > Package Element > External·

Requirements > Linked Document'
'Package > Element > Linked·

Document' or
'Package > Element > External·

Requirements > Linked Document'
The Linked Document is rendered into
the document report between these
markers:
     linked document >
     <linked document

Notes

In some system templates that you might copy, the·

'Linked Document' checkbox is only available as a child
of the 'External Requirements' checkbox
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You do not need to add any fields between the Linked·

Document section markers
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Report Elements From External
Packages

Elements can be re-used in different diagrams across a
model, which can often mean that a diagram contains
'external' elements from Packages other than the diagram's
parent Package. Using the Document Template Designer,
you can create custom templates to generate reports showing
all elements used in a Package with 'internal' and 'external'
elements grouped separately, or only the elements actually
held within a Package. You can also select options to expose
the external elements from all diagrams in a Package, or
only from selected diagrams in the Package.

The separation of 'external' and 'internal' elements avoids
duplication of information and identifies the elements that
impact the Package but are not part of the Package structure.
Normally, you would report the same level of detail for each
internal and external element, but you can also define a
smaller group of details for the external elements, including
the name of the parent Package.

Access

Ribbon Publish > Model Reports > Templates >
Sections
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Other 'Resources' tab of the Browser window |
Document Publishing | Custom
Templates : right-click on a template |
Open > Sections

Add sections to include elements in
diagrams

Ste
p

Action

1 In the 'Sections' panel on the left-hand side of the
editor window, select the 'Package > Element'
checkbox.
Selecting the checkbox adds this set of sections to
the 'Content' panel of the template:

2 Delete the two [right-click-to...] texts and after the:
package> section marker, type 'Package Name:'·

then right-click and select the 'Insert Field | Name'
option
element> section marker, type 'Element Name:'·
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then right-click and select the 'Insert Field | Name'
option

The template now resembles this illustration:

3 In the 'Sections' panel, select the 'Package > Diagram
> Element' checkbox.
Selecting the checkbox extends the set of sections in
the 'Content' panel of the template:

4 Delete the two [right-click-to...] texts and after the:
diagram > section marker type 'Diagram:' then·

right-click and select the 'Insert Field | Name'
option

Delete the space between the element > section
markers. The template now resembles this
illustration:
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Because the 'Diagram > Element' section does not
contain any fields, the type of content of this section
in the generated report is determined by the 'Package
> Element' section.

Specify diagrams and generate report

Ste
p

Action

1 Select the appropriate option:
In the 'Properties' dialog for selected diagrams, the·

'Add each contained element in Documentation'
checkbox, to identify all the elements in those
diagrams in your report, or
On the 'Generate Documentation' dialog, the·

'Include all Diagram Elements in Report' checkbox
to include all elements in each and every diagram
checked by the report

2 In the Browser window, select the Package to report
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on, and execute the report through either:
The Document Template Designer, or·

The 'Generate Documentation' dialog·

3 The generated report for the example resembles this
output:

The report shows that the BlockFrame Package
contains 8 elements, but has links to three elements
from other Packages because those three elements
have been used in the BlockFrame diagram.

Notes

The illustrations in this description show the very simplest·

set-up, to achieve the result of identifying external
elements in a report; you can, if you prefer, populate the
report with other sections and fields, leaving the 'Diagram
> Element' section empty to duplicate the structure of the
'Package > Element' section
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If you do add fields to the 'Diagram > Element' section,·

the section will have its own structure and format and can
provide different element details; for example, selecting
the 'Insert Field | Name (Full)' menu option adds the
{Element.FullName} field, which identifies each external
element's parent Package

If you insert the 'Package > Diagram > Element' section·

but not the 'Package > Element' section, the subsequent
report will show just the elements used in each diagram,
without distinguishing between external and internal
elements

If you insert the 'Package > Element' section but not the·

'Package > Diagram > Element' section, the subsequent
report will show just the elements held in the Package
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Report on Tagged Values

Tagged Values are used extensively across the objects of
your model, including:

Package Elements·

Elements·

Connectors and their Source and Target elements·

Attributes·

Operations (Methods) and·

External Requirements·

When designing a template to report on these objects, you
can include information on their Tagged Values either:

As a group, using the 'Tagged Value' subsection to·

identify all Tagged Values used in the object, or

Individually, using the 'valueOf()' field to extract a·

specific value of a specific tag

Access

Ribbon Publish > Model Reports > Templates >
Sections

Other 'Resources' tab of the Browser window |
Document Publishing | Custom
Templates | <template type> : right-click
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on a template | Open > Sections

Extract information on Tagged Values

Action Detail

Insert a
Tagged
Value section

The Tagged Value section reports all
Tagged Values for the object.
In the 'Sections' panel, select the
checkbox for each object to report on,
and for the Tagged Value subsection for
that object. For example:

Package > Package Element > Tagged·

Value
Package > Connector > Source >·

Tagged Value
Package > Element > External·

Requirements > Tagged Value, or
Package > Element > Method >·

Tagged Value
The Tagged Value section markers
display in the 'Contents' panel.
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Delete the [right-click-to-...] text,
right-click in the space and select the
'Insert Fields' option to add 'Tagged
Value Name', 'Notes' and/or 'Value'
fields.

Insert a
valueOf()
field

For any object having a Tagged Value,
you can add a 'valueOf()' field to your
report template to extract the value of a
specific tag. This should be one of the
tags normally associated with the object,
such as 'ConnectorAltName' for a
connector.
Obtain the name of the tag before starting
this procedure.
To insert the field, right-click between the
section tags for the object and select the
'Insert Field | valueOf' option.
The Document Template Designer
prompts you to type in the name of the
tag from which to extract the value. Type
the name and click on the OK button.
The Document Template Designer adds
the field at the cursor position, in the
format:
     {Objecttype.valueOf(tagname)}
For example:
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{Connector.valueOf(ConnectorAltName)
}
The 'valueOf' field extracts just the value
of the tag, so for clarity you could type
some lead-in text or the meaning of the
tag, immediately preceding the value
field. For example:
     Alternative Name:
{Connector.valueOf(ConnectorAltName)
}
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Create Sections as Tables

In a document report template, you can render a model
section as a table, defined with any number of columns but
with only two rows:

The first row is used to describe the headings of the·

columns, which you define and format yourself

The second row defines the output, which you specify by·

right-clicking in each cell and selecting the output type
from the field list; the output is then generated iteratively
for every occurrence of the section in question

For example, you might set up the Model > Glossary >
section as a section table, using the table definition:

This table definition renders the document output:

Access
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Ribbon Document-Edit > Paragraph > Table >
Insert Table

Create and format a table

To Action

Insert a table
in the
document

Position the cursor on the point in the text
to create the table, and from the
'Document-Edit' ribbon bar select
'Paragraph > Table > Insert Table'. The
'New Table' dialog displays, in which you
specify the number of table rows and
columns. For a model section table in a
report template you can accept the default
values of two rows and three columns.
Click on the OK button.
Your table might be invisible; if so, select
the 'Paragraph > Table > Show Gridlines'
from the ribbon bar to reveal the table
and cell borders in dotted lines. These
lines are for guidance in creating the
document, and do not display on the
printed document. You can add printable
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borders if you prefer, using other menu
options.
The editor initially creates a table with
cells of equal width across the page; you
can change the cell width by dragging the
cell borders using the mouse, or using
other context menu options.

Add a header
row

Select the top row of the table, and then
select 'Paragraph > Table > Header Row'
from the ribbon bar. Apply any heading
text, settings and formatting to the
highlighted row.
In the document or compiled report, the
heading row is repeated at the top of the
columns each time the table flows on to a
new page. In a report, if the heading row
is populated with the values from field
names, the heading rows on subsequent
pages reflect the values from that first
row.
This option operates on the single row at
the top of the table, and not on multiple
rows.

Populate data
row with
fields

Right-click on the table cell and select the
'Insert Field | <field name>' option to add
one or more fields to the cell.
When the report is generated, the field
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values are extracted and displayed in the
table for each instance of the object, such
as an element or attribute.

Notes

In a document report template, if you type a carriage·

return between the end of the table and the section
terminator, the table you generate has a line space
between the rows; for example:

This generates the table:

To avoid this, remove any carriage return between the end
of the table and the section terminator, as shown:
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This generates a table with no space between the rows:
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Add Section Content

In the Document Template Designer, as you select the
checkboxes in the 'Sections' panel to report on the different
objects and features of the model, pairs of highlighted tags
are added to the 'Contents' panel. Many of these pairs of tags
have a short instruction between them, as shown:

     sectionname >

     [right-click-to-insert-< objectname >-fields]

     < sectionname

Where the text message is shown, you can delete it and use
the space between the tags to provide the content of the
report, by:

Typing or pasting boiler-plate text that you want to·

include in your reports, and

Inserting fields that extract the values of specific·

characteristics and properties of the object

Access

Ribbon Publish > Model Reports > Templates >
Content

Other 'Resources' tab of the Browser window |
Document Publishing | Custom
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Templates | <template type> : right-click
on a template | Open > Content

Add information content to template

Action Detail

Add text Click in the space between the tags (or
anywhere else in the template) and type
or paste (Ctrl+V) the text you want to
display in the report.
Highlight and right-click on text to
format it, using the Document Editor
commands.

Insert fields Right-click in the area between the
opening and closing tags, and select the
'Insert Field' option; this displays a
context-sensitive list of fields to add to
this section of the template.
Click on the name of the field you want
to add. The Document Template Editor
displays the field tag in the text space.
For example:
      {Element.ParentPackage}
When you generate a report from the
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template, the report generator replaces the
field name with the actual value. You
might need to type lead-in text and add
spaces to support the field value, or use
the fields in a table with row and column
headings.
You can insert as many fields as you
want from the list; you usually apply each
field once, as the report generator applies
the template instructions to each instance
of the object.

Notes

As the model and Linked Document tags do not require·

fields, you cannot display the editor context menu
between these tags

The child element, embedded element and child Package·

tags represent sections that can have defined fields, but
these fields prevent the sections from replicating the
structure of their parent element and Package sections; as
it is preferable to use the parent structures, these tags do
not prompt you to add fields with the
[right-click-to-insert-<objectname>-fields] message,
although the message is still applicable

If you select a field with short date format (such as·
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Pkg.DateCreatedShort, Diagram.DateModifiedShort or
Element.DateCreatedShort) the format is actually drawn
from the MS Windows settings; to use a different short
date format, click on the Start icon on the Windows
desktop and select the 'Control Panel | Regional and
Language Options | Customize' option
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Apply User-Defined Section
Numbering

In your report template, you might want to number the
section levels, with a numbering format of your own design.
For example:

     1. Package level 1

     1.1 Package level 2 (child Package)

     1.1.1 Element Level 1

     1.1.1.1 Element (child element)

To define the numbering format you:

First create a numbering list, then·

Create a set of list overrides for this list·

In the overrides, you change the initial 1.0.0 setting to 1.1.1.
You can then apply the numbering list to the headings set
for Packages and elements, using paragraph numbering.

Access

Ribbon Document-Edit > Edit > Edit > List and
Overrides
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Define the numbering format

Ste
p

Action

1 To create the numbering list, select the 'Create List
Item' menu option.
The 'List Properties' dialog displays:

In the 'List Name' field, type a name for the list·

Leave the 'Multi-level list' checkbox selected·

If you have added sections to your document and·

want to restart numbering for each new section,
select the 'Restart at section break' checkbox
Click on the OK button to close the dialog·

2 To create the list override, select the 'Create List
Override' menu option.
The 'List Override Properties' dialog displays:

In the 'List to Override' field, type or select the·

name of the list you have just created
Leave the 'Override Levels' checkbox selected·

Click on the OK button to close the dialog·

3 To set up the list level properties for a level, select
the 'Edit List Level' menu option.
The 'List Level properties' dialog displays.

Select the 'List item' radio button and type or·
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select the list item you have just created
Set the 'List Level' field to '1' (for the Package·

Section) and the 'Number text' field to '~1~'
Click on the OK button to save the values and·

close the dialog

4 Select the 'Edit List Level' menu option again to
re-open the dialog:

Select the 'List item' radio button and type or·

select the list item you have just created
Set 'List Level' to '2' (for the 'Element Section' or·

'Child Package Section', for example)
Set 'Start at' to '1' (to ensure that numbering at this·

level begins at 1.1 rather than 1.0)
Click on the OK button to close the dialog and·

save the changes

5 Repeat steps 3 and 4 for each additional list level to
need, incrementing the List Level number and
resetting Start at to 1 each time.

Apply the defined numbering levels

Ste
p

Action
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1 In the 'Content' panel of the Document Editor,
select the first item of text to be numbered (for
example, Package).

2 Set the text style to one of the Heading styles
(Heading 1 to Heading 9), using the 'Style'
drop-down field in the Document Editor toolbar.

3 Right-click on the text and select the 'Paragraph |
List Numbering' menu option.
The 'Apply paragraph numbering using Lists' dialog
displays.

In the 'List' panel, select the required List and·

Override combination
Set the 'Level' field to the required level (1, for the·

top level)
Click on the OK button to close the dialog, and·

check that the required level has been applied to
the selected text
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4 Repeat step 3 for the next level (Element), but
change the 'Level' field to 2.

5 Continue applying the overrides for each lower
section level as necessary, then generate your
document.
The output will be numbered and formatted, as
illustrated by the example.

Numbering Level Example
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Custom Template Design Options

The Document Template Designer, through the
'Document-Edit' ribbon, provides a wide range of options
for defining the format and styles of the document reports
generated from your custom templates. In addition to these
functions, you can also access options from the toolbar at
the top of the 'Content' panel, and from an in-text context
menu.

Access

When you open a template in the Document Template
Designer, the Document - Edit ribbon also opens
automatically.

Ribbon Publish > Model Reports > Templates

Other 'Resources' tab of the Browser window |
Document Publishing | System Templates
| <template group> : right-click on a
template | Copy
'Resources' tab of the Browser window |
Document Publishing | Custom
Templates | <template group> :
right-click on a template | Open
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Option Descriptions

The ribbon option descriptions are grouped according to the
actions you are performing.

Actions

Creating and importing templates

Configuring the editor page display and formatting tools
shown

Incorporating stylesheets, special texts and Tables of
Contents
Managing the base styles in the Normal.rtf style template
file

Moving through, searching and selecting text

Formatting characters and text strings

Formatting paragraphs and text blocks

Inserting tab points

Inserting sections, columns and page breaks, and
repaginating
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Inserting and editing page headers and footers, and
footnotes and endnotes

Inserting tables

Setting up User-Defined Section Numbering

Inserting hyperlinks

Inserting images, OLE objects, frames and drawing
objects

Checking the spelling of text, and word use

Tracking changes and incorporating or rejecting them

Protecting document and template text from accidental
change

Printer set up and printing documents

Notes

Throughout your template editing:

To undo one or more immediately previous edits, press·
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Ctrl+Z, or select the 'Undo' context menu option; you can
still undo a change even after you have saved the change

To redo one or more immediately previous undone edits,·

press Ctrl+Y, or select the 'Redo' context menu option
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Using Bookmarks

Within a document template, you can insert a bookmark to
locate material inside the generated document, either from
within the same document or from a separate Word
document.

Manage bookmarks

As your report template develops, the editor automatically
assigns a unique bookmark to the start and end of each
model section you select from the 'Sections' panel.

You can also create your own bookmarks in any document
wherever you want to reference a specific point, and move
these to other points in the text.

(In the report template you can move the automatic
bookmarks as well, but if you want to use these as reference
points for a Word document to access, it is better to leave
them as they are.)

Task Description

Insert a
Bookmark

Right-click on the point in the text to1.
mark, and select the 'Bookmark' menu
option; the 'Bookmarks' dialog
displays.
Either select an existing bookmark2.
from the list (to switch it to the current
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location) or type a new bookmark name
in the top field. Do not use spaces in
the Bookmark; this will prevent the
bookmark from being inserted.
Click on the Insert button.3.

Locate
Bookmarked
Text in the
Document

Select the 'Bookmark' menu option.1.
On the 'Bookmarks' dialog, click on the2.
bookmark and on the Go to button.
The editor displays the point at which3.
the bookmark was set, in the top left
corner of the display.

Delete an
Existing
Bookmark

Select the 'Bookmark' menu option.
On the 'Bookmarks' dialog, click on the
bookmark and on the Delete button.

Insert a
Reference to
a Bookmark

Move the cursor to the point at which1.
to insert the reference and, if you want
to, type some lead-in text such as 'Go
to page' or 'See page'.
Select the 'Bookmark' menu option.2.
On the 'Bookmarks' dialog, click on the3.
bookmark and on the Set Page
Reference button.
The editor inserts the number of the4.
page containing the bookmark, at the
cursor position in the text; for a
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document, this acts as a hyperlink to
the bookmark position. If you set the
reference in a template, the link is
created in the document you generate
from the template.

Additional Bookmark Facilities in Document
Generation

All .Start and .End bookmarks that enclose a labeled field
will hide the label in the report if the field has no content;
for example:

The bookmarks Element.Keywords.Start and·

Element.Keywords.End enclose the Keywords
{Element.Keywords} report field, but if an element has no
keywords, the Keywords label in the generated report is
hidden and the space closed up

All Begin and End bookmarks containing the string _LIST_
will add a comma to the enclosed section, so that all values
extracted from the model for that section will be presented
in a comma-separated list; for example:

The bookmarks·

Pkg_Element_Meth_MethParameter_LIST_Begin and
Pkg_Element_Meth_MethParameter_LIST_End in the
parameter section set a comma that, in the report, is
inserted between the multiple parameter name/type pairs
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in the section

All Begin and End bookmarks containing the string
_TITLE_ will add a line break and a value title to the field,
and present the values extracted from the model as a vertical
list underneath the title; for example:

The bookmarks·

Pkg_Element_Meth_FeatTagVal_TITLE_Begin and
Pkg_Element_Meth_FeatTagVal_TITLE_End in the
Tagged Value section insert a line space and the heading
'Properties', underneath which is printed, in the report, the
names and values of the parameter Tagged Values

Notes

When you force a custom SQL field in the fragment to be·

processed as a formatted notes, you must have '.formatted'
in the custom field name; for example:
     {FieldName.Formatted}

The same is required in the bookmarks for SQL·

fragments; for example:
     {FieldName.Formatted.Start} or
FieldName.Formatted.End}.
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Report Constants

The Document Editor (for generated report templates)
provides a set of fields that represent data on the report
itself, such as the report name, title, generation date, version,
author and status. When the report is generated, each field is
replaced by the current value of the data item. These are
called report constants.

You can insert a report constant anywhere in your template -
in text, in headers or footers, or in cover page material. They
are particularly suited for cover pages.

Constants

Constant Replaced by

ReportAlias (For a report generated on a root
Package) The Alias of the Package, from
the Package properties.
(For a report generated on a single
element) The Alias of the element, from
the element properties.
Otherwise, the constant remains empty.

ReportAuthor The Enterprise Architect login ID of the
user who is generating the report.
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ReportClipbo
ard

The image currently held on the
clipboard.

ReportDateL
ong

The system-generated date in long
format.

ReportDateS
hort

The system-generated date in short
format.

ReportFilena
me

The file name of the generated report, as
recorded on the 'Generate
Documentation' dialog.

ReportFilena
meShort

The current filename of the generated
report. (Will change if the file is renamed
on disk.)

ReportKeyw
ords

(For a report generated on a root
Package) The Keywords of the Package,
from the Package properties.
(For a report generated on a single
element) The Keywords of the element,
from the element properties.
Otherwise, the constant remains empty.

ReportName (For a report generated on a root
Package) The name of the Package, from
the Package properties.
(For a report generated on a single
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element) The name of the element, from
the element properties.
Otherwise, the constant remains empty.

ReportSource The name of the Repository that was used
to generate the document.
For file-based repositories, this will be
the file path and name of the project file.
For DBMSs this will be the name of the
database used.

ReportStatus (For a report generated on a root
Package) The status of the Package, from
the Package properties.
(For a report generated on a single
element) The status of the element, from
the element properties.
Otherwise, the constant remains empty.

ReportSumm
ary

Provides the content of the
'ReportSummary' Tagged Value found on
the root Package or single element.
If there is no 'ReportSummary' Tagged
Value, the constant remains empty.

ReportTitle The name of the template used to
generate the report, as selected on the
'Generate Documentation' dialog.
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ReportVersio
n

(For a report generated on a root
Package) The version of the Package,
from the Package properties.
(For a report generated on a single
element) The version of the element,
from the element properties.
Otherwise, the constant remains empty.

Insert a Report Constant

Right-click on the point in the template to insert the data
field and select the 'Report Constants | <field name>' option.
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Notes on Creating Stylesheets

Stylesheets define a range of formatting parameters that
control the appearance and layout of a document report. You
create them to provide an alternative set of styles to the
Normal.rtf file and to any special styles redefined within a
document report template. A user can choose to apply a
Stylesheet to any kind of document report they are
generating, in which case the styles in the Stylesheet
override the styles with matching names in the template or
Normal.rtf. You can, therefore, create a Stylesheet that:

Redefines and overrides certain styles·

Does not include other named styles, so use of those·

styles defaults to the template or Normal.rtf file definition,
and

Provides additional styles that can be applied by editing·

the generated report

Each custom Stylesheet can define a totally different page
layout and document styles to other Stylesheets and to the
Normal.rtf Stylesheet.

The simplest way to create a new Stylesheet is to copy one
of the system-provided files (for print output or for online
output) or another custom Stylesheet, and edit the style
definitions in the copy. However, you can create a
Stylesheet from scratch if you prefer; this would be initially
derived from the Normal.rtf file.
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Access

Use one of the methods outlined here to display the 'New
Document Template' dialog. Create the new Stylesheet file,
then edit the styles in the Document Template Designer
using the 'Styles, Special Text and Table of Contents'
facilities.

Ribbon Publish > Model Reports > Templates :
    or

Start > Desktop > Share > Resources >
Document Publishing > Custom
Templates > right-click on Style Sheets >
Create Template
Start > Desktop > Share > Resources >
Document Publishing > Custom
Templates > Style Sheets > right-click on
<stylesheet name> | Copy

Other In the 'Resources' tab of the Browser
window, expand the Document
Publishing folder, then:

Expand the Custom Templates folder |·

right-click on Style Sheets | Create
Template, or
Expand the System Templates folder |·

Expand the Style Sheets folder |
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right-click on <stylesheet name> |
Copy

You can also create Stylesheets within
the 'Templates' tab of the 'Generate
Documentation' dialog.
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Notes on Creating Tables of Contents

A Table of Contents template defines the style, levels and
numbering formats of a document report Table of Contents
that a user can choose to apply to any kind of document
report they are generating, in which case the Table of
Contents template overrides any Table of Contents styles
defined in the template or Normal.rtf file.

The simplest way to create a new Table of Contents is to
copy one of the system-provided files (for portrait output or
for landscape output) or another custom Tables of Contents,
and edit the style definitions in the copy. However, you can
create a Table of Contents from scratch if you prefer; this
would be initially derived from the Normal.rtf file.

Access

Use one of the methods outlined here to display the 'New
Document Template' dialog and create the new Table of
Contents template file.

After creating the new template file, edit the styles in the
Document Template Designer using the 'Styles, Special
Text and Table of Contents' facilities.

Ribbon Publish > Model Reports > Templates :

In the 'Resources' tab of the Browser
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Other window, expand the Document
Publishing folder, then:

Expand the Custom Templates folder |·

right-click on Table of Contents |
Create Template, or
Expand the System Templates folder |·

Expand the Table of Contents folder |
right-click on <table of contents name>
| Copy

Insert a new Table of Contents

To insert a new Table of Contents:

Add at least one character of text to the document·

Set that to a 'Heading n' style. For example 'Heading 1'·

Move the cursor to the point at which to insert the Table·

of Contents, and select the option:
Document-Edit > Edit > Insert > Table of Contents.

A small dialog displays in which you specify the highest and
lowest Table of Contents levels to apply in the table in this
document; when you have specified the levels, click on the
OK button.
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Note: If there are corresponding headings within the
specified range, the Table of Contents displays; otherwise,
the line remains blank.

Remove the Heading Style text added above.·

Save the template.·
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Import a Document Template

Many organizations have established corporate formats and
templates, or might design templates outside Enterprise
Architect. If you want to use such 'external' templates from
your business to apply formats and standards to your
document reports, you can import them into your document
template library.

Access

Ribbon Document-Edit > File > File > Import
File

Import a template from an external
directory

Ste
p

Action

1 Save the external template as a document.

2 In Enterprise Architect, create a new blank template.
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Either:
Click on the  icon in the Document Template·

Designer, or
Right-click on a User Template folder in the·

'Resources' tab of the Browser window and select
'Create Template'

The 'New Document Template' dialog displays.
Name the template, but do not specify an existing
template to copy from.

3 Once the new blank template is loaded in the
Document Template Designer, select the option
'Document-Edit > File > File > Import File'.
The 'File Open' dialog displays.

4 Locate your template file, and click on the Open
button.
The 'Open' dialog closes, returning you to the
Document Template Designer; this now contains
your imported template.

5 Select the option 'Document-Edit > File > Save'.
If necessary, make any changes to the template and
select the option 'Document-Edit > File > Save'
again.
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Notes

Standard graphical images (such as a logo in the header,·

main text or footer) are imported; however, any meta-file
graphics are not imported

You can select the new template to use in generating a·

document report, either on the 'Generate Documentation'
dialog or in a Model Document element
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Notes on Creating Cover Pages

A Cover Page template defines the style, fields and format
of a document report front cover that a user can choose to
apply to any kind of document report they are generating, in
which case the Cover Page styles override any styles of the
same name defined in the report template or Normal.rtf file.

The simplest way to create a new Cover Page is to copy one
of the system-provided files (for portrait output or for
landscape output) or another custom Cover Page Contents,
and edit the style definitions in the copy. However, you can
create a Cover Page from scratch if you prefer; this would
be initially derived from the Normal.rtf file.

Access

Use one of the methods outlined here to display the 'New
Document Template' dialog and create the new Cover Page
template file.

After creating the new template file, edit the styles in the
Document Template Designer using the 'Styles, Special
Text and Table of Contents' facilities.

Ribbon Publish > Model Reports > Templates :

Other In the 'Resources' tab of the Browser
window, expand the Document
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Publishing folder, then:
Expand the Custom Templates folder |·

right-click on Cover Pages | Create
Template, or
Expand the System Templates folder |·

Expand the Cover Pages folder |
right-click on <cover page name> |
Copy
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Template Fragments

Within a document template you can include one or more
sub-templates, or Template Fragments. Using Template
Fragments, you can include in your document reports
information extracted from the model using SQL Queries
and Model Scripts, providing a greater level of
customization of the document output. You can also use a
Template Selector Fragment to call other Template
Fragments depending on which type of element is being
reported on. It is possible to reuse the same Template
Fragment in several different templates, so you can develop
a library of common Template Fragments that can be used
to build larger, more complex document reports.

A Template Fragment is created through the same process
as a normal, full-document template. Each Template
Fragment can have its own document options applied, such
as filtering and sorting.

You can also use, copy and edit a number of
system-provided Template Fragments, which you can access
from the Document Publishing > System Templates >
Fragments folder in the 'Resources' tab of the Browser
window.

Template Fragments - Process Overview

Ste Action
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p

1 Create the Template Fragments to be included in
your template.

2 Create a normal, full-document template that is to
include your Template Fragments.

3 Within this full-document template add references to
your Template Fragments in the appropriate
locations.

Notes

You cannot generate documentation directly from a·

Fragment; to use a Fragment it must be included in a
template
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Creating a Template Fragment

A Template Fragment can return data from either an SQL
Query or Model Scripts. The process of defining the content
of a Template Fragment depends on which type of data you
want your Template Fragment to return; the choices being:

Normal Document Template model data - the Template·

Fragment operates in the same way as a normal template

Template Selector - to define a template that calls in other·

Template Fragments depending on the element type being
reported on

Custom SQL - to refer to the data returned by a custom·

SQL Query

Custom Scripts - to refer to data returned from a Model·

Script

Document Script - to identify a Model Script to be used·

by your Template Fragment; the script must return either
an empty string or a string that contains raw RTF

Custom XML Script - to create a query to report values·

from an XML file produced by a previously-generated
script, such as the data from a simulation; the query
operates on static data that is not being continually or
automatically updated

In all cases the process is very similar to creating a normal
document template.

Access
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Use one of the methods outlined here to open the 'New
Document Template' dialog.

Ribbon Publish > Model Reports > Templates :
 New Template icon

Keyboard
Shortcuts

F8 > Templates : New

Other In the 'Resources' tab of the Browser
window, expand the Document
Publishing folder, then:

Expand the folder Custom Templates |·

right-click on the folder Fragments |
Create Template or
Expand the folder Custom Templates |·

expand the folder Fragments |
right-click on <template name> | Copy
or
Expand the folder System Templates |·

expand the folder Fragments |
right-click on <template name> | Copy

Create a new Template Fragment
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Ste
p

Action

1 Using one of these methods, display the 'New
Document Template' dialog.

2 In the 'New Template' field, type the name for the
Template Fragment.

3 In the 'Template Type' field, click on the drop-down
arrow and select the 'Fragments' option.

4 In the 'Copy Template' field, click on the drop down
arrow and select either:

'None', to create an empty Template Fragment to·

develop from scratch, or
The name of an existing Template to act as a base·

5 In the 'Template Group' field either:
Click on the drop-down arrow and select an·

existing group from the list, or
Type a name to generate a new template group, or·

Leave this field blank, to not place the Template·

Fragment in a group
The Template Group determines the location of the
Template Fragment in the 'Resources' tab of the
Browser window.
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6 Click on the OK button.
The Document Template Designer displays in the
Diagram View.

7 Define the contents of your Template Fragment; the
actual steps you follow depend on the data source
you want the Template Fragment to operate on:

Normal Document Template model data·

Template Selector·

Custom SQL·

Custom Scripts·

Document Script·

Custom XML Script·

8 Once you have created the Template Fragment, you
incorporate it into a normal template (or into an
existing Template Fragment, if you prefer).

Notes

Custom Queries and the Custom template section can only·

be used in Template Fragments; they cannot be used in
normal, full-document templates

As with normal document templates, Template Fragments·

can also be created and opened via the 'Resources' tab of
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the Browser window

Template Fragments in the 'Resources' tab are held in a·

Fragments folder in each of the Document Publishing >
System Templates and Document Publishing > Custom
Templates folders, and are indicated by a T symbol

If you have an existing template that you want to use as a·

Template Fragment, copy the template as the base of a
new Fragment

Filtering operates only for the template in which it is set,·

and does not propagate through sub-templates/fragments;
you can set filtering for each sub-template separately, in
the Document Options for the sub-template

If you embed a Template Fragment within another·

Fragment, report generation from the parent template will
be slower

If you have a column or node with the name·

EABOOKMARK, this will insert a document bookmark
around the parent section in the 'Contents' panel
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How to Define a Template Selector
Fragment

A Template Selector is a Template Fragment that calls other
Template Fragments, depending on what type of element is
being reported. The Template Fragments being called can be
system Fragments or existing user-defined Fragments, as
listed in the 'Resources' tab of the Browser window.

Access

Use one of the methods outlined here to display the 'Custom
Query' page of the 'Document Options' dialog. Before you
select the Document Options icon, select the 'Custom'
checkbox in the 'Sections' list, to enable the  'custom >
<custom' tags. These are necessary for the Template
Selector fragment to work.

Ribbon Publish > Model Reports > Templates :
<select a fragment template> : 
(Document Options icon) > Custom
Query

Keyboard
Shortcuts

F8 > Templates | Fragments |
Double-click on <Fragment name>, then

 (Document Options icon) > Custom
Query
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Set Up the Template Selector

Option Action

Template
Selector

Click on this radio button to define the
template selection commands.

data field On separate lines, type each element type
and the name of the Template Fragment
to use for that element type, in the format:
     ElementType:<stereotype>:Fragment
Name
For example (elements not extended by a
stereotype):
     Action::Behavioral
     ActionPin::Simple Behavioral
     CollaborationUse::Structural
and (element extended by a stereotype):
     Class:table:Database Table
To identify the fragment to use if
elements are reported that have not been
specifically identified, type:
     default::Fragment Name
Also see the Notes section in this topic.
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OK Click on this button to save the changes
you have made and close the 'Document
Options' dialog.

Notes

Further advice on providing a value for the data field:

To a certain extent you can adapt the 'extended by
stereotype' line according to what alternative modeling
language you are using, what you specifically want to
extract in the report, and what elements exist under the
Package or element you execute the report on. For example:

Extract ArchiMate Business Actor elements·

     -  From a structure containing UML and ArchiMate
elements - Class: ArchiMate_Business Actor:BusActFrag
     -  From a structure containing only ArchiMate
elements - Class:BusinessActor:BusActFrag
     -  From a structure containing only ArchiMate
Business Actor elements - Class::BusActFrag

Extract Business Actor elements·

     -  From a structure containing UML and ArchiMate
elements - Class:Business Actor:BusActFrag
     -  From a structure containing only ArchiMate
elements - Class:BusinessActor:BusActFrag
     -  From a structure containing only Business Actor
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elements - Class::BusActFrag

To establish the type and Stereotype details of a
representative element selected in the 'Resources' tab of the
Browser window, run this query in the SQL scratch pad
(use the ribbon option 'Explore > Search > Model :  >
SQL Scratch Pad'):

Select t_object.name, t_object.Object_Type,·

t_object.Stereotype from t_object where
t_object.Object_ID=#CurrentElementID#

For example, selecting a  BPMN DataObject in the Browser
window and running this SQL gives:

Name  -   Issue List[Initial]

Object_Type -  Artifact

Stereotype - DataObject

So you would use the combination
Artifact:DataObject:<fragment name> in the data field

Alternatively, do not use a Template Selector fragment and
create a simple template to operate on the 'Element' section
of the report, to extract elements of Type - Class and
Stereotype - Business Actor. Run this on the specific
element(s).

For a complete example, make a copy of the
system-supplied Template Selector in the Document
Publishing | System Templates | Fragments folder of the
'Resources' tab of the Browser window and review the
'Custom Query' tab of the 'Document Options' dialog. (To
make a copy, right-click on the template name and select the
'Copy' option.)
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How to Define a Custom SQL Fragment

You can create a Template Fragment to return data from an
SQL Query. You do this by defining an SQL Query in the
'Document Options' of the Template Fragment, then adding
fields within the 'Custom' section of your Template
Fragment that refer to the columns returned by the SQL
Query. The Query is DBMS dependent and so might vary
according to the DBMS you are using.

Create an SQL Query Fragment

Ste
p

Action

1 Open or create a Template Fragment in the
Document Template Editor.

2 In the Document Template Editor, right-click on the
Template background and click on the icon.
The 'Document Options' dialog displays.

3 Select the 'Custom Query' page.

4 In the 'Template Fragment type' panel, select the
Custom SQL radio button.
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5 In the main text field on the tab, type the SQL Query
that is to be run on your model.
You can use #<macro>#s as string substitutions, as
for other SQL Search Queries.
Your Query must return one or more columns; for
example:

     SELECT DocName AS TemplateName, Author
AS TemplateLocation
     FROM t_document
     WHERE DocType = 'SSDOCSTYLE' and
(IsActive = 1)

The SQL Query can reference the ID of the element,
diagram or Package currently being processed by the
document template, using the #OBJECTID#,
#DIAGRAMID# or #PACKAGEID# macros; for
example:

     SELECT Count(Object_Type) AS
CountOfActors
     FROM t_object
     WHERE Object_Type = "Actor" and Package_ID
= #PACKAGEID#

You can also make your column entries into
hyperlinks to the element entries in the generated
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document. The column header field (in the template
text itself, in the 'Custom' panel) must contain the
suffix 'Hyperlink'; for example:

     {Elements-Hyperlink}     for .eap (JET)
repositories, or {Elements.Hyperlink} for other types
of repository

The column entries, or values, must have the format:

     {guid}LABEL

In this format, {guid} is the GUID of the element to
link to and LABEL is the hyperlink text (such as the
element name), either manually inserted or returned
from another command. For example:

     {123-456-7890}Class2

In the generated report this displays as 'Class2',
which links to the description of Class2 in the
document.
This example returns the hyperlinked name of each
base (parent) Class of the element currently being
reported:

     SELECT #Concat t_object.ea_guid,
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t_object.Name#
     AS [BaseClassName-Hyperlink]                      (for
.eap files; for other repositories use    AS
[BaseClassName.Hyperlink])
     FROM t_object, t_connector
     WHERE t_connector.Start_Object_ID =
#OBJECTID#
     AND t_object.Object_ID =
t_connector.End_Object_ID
     AND t_connector.Connector_Type =
'Generalization'

This query could return multiple entries, in which
case the entries are reported one per line. You can, if
required, have multiple Hyperlink query statements,
separated by commas. You can hyperlink to reported
elements, attributes, operations, diagrams and
Packages.
It is possible to force a field to be processed as a
hyperlink or as formatted notes, by providing a
column in this format:
     custom >
     {Name}
     <fieldname>.Formatted      (or
<fieldname>.Hyperlink)       (for all repositories,
excluding .eap)
     < custom
In your custom SQL Query statement, you must use
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an alias matching the template field name; for
example (in MySQL):

     SELECT ea_guid AS CLASSGUID,
Object_Type AS CLASSTYPE, Name, Note as
"Note.Formatted" FROM t_object
     Where Object_ID=#OBJECTID#

6 Click on the OK button to close the 'Document
Options' dialog.

7 In the 'Document Template Editor', in the 'Sections'
panel, select the 'Custom' checkbox to generate the
'Custom' section.

8 Within the 'Custom' section, right-click and select
the 'Insert Custom Field' option.
A prompt displays for the name of the field to create.

9 In response to the prompt, type the name of the
column that is being returned by your Query; for
example, CountOfActors.
Click on the OK button.

10 Repeat steps 8 and 9 for each column that you want
to include in your report.
Add any other formatting and content you need, to
the Template Fragment.

(c) Sparx Systems 2021 Page 213 of 416



Document Reports 2 September, 2021

11 Save the Template Fragment, and add it to a normal
document template.

Notes

An element Filter will not apply to the 'Custom' section in·

a Template Fragment

In your SQL statements you can reference model details·

using:
     -  #OBJECTID# returns the ID of the element currently
being processed by the document template
     -  #PACKAGEID# and #Package# return the ID of the
Package currently being
        processed by the document template
     -  #Author# takes the user name from the 'Author' field
in the 'General' page of the
        'Preferences' dialog, so the defined search can be
performed on objects created
        by that user (this value can be manually re-set in the
'Preferences' dialog)

You can test your SQL Query using the SQL Editor in the·

Find in Project window
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How to Define a Custom Script
Fragment

You can create a Template Fragment to return data from a
Model Script. You do this by creating a Script that returns
an XML string in a specific format. You add a reference to
this Script in the 'Template Fragment Document Options',
then add fields within the 'Custom' section of your Template
Fragment that refer to the data returned by the Script.

Creating a Script Fragment

Ste
p

Action

1 Using the Scripting window, create a Model Script
that returns a string in XML format.
See the examples of:

A Script that returns data in the appropriate XML·

format (Example Template Fragment Script)
The XML format that the Script must return so·

that it can be used by a Template Fragment
(Example Output of a Template Fragment Script)

2 Open or create a Template Fragment in the
Document Template Editor.
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Right-click on the Template background and click
on the icon.
The 'Document Options' dialog displays.

3 Select the 'Custom Query' tab and, in the 'Template
Fragment type' panel, select the 'Custom Script'
option.
A blank field displays to the right of the options.

4 Click on the drop-down arrow and select your
Script from the list.

5 In the main text field on the tab, type the entry point
of your Script that returns the XML data.
For example, if you were using the example script
mentioned in step 1, in JScript, then the entry point
would be:
     MyRtfData(#OBJECTID#);
To convey Package information, you can replace
#OBJECTID# with #PACKAGEID#. (Also, for
VBScript, omit the semi-colon at the end.)
This applies to the calling statement (not the script
that is called), which can also reference:

#Branch# - gets the IDs of the child Packages of·

the current Package being processed, working
recursively down to the lowest level of
sub-Package; this is only valid when processing a
Package - elements return a 0 value
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#Package# - (as for #PACKAGEID) gets the·

package_ID of the currently-selected Package

6 Click on the OK button to close the 'Document
Options' dialog.

7 In the Document Template Editor, in the 'Sections'
panel, select the 'Custom' checkbox to generate the
Custom section.

8 Within the 'Custom' section, right-click and select
the 'Insert Custom Field' option.
A prompt displays for the name of the field to create.

9 In response to the prompt, type the name of the data
field that is being returned by your script.
Referring to the example from step 1, you would add
DateGen.
Click on the OK button.

10 Repeat steps 8 and 9 for each data field that you
want to include in your report.
Add any other formatting and content you need, to
the Template Fragment.

11 Save the Template Fragment, and add it to a normal
Document Template.
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Notes

Scripts have a limit of 60 seconds per call before control·

is returned to the Document Generator
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Example Template Fragment Script

This JScript returns a row of data in XML format. The XML
data can be returned in a document report using a Custom
Script Template Fragment.

The script will also display the XML data in the System
Output window, so you can easily check the output without
running a document report.

!INC Local Scripts.EAConstants-JScript

/*

* Script Name: Document Properties

* Author: Tom O'Reilly

* Purpose: To display the properties of a document

* Date: 02/02/2013

*/

function MyRtfData(objectID)

{

var i;

var xmlDOM = new
ActiveXObject("MSXML2.DOMDocument.4.0");

xmlDOM.validateOnParse = false;

xmlDOM.async = false;

var node = xmlDOM.createProcessingInstruction("xml",
"version='1.0' encoding='ISO-8859-1'");
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xmlDOM.appendChild(node);

var xmlRoot = xmlDOM.createElement("EADATA");

xmlDOM.appendChild(xmlRoot);

var xmlDataSet = xmlDOM.createElement("Dataset_0");

xmlRoot.appendChild(xmlDataSet);

var xmlData = xmlDOM.createElement("Data");

xmlDataSet.appendChild(xmlData);

var xmlRow = xmlDOM.createElement("Row");

xmlData.appendChild(xmlRow);

var xmlName = xmlDOM.createElement("DateGen");

var today = new Date();

var dd = today.getDate();

var mm = today.getMonth()+1; //January is 0!

var yyyy = today.getFullYear();

if(dd<10){dd='0'+dd} if(mm<10){mm='0'+mm} today =
mm+'/'+dd+'/'+yyyy;

xmlName.text = today;

xmlRow.appendChild(xmlName);

var xmlName = xmlDOM.createElement("TimeGen");

var currentTime = new Date()

var hours = currentTime.getHours()

var minutes = currentTime.getMinutes()

if (minutes < 10)

{

minutes = "0" + minutes
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}

xmlName.text = hours + ":" + minutes + " ";

xmlRow.appendChild(xmlName);

var xmlName = xmlDOM.createElement("Author");

xmlName.text = Session.UserName;

xmlRow.appendChild(xmlName);

var xmlName = xmlDOM.createElement("EA_REPOS");

xmlName.text = Repository.ConnectionString;

xmlRow.appendChild(xmlName);

return xmlDOM.xml;

};

Session.Output(MyRtfData(439));
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Example Output of a Template
Fragment Script

You can create a Template Fragment to return data from a
Model Script into a document report. The Script must return
one or more rows of data in this XML format:

<EADATA>

     <Dataset_0>

          <Data>

               <Row>

                    <DateGen>09/01/2013</DateGen>

                    <TimeGen>9:31 </TimeGen>

                    <Author>John</Author>

<EA_REPOS>C:\Users\John\Documents\Sample
Model.eap</EA_REPOS>

               </Row>

          </Data>

     </Dataset_0>

</EADATA>

Each of these data fields in the XML (such as 'DateGen',
'TimeGen') refers to fields that can be included in the
'Custom' section of a Template Fragment.
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Notes

If the text is a formatted Note, add formatted="1" to the·

field row; for example:
      <Author formatted="1"><i>John</i></Author>
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How to Define a Document Script
Fragment

You can create a Template Fragment to return data from a
Document Script. You do this by creating a Script that
returns either an empty string or a string that contains raw
RTF. You add a reference to this Script in the 'Template
Fragment Document Options', and the returned RTF string
is added to the generated document.

This is an example of a Document Script you might create:

!INC Local Scripts.EAConstants-JScript

function main()

{

     var reporting as EA.DocumentGenerator;

     reporting = CreateDocumentGenerator();

     if(reporting != null)

     {

          if(reporting.NewDocument(""))

          {

               if(!reporting.LoadDocument("<filename>"))

               {

                    Session.Output( "Error: " +
reporting.GetLastError() );

               }
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               return reporting.GetDocumentAsRTF();

          }

     }

}

Create a Document Script Fragment

Ste
p

Action

1 Open or create a Template Fragment in the
Document Template Editor.

2 In the Document Template Editor, right-click on the
Template background and click on the icon.
The 'Document Options' dialog displays.

3 Select the 'Custom Query' page.

4 In the 'Template Fragment type' panel, select the
'Document Script' radio button.

5 A field displays to the right of the radio button panel;
click on the drop-down arrow and select the Model
Script to be used by your Template Fragment.

6 In the main text field on the tab, type the entry point
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of your Script that returns the RTF Text.
For example, in JScript, the call to your script would
be in the form:
     Main(#OBJECTID#);
(For VBScript, omit the semi-colon at the end.)

7 Click on the OK button to close the 'Document
Options' dialog.

8 In the 'Document Template Editor', in the 'Sections'
panel, select the 'Custom' checkbox to create the
'Custom' section.

9 Save the Template Fragment, and add a call to it in a
normal document template.
When run, this will return an RTF string that is
incorporated into the generated document.

Notes

The Model Search macros #..# can be used in the call·

statement that calls the procedure, but not in the procedure
code; in your call statement you can reference model
details using:
     -  #OBJECTID# to return the ID of the element
currently being processed by the document template
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     -  #PACKAGEID# and #Package# to return the ID of
the Package currently being processed by the
        document template
     -  #Branch# to get the IDs of the child Packages of the
current Package being processed, working
        recursively down to the lowest level of sub-Package;
this is only valid when processing a Package,
        elements return a 0 value
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How to Define a Custom XML Script
Fragment

Within a template fragment, you can create a query to report
values from an XML file produced by a
previously-generated script; for example, the data from a
simulation. The query operates on static data that is not
updated during generation of the document.

This is an example of the query format:

     Filename=<filepath>\<filename>.xml

     XPath=/EADATA/Dataset_0/Data/Row

The first line is the location of the XML file to process, and
the second line is the query to perform on that file, assuming
that the file content is:

     <EADATA>

         <Dataset_0>

             <Data>

                 <Row Name="NameValue"
Second="Value2"></Row>

                 <Row Name="NameValue2"></Row>

             </Data>

         </Dataset_0>

(c) Sparx Systems 2021 Page 228 of 416



Document Reports 2 September, 2021

     </EADATA>

You can then add fields within the 'Custom' section of your
Template Fragment, to refer to the data returned by the
query. For example, you might edit:

     custom >

     [right-click-to-insert-Custom-field(s)]

     < custom

to give:

     custom >

     Name - Second

     < custom

Creating a Custom XML Script Fragment

Ste
p

Action

1 Using the Scripting window, create a Model Script
that returns an XML file.

2 Open or create a Template Fragment in the
Document Template Editor.
Right-click on the Template background and click
on the icon.
The 'Document Options' dialog displays.
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3 Select the 'Custom Query' tab and, in the 'Template
Fragment type' panel, select the 'Custom XML'
option.

4 In the main text field on the tab, type the entry point
of your Script that returns the XML data.  For
example:
Filename=<filepath>\<filename>.xml

5 Click on the OK button to close the 'Document
Options' dialog.

6 In the Document Template Editor, in the 'Sections'
panel, select the 'Custom' checkbox to generate the
Custom section.

7 Within the 'Custom' section, right-click and select
the 'Insert Custom Field' option.
A prompt displays for the name of the field to create.

8 In response to the prompt, type the name of the data
field that is being returned by your script.
Click on the OK button.

9 Repeat steps 7 and 8 for each data field that you
want to include in your report.
Add any other formatting and content you need, to
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the Template Fragment.

10 Save the Template Fragment, and add it to a normal
Document Template.

Notes

The calling statement (not the script that is called) can·

reference the ID of the element or Package currently
being processed by the document template, using the
#OBJECTID# or #PACKAGEID# macros; for example,
MyRtfData(#OBJECTID#):
     -  #Branch# gets the IDs of the child Packages of the
current Package being processed,
        working recursively down to the lowest level of
sub-Package; this is only valid when
        processing a Package - elements return a 0 value
     -  #Package# gets the package_ID of the
currently-selected Package
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Adding Fragments to a Document
Template

A Template Fragment is a template that can be used as a
smaller sub-section of a normal document template. You do
not generate a report from a Template Fragment on its own;
instead you use a normal template that includes references
to one or more Template Fragments.

Fragments can be called into these sections in the template:

Package·

Element·

Attribute·

Method·

They cannot be called into other sections. When generating
a document report, as the report generator processes each
section in the template, if it encounters a reference to a
Template Fragment it will process that Fragment, inserting
its output in the appropriate location of the generated report.

Access

Ribbon Publish > Model Reports > Templates

Keyboard
Shortcuts

F8 > Templates
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Incorporating Template Fragments into a
Document Template

Ste
p

Action

1 Create the Template Fragment(s) to be included in
your document template, or identify system
Template Fragments to use.

2 Create a new document template, or open an existing
template in the document editor.

3 In the 'Sections' panel, select the checkbox against
each section that will refer to the Template
Fragment(s) ('Package', 'Element', 'Attribute' or
'Method').

4 In the 'Content' panel, at the appropriate point within
one of these sections, right-click and select the
'Insert Template' option.
The 'Select Template' dialog displays.

5 Click on the drop-down arrow and select the
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Template Fragment to insert.

6 Click on the OK button.
The tag {Template - <template name>} is inserted at
the current cursor position.

7 Repeat steps 4 to 6 for each Fragment you want to
insert into the document template.
Complete any other work you need to do on the
template, then save it and use it to run reports.

Editing or Switching Template Fragments

Right-click on the red Template tag > <required option>.

Option Action

View / Edit
Fragment

Opens the selected Template Fragment in
another instance of the Document
Template editor.
If you have selected a System Fragment,
you can view the Fragment but not edit it.
If you have selected a Model
(user-created) Fragment, you can edit the
Fragment.
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Override
Fragment

(Option available for a selected System
Fragment)
Opens another instance of the Document
Template Editor, where the System
Fragment is duplicated as a Model (user
created) Fragment with the same name.
You can edit this Fragment and save it,
and the original template will apply that
new Model fragment instead.

Switch
Fragment

Displays the 'Select Template' dialog;
click on the drop-down arrow and select
a different Template Fragment.

Notes

You can also add a Template Fragment to a document·

template by locating the Fragment in the Document
Publishing folder in the 'Resources' tab of the Browser
window and dragging the Fragment into the Document
Editor; Template Fragments are held in the Fragments
folders within the System Templates and Custom
Templates folders

To delete a Template Fragment from a Template, drag the·

cursor along the inserted name to highlight it, then press
the Delete key
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It is possible to embed a Template Fragment within·

another Fragment; however, this will slow down report
generation
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Editing Documents and Templates

Within Enterprise Architect you can create various
documents from templates, and you can create customized
templates to help tailor the documents to the needs and
standards of your organization. You can create Linked
Documents, Linked Document Templates and Document
(Report) Templates, amongst others. In each case, selecting
to create or edit the document opens the Document-Edit
ribbon, which provides a wide range of editing and
formatting facilities that you can use to develop your
documentation. This section explains how to perform
various editing tasks using the ribbon.

Each type of document can also have its own context menu
of additional options, and the editing window might also
have an option toolbar. These facilities are described in the
topics specific to the type of document.

Access

Ribbon Create or edit a document or template
file; the Document - Edit ribbon displays
automatically
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Option Descriptions

The descriptions of the Document - Edit ribbon options are
grouped according to the actions you are performing.

Actions

Creating and importing documents

Configuring the editor page display and formatting tools
shown

Moving through, searching and selecting text

Formatting characters and text strings

Formatting paragraphs and text blocks

Inserting tab points

Inserting sections, columns and page breaks, and
repaginating

Incorporating stylesheets, special texts and Tables of
Contents
Managing the base styles in the Normal.rtf style template
file

Inserting and editing page headers and footers, and
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footnotes and endnotes

Inserting tables

Inserting hyperlinks

Inserting images, OLE objects, frames and drawing
objects

Printer set up and printing documents

Checking spelling and use of words

Tracking, accepting and rejecting changes to text

Protecting document text from accidental change

Create and refer to definitions of Glossary terms in the
Project Glossary (using the 'Create | Glossary Definition'
menu option)

Notes

Throughout your document editing:·

     -  To undo one or more immediately previous edits,
press Ctrl+Z, or select the 'Undo' context menu
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        option; you can still undo a change even after you
have saved the change
     -  To redo one or more immediately previous undone
edits, press Ctrl+Y, or select the 'Redo'
        context menu option
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File Control

The 'File' panel of the 'Document Edit' ribbon provides a
number of options for changing and saving a document
report file contents as a complete file as well as for setting
page layout options, such as margins, and for printing the
document.

Access

Ribbon Document-Edit > File > File > [options]

File control options

To Action

Import a file Select the option 'Document-Edit > File >
File > Import File'. This imports the
contents of an existing document into the
current file. The file type in the dialog
defaults to .rtf, but you can import files in
a number of other formats. Click on the
drop-down arrow and select the
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required file type.
The 'Import File' option is useful when
creating documents from existing
documents external to Enterprise
Architect, such as your own corporate
standards templates and, in conjunction
with the 'New' option, of updating the
document from the external file.

Export a
Document
file

Select the option 'Document-Edit > File >
File > Save As (Export to File)'. This
saves your document to an external
document file.
The 'Export' option is useful for saving a
specific template or document to be
imported into another project.

Clear a file
for redesign

Select the option 'Document-Edit > File >
File > New (Clear Document)'. This
clears the existing contents of the
document.
If you have made any unsaved changes to
the file, the editor prompts you to save
them. If you want to protect those
changes, click on the Yes button to
display a browser screen and select a file
path and file name to save the changes to.
This is a method of clearing out an
existing document for redesign. As you
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do not change the name, all references to
it simply go to the changed content.

Roll back
changes to
previous
version

Select the option 'Document-Edit > File >
File > Reload from Repository' to roll
back the file contents to the
previously-saved version.

Save changes Select the 'Document-Edit > File > Save'
icon to save the file contents to the
current file.

Save
Template

Applicable to the Document Template
Designer and Linked Document template
editor.
The key combination Ctrl+Shift+S
invokes the 'Save As' command to save a
template contents under a new name,
which you are prompted to type in. This
command is not available when editing a
document - see 'Export a Document file'
instead.

Close the file
and editor

Click on the cross at the right of the
document tab or in the top right corner of
the Document Window.
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Print options

When you are editing a document or template, you can
manage print jobs within the Document Editor. You can
select from options to define the page layout, text to be
printed and number of copies, and to check the appearance
of the printing before actually submitting the print job.

To Action

Set the page
margins for
viewing and
printing the
document

Select the option 'Document-Edit > File >
File > Page Layout'.
The 'Page Parameters' dialog displays, on
which you can define the left, right, top
and bottom page margins in inches.
The 'Top' and 'Bottom' margins define
how much space is set aside to contain
header and footer text.
In the 'Header distance from the Page
Top' and 'Footer distance from the Page
Bottom' fields, type the separation of the
header and footer text from the edge of
the paper.

Set the
parameters
for the print
run

Select the option 'Document-Edit > File >
File > Printer Setup', or press
Ctrl+Shift+P.
The 'Setup Page' dialog displays for the
default printer, which you would have
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selected on the Windows 'Control' panel.
You can simply confirm or reselect the
core parameters such as page size, paper
source and page orientation, or click on
the Properties button to define more
advanced settings such as use of a
watermark, duplex printing and print
resolution.

Print your
document

Select the option 'Document-Edit > File >
File > Print Preview', or press Ctrl+P.
The 'Print' dialog displays, on which you
can select the pages to print and the
number of copies, and initiate the print
task.
You can also choose to print only a
selected part of the file. To do this,
highlight the required text before
selecting the 'Print' option. You can print
a highlighted block of:

Lines, or·

Characters·

Preview
document
before
printing

Select the option 'Document-Edit > File >
File > Print Preview' to display the
document as it would appear when
printed.
The editor displays either one page or
two - toggle the display by clicking on
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the One Page button or Two Pages
button. Scroll to further pages using the
scroll bar.
By default the preview rectangle is sized
to fit the current window; you can use the
'Fitted' field to enlarge or shrink the size
of the displayed pages as required.
Click on the Print button to display and
use the 'Print' dialog.
To return to editing mode click on the
Edit button, or on the 'Document-Edit >
File > File > Print Preview' menu option
again.
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Editor Display Options

Within the Document Editor, to help you edit the document
contents you can configure the page display and the
formatting tools visible, using the 'View' menu options in
the 'File' panel of the 'Document-Edit' ribbon.

Access

Ribbon Document-Edit > File > View > [options]

Editing tools and options

Menu Option Action

Page Layout
Mode

Select the option 'Document-Edit > File >
View > Page Layout Mode'. Toggles the
text display between page layout and full
window layout.

Borderless
Mode

Select the option 'Document-Edit > File >
View > Borderless Mode'. Toggles the
display of page borders, allowing the
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document to occupy the entire display
area.

Horizontal
Ruler

Select the option 'Document-Edit > File >
View > Horizontal Ruler'. Displays or
hides the ruler at the top of the page.
The ruler shows tab stops and paragraph
indentation marks; you can also use it to
create or delete tab stops.

Vertical
Ruler

Select the option 'Document-Edit > File >
View > Vertical Ruler'. Displays or hides
the ruler against the left edge of the page.
The ruler indicates the depth of the top
and bottom margins of the page.

Status
Ribbon

Select the option 'Document-Edit > File >
View > Status Ribbon'. Displays or hides
the status ribbon at the bottom of the
editing panel.
The status ribbon displays the current
page number, line number and column
number; it also indicates the current
insert/overtype mode (at the left end of
the ribbon).

Hidden Text Select the option 'Document-Edit > File >
View > Status Ribbon'. Shows or hides
'hidden' text.
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Text formatted with the 'Hidden' option is
shown with a dotted underline; when the
'Hidden Text' option is turned off, the
hidden text is not visible and the normal
text closes up to single character or line
spacing.

Field Names Select the option 'Document-Edit > File >
View > Field Names'.
Applicable to all document editing:
If you have inserted any data fields and
values, the 'Field Names' option toggles
between displaying field names in the
text and displaying the field values.
Applicable to the Document Template
Designer:
As you develop your custom document
template, you right-click on sections to
insert field markers and select the 'Insert
Fields' option. The 'Field Names' option
makes the 'Insert Fields' option available.

Hyperlink
Cursor

Select the option 'Document-Edit > File >
View > Hyperlink Cursor'.
Applicable to the Document Template
Designer and Linked Document
Template Editor:
Toggles the cursor icon when you 'mouse
over' a hyperlink, between your default
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image (usually a line or arrow) and a
'pointing hand'.

Page
Header/Foote
r

Select the option 'Document-Edit > File >
View > Page Header/Footer'. Displays or
hides the text of page headers and footers.
To edit the header or footer text, select
the option 'Document-Edit > Edit > Edit
> Page Header/Footer'.

Zoom Select the option 'Document-Edit > File >
Fixed Zoom'. A short menu displays,
from which you can select from a range
(10% to 200%) of percentages of normal
size by which to shrink or enlarge the
display of the document content. The
menu also has a 'Custom' option that you
can select to display the 'Zoom
Parameter' dialog, on which you define
the percentage you need, between 10%
and 500%.
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Styles, Special Text and Table of
Contents

Using the Document Editor, you can define
character-based styles and paragraph-based styles.

A character style constitutes a set of character formatting·

attributes and is applied to a character string

A paragraph style constitutes both a set of character·

formatting attributes and a set of paragraph formatting
attributes, and is applied to one or more paragraphs

You can also include special, structured text in the
document, such as page number, date and time, table of
contents and text input fields.

Every custom template or document you create is
automatically based on the Normal.rtf template file. This
provides default styles, numbering and other base formats,
which you can change using the Document Editor facilities
and save either as a specific document, template or
document report Stylesheet.

Access

Ribbon Select options from the 'Document Edit'
ribbon bar.
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Editing Styles

To Action

Create and
edit styles

Select the option 'Document-Edit > Edit
> Edit > Edit Style'. The 'Edit Stylesheet'
dialog displays.
Select the appropriate radio button to
define a paragraph style or a character
style.
If you want to update an existing style,
select that style from the list box. If you
want to create a new style, select the
'Create a new style' checkbox, and type a
name in the 'Style Name' field. Short style
names are best, but you can type in long
names if necessary.
To begin defining the style properties,
click on the OK button.
You can use the ruler, toolbar or context
menu selections to modify the style
properties; for an existing stylesheet item,
these also reflect the currently-selected
properties.
After you have defined the required style,
you set it by either selecting the
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'Document-Edit > Edit > Edit > Edit
Style' menu option again or clicking
anywhere in the document:

If you modified an existing stylesheet·

item, the document automatically
reflects the updated style
If you created a new stylesheet item,·

you can apply the style to highlighted
text by selecting the 'Document-Edit >
Font > Font > Style' or 'Document-Edit
> Paragraph > Paragraph > Style'
ribbon options

Update the
standard
styles used

Right-click on the document and select
'Update Styles > [select Stylesheet to
update]'

Re-import the standard styles from·

Normal.rtf, into the current document,
or
Apply one of the system-supplied·

standard Stylesheets to the document
A submenu displays from which you
select the appropriate style source.
This is useful for maintaining consistency
of styles across all your documents,
including such things as numbering
formats.

Edit the This option operates specifically on the
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hyperlink
style

style of any hyperlinks you want to
create.
Select the option 'Document-Edit > Font
> Font > Hyperlink', then select the font,
font size and emphasis (bold, italic) you
want to apply. You cannot remove the
hyperlink underline or change the color
from blue.
Select the option 'Document-Edit > Font
> Font > Hyperlink' again to set the style.
When you create a hyperlink from this
point onwards, the link text will be in the
style you have set. Links created before
you changed the style remain in the
earlier style.

Apply
character
styles

Highlight the text to be styled and select
the option 'Document-Edit > Font > Font
> Style'; the 'Select a Style' dialog
displays, from which you select the
character style to apply.
Alternatively, select a character style
from the drop-down list in the 'Font'
panel of the 'Document-Edit' ribbon.

Apply
paragraph
styles

Highlight the text to be styled and select
the option 'Document-Edit > Paragraph >
Paragraph > Style'; the 'Select a Style'
dialog displays, from which you select
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the paragraph style to apply.
Alternatively, select a paragraph style
from the drop-down list in the 'Font'
panel of the 'Document-Edit' ribbon.

Clear unused
lists from the
template or
document

Select the option 'Document-Edit > File >
Manage > Remove Unused Lists'.
The system prompts you to confirm
removal of the lists when the file is
saved. Click on the Yes button.
When you have list formats such as for
bullet or numbered lists in the file, and
you have reversed or otherwise not used
them, the formatting instructions for
applying these lists to the text remain in
the file. You can see this when you set up
the list and then toggle the bullets or
numbering on and off.
If you select the 'Remove Unused Lists'
option, when you save the file the unused
format instructions are removed from the
file, reducing the number of list formats
maintained in the file and reducing file
size.

Insert date
and time
fields

At the point in the text at which to insert
the current date and/or time field, select
the option 'Document-Edit > Edit > Insert
> Date and Time'.
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The 'Insert Current Date/Time' dialog
displays, from which you can select the
required date and time format. You can
insert the date or time fields separately, or
as a combined field.
The date and time are automatically
updated whenever the page text is
refreshed (that is, clicked on).

Insert a table
of contents

Edit the 'Table of Contents' level styles
(TOC 1 to TOC 9) as required, using the
option 'Document-Edit > Edit > Edit >
Edit Style'. Add at least one 'Heading n'
style to the document.
Move the cursor to the point at which to
insert the Table of Contents, and select
the option 'Document-Edit > Edit > Insert
> Table of Contents'. A small dialog
displays in which you specify the highest
and lowest Table of Contents levels to
apply in the table in this document; when
you have specified the levels, click on the
OK button. If there are corresponding
headings within the specified range, the
Table of Contents displays; otherwise, the
line remains blank.
To create a Table of Contents heading
that displays in the generated document,
type the appropriate text at least one line
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above the inserted list and define the style
as required - use a Heading style to
include the heading itself in the Table of
Contents, otherwise use a non-heading
style.
The Table of Contents is automatically
generated and updated whenever
generation or repagination occurs.

Insert your
own data
fields

Move the cursor to the point at which to
insert the data field and select the option
'Document-Edit > Edit > Insert > Data
Field' menu option.
The 'Data Field Parameters' dialog
displays, in which you enter the field
name and the data value. Wherever you
insert the data field, the values are
automatically updated with the most
recent data value you enter.

Insert your
own text
entry field

You insert text entry fields so that anyone
using the document can type in their own
text in response to either a lead-in
sentence or the field name itself.
Move the cursor to the point at which to
insert the text entry field and type in any
lead-in text you want to use. Then select
the option 'Document-Edit > Edit > Insert
> Text Input Field'.
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The 'Input Field Parameters' dialog
displays, in which you enter:

The field name·

The initial value to display as a default·

The maximum length of the field·

The text font in which to display the·

text
You can also specify whether or not the
field has a border.

For example: 
If you insert a text entry field in a
template, any document generated from
the template shows the typed entry as
normal text, not boxed.

Insert a
selectable
checkbox

You insert checkboxes in a document so
that the users of the document can mark
the item represented by the box. The
checkbox can be selected and deselected
in a document, a template and a
document generated from a template.
Move the cursor to the point at which to
insert the checkbox and select the option
'Document-Edit > Edit > Insert >
Checkbox Field'.
The 'Checkbox Field Parameters' dialog
displays, in which you enter:

The field name (which does not display·
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in the text)
Whether the checkbox defaults to·

selected
The size of the checkbox·

Click on the OK button.

Insert a
selection
(drop-down)
field

You insert selection fields in a document
so that the users of the document can
select one of the items presented in a
drop-down list.
Move the cursor to the point at which to
insert the checkbox and select the option
'Document-Edit > Edit > Insert >
Selection Field'.
The 'Selection Field Parameters' dialog
displays, in which you enter:

The field name·

The options to present in the·

drop-down list (separated by the |
character)
The value from this list to display as a·

default
Click on the OK button.

Insert a
non-breaking
space

Move the cursor to the point at which to
insert the non-breaking space and select
the 'Insert | Non-breaking Space' menu
option.
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Insert a
non-breaking
dash

Move the cursor to the point at which to
insert the non-breaking dash and select
the 'Insert | Non-breaking Dash' menu
option.

Insert an
optional
hyphen

Move the cursor to the point at which to
insert the hyphen and select the 'Insert |
Optional Hyphen' menu option.

Insert a
Project
Constant

(For Document Report templates.)
You can create Project Constants to insert
a specific text string wherever you place
the flag for that string. You can therefore
design a report containing many instances
of that string, but create and edit the
actual value in one place - on the 'Project
Constants' tab of the 'Generate Report'
dialog.
Right-click at the point at which you
want to insert the Constant (flag), and
select the 'Project Constants | <flag
name>' option. The Constant displays at
that point in the template, and when the
report is generated the flag is replaced by
its defined value.
You can insert a Project Constant
anywhere in the template - in the text
body, section headings, headers, footers,
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endnotes or footnotes. Project Constants
are available to any template in the
model.

Define level
numbering in
generated
document

(Used in the Document Template Editor.)
Select the option 'Document-Edit > Edit
> Edit > Lists and Overrides'.
Set up the numbering list and the list
overrides.
Apply the numbering list to the headings
set for Packages and elements, using
paragraph numbering.

Use
double-byte
characters

Select the option 'Document-Edit > Edit
> Edit > Inline Ime'.
Double-byte characters are, broadly,
complex characters used in languages
such as Japanese, Chinese, and Cyrillic.
With this menu option, you can use both
single-byte characters and double-byte
characters in your text, without having to
switch to an external Input Method Editor
(IME) application.
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Manage Page Counting

As you set up the document structure, especially if you
divide the document up into sections, you can insert page
counts, insert and reset page numbers, and repaginate the
document to update the page number, page count and Table
of Contents.

Access

Ribbon Document-Edit > Edit > Insert > Page
Number
Document-Edit > Edit > Insert > Page
Count
Document-Edit > Edit > Edit >
Repaginate

Insert the page number

Position the cursor at the point at which to display the page
number, and select the option 'Document-Edit > Edit >
Insert > Page Number'.

The page number is displayed in gray.
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Insert the page count

Position the cursor at the point at which to display the total
number of pages in the document, and select the option
'Document-Edit > Edit > Insert > Page Count'. The page
count is displayed in gray.

Repaginate the document

Select the option 'Document-Edit > Edit > Edit >
Repaginate'.

The 'Page Number' and 'Page Count' fields and the Table of
Contents are all updated.
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The Normal.rtf Style Template

Every custom template or document you create is
automatically based on the 'Normal.rtf template' file. This is
an external file that provides default styles, numbering and
other base formats, such as the default list numbering,
MasterList. You can edit the Normal.rtf file to apply your
own default styles to the documents and templates you
create. You also have the options of:

Editing selected styles within a template, so that reports or·

documents created from that template always have those
different styles

Using the standard Stylesheets or creating custom·

Stylesheets, to optionally apply to any document report
you generate independent of the template you are using

The Normal.rtf template is stored in %APPDATA%\Sparx
Systems\EA\RTF Templates.

Edit Normal.rtf

Ste
p

Action

1 Open the Document Template Designer and create
a new template called, for example, Normal.

2 Select the 'Document-Edit > File > File > Import
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File' menu option to import the Normal.rtf file into
the Normal template.

3 Modify the Normal template style definitions as you
want, and remove any text before you save the
template.

4 Export the modified template ('Document-Edit > File
> File > Save As (Export to File))' back into the
Normal.rtf file in the RTF Templates folder. The
modified styles will be applied to all documents and
templates you create from now on.

Notes

You must not edit the SSbookmark style; this defines the·

section styles and must be preserved

A related feature in the Document Editor is the 'Update·

Styles' context menu option, which you select to update
an existing template to reflect any changes to Normal.rtf,
or to apply a standard Stylesheet to the template
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Scroll, Search and Select Text

In the Document Editor, you can move the cursor through
the template or document using either the keyboard or the
mouse. Alternatively, you could move the cursor to a
position in the file by searching for a text string.

Having positioned the cursor on the required text, you can
then highlight and manipulate it with various options, in
addition to the standard 'mouse-click-and-drag' and the
'Ctrl+X', 'Ctrl+C' and 'Ctrl+V' keys.

Cursor Positioning

Scroll Using Options

Keyboard
Keys

Press:
Ctrl+Left Arrow to move to the·

previous word
Ctrl+Right Arrow to move to the next·

word
Ctrl+Up Arrow to move to the first·

column of the current line (if not
already on the first column) or the first
column of the previous line
Ctrl+Down Arrow to move to the first·

column of the next line
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F10 to display the 'Jump to line·

number' dialog; type in a line number
to jump to, and click on the OK button

Mouse To perform various scrolling functions,
click on the vertical or horizontal scroll
bars. These functions are available when
the scroll bars have been enabled by the
startup parameters.
Vertical Scroll Bar: To scroll the screen
up or down by one line, click on the
arrows on either end.
To scroll the screen up by one page, click
above the elevator (the block within the
scroll bar); similarly, to scroll the screen
down by one page, click below the
elevator.
You can also scroll the screen up or down
by dragging the elevator in the
appropriate direction.
Horizontal Scroll Bar: To scroll the
screen left or right by one column, click
on the arrow on the appropriate end of
the bar; to scroll the screen left or right by
half a screen, click on the bar on the
appropriate side of the elevator.
You can also scroll the screen left or right
by dragging the elevator along the bar in
the appropriate direction.
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Text Search

When you search for a text string, the dialog for specifying
the search details does not persist on the screen, so you can
simply use keyboard keys or a menu option to continue the
search without obscuring text behind a dialog.

To Action

Find first
instance of a
text string

Select the option 'Document-Edit > Edit
> Search > Search', or press F5.
The 'Search String Parameters' dialog
displays. Specify:

The term to search for·

Whether to search from the start of the·

file or forwards or backwards from the
current cursor position, and
Whether the search should exactly·

match the case of the search term
The editor searches for the first instance
of the specified character string as
defined by the parameters.

Find next
instance of a

Select the option 'Document-Edit > Edit
> Search > Search Forward', or press
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text string Ctrl+F.
The editor searches forwards through the
file for the next instance of the previously
specified text string, and highlights it.

Find previous
instance of a
text string

Select the option 'Document-Edit > Edit
> Search > Search Backward', or press
Ctrl+Shift+F.
The editor searches backwards through
the file for the next instance of the
previously specified text string, and
highlights it.

Replace a
text string

Select the option 'Document-Edit > Edit
> Search > Replace', or press F6.
The 'Replace String Parameters' dialog
displays, in which you specify:

The text string to locate·

The text string to replace it with·

Whether to search the whole document·

or just a highlighted block of text
Whether to confirm each replacement·

before making the change
If you want to confirm replacement, a
prompt displays for each occurrence of
the search term to confirm or skip
replacing that occurrence.
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Text Selection

To Action

Highlight a
word

Double-click on the word.

Highlight a
line

Move the cursor onto the line and press
F8.

Delete a line Press Shift+F9 to delete the current line;
the remaining lines close up.

Paste special
objects

Select the option 'Document-Edit > Edit
> Edit > Paste Special'; the 'Paste Special'
dialog displays, listing the appropriate
data type formats for inserting the copied
object.
Click on the Paste button to embed the
data into your application, or click on the
Paste Link button to create a link to the
original file.

'Native Object Format' - If available,·

this is the first format in the list box;
you can edit data in this format using
the original application, by
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double-clicking the object
'Formatted Text' - A text format; this·

option offers the most suitable format if
the data is pasted from another text
output application, as the font and
formatting attributes are reproduced
accurately
'Unformatted Text' - Another text·

format; this option pastes the text
without retaining the formatting
information
'Picture Format' - The data is available·

in Picture format; you can later edit the
object, by double-clicking on it and
invoking the Microsoft MS Draw
application
This format is preferable to the Bitmap
and the Device Independent Bitmap
formats
'Device Independent Bitmap' and·

'Regular Bitmap' formats - The data is
available in bitmap formats; you can
later edit the object, by double-clicking
on it and invoking the Microsoft MS
Draw application
The editor converts these formats into
the Picture format before calling the
drawing application
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Format Text

When you create a document template or document, the
default character or text styles are already defined, as they
are derived directly from the Normal.rtf style template file.
Within the document you can edit any of these character
styles or apply individual formatting to text strings as you
require.

When you change the format of existing text, any new
characters you type immediately after that text automatically
assume the formatting characteristics you have applied.

Access

Ribbon Highlight the text to which to apply the
format, then select options from the 'Font'
panel of the 'Document-Edit' ribbon bar.

Text formatting options

To Action

Apply Highlight the text to which to apply the

(c) Sparx Systems 2021 Page 273 of 416



Document Reports 2 September, 2021

character
format

format, and use one or more of these
menu options or key combinations.
From the 'Font' panel of the
'Document-Edit' ribbon, choose:

 or 'Font | Normal', or press Alt+0·

 or 'Font | Bold', or press Ctrl+B·

 or 'Font | Italic', or press Ctrl+I·

 or 'Font | Underline', or press·

Ctrl+U
 | 'Double Underline', or 'Font |·

Double Underline', or press Ctrl+D
 or 'Font | Subscript', or press Alt+5·

 or 'Font | Superscript', or press·

Alt+4
 or 'Font | Strike', or press Alt+6 (puts·

a line through the text)
 | 'Double Strike', or 'Font | Double·

Strike'
 | lowercase·

 | UPPERCASE·

Font | All Caps·

Font | Small Caps·

To reset any character format, highlight
the text and select the option  or 'Font |
Normal', or press Alt+0.
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Change font
typeface and
point size

Highlight the text to change and select
the required typeface from the 'Font'
drop-down list in the 'Font' panel of the
'Document-Edit' ribbon bar. Select the
required point size from the 'Size'
drop-down list, beside the 'Font' list.
Alternatively, select the option
'Document-Edit > Font > Font > Fonts'.
The 'Font Selection' dialog displays, from
which you select the required typeface
and point size. Click on the OK button.

Change
character
style

Highlight the text to change and select
the required character style from the
'Style' drop-down list in the 'Font' panel
of the 'Document-Edit' ribbon bar.
Alternatively, select the option
'Document-Edit > Font > Font > Style'.
The 'Select a Style' dialog displays,
listing the currently-defined character
styles in the template stylesheet. Select
the required style and click on the OK
button.

Change the
color of text,
background
(permanent
highlight) or

Highlight the text to change and select
one or more of these options, as required:

Document-Edit > Font > ·

Document-Edit > Font > ·

Document-Edit > Font >  >·
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underline Underline Color
In each case, the 'Color' dialog displays,
through which you can select or define
the required color.
When you have selected a color, click on
the OK button.

Change
character
spacing

Normal character spacing (the space
between characters) is 20 twips; if you
want to change this (or return to it),
highlight the text to adjust, and select the
option 'Document-Edit > Font > Font >
Spacing'. The 'Character Spacing' dialog
displays.
Select the radio button to expand or
compress spacing, or to return to normal
spacing; if you are changing from normal
spacing, enter the number of twips to set
the spacing to.
Click on the OK button.

Change
horizontal
scaling

Highlight the text to change and select
the option 'Document-Edit > Font > Font
> Horizontal Scaling'.
The 'Horizontal Character Scaling' dialog
displays. Enter a percentage value for the
amount of scaling required (valid values
are 10 to 999 inclusive), then click on the
OK button. The text (both characters and
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spaces) is scaled horizontally, by the
specified amount.

Hide text Hidden text is not displayed on the screen
or printer, but remains in the document
and is not deleted.
Highlight the text to hide and select the
option 'Document-Edit > Font > Font >
Hidden', or press Ctrl+H.
The highlighted text is not displayed and
the rest of the text closes up.
To view hidden text, select the option
'Document-Edit > File > View > Hidden
Text'; you can then make the text normal
again by highlighting it and deselecting
the option 'Document-Edit > Font > Font
> Hidden'.

Create a box
around text

Highlight the text to box and select the
'Font | Boxed' menu option; this creates a
broken-line border around the selected
text.

Protect text Highlight the line, block or section of text
to be protected, and select the option
'Document-Edit > Font > Font > Protect'.
The selected text is displayed in a gray
font, and cannot be edited.
To release the text for editing again,
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highlight it and reselect the option
'Document-Edit > Font > Font > Protect'.
You can select and release a portion of
the protected text; the remainder stays
protected.

Note: If the ribbon option is unavailable,
or the text is not faded, it means that you
have not removed the protection lock.
(See Protect Document Contents.)
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Create Tables

Within any document report, you can present information
using simple tables with any number of rows and columns.
In a report template, it is also possible to render a model
section as a table, defined with any number of columns but
with only two rows. You can either add your own text to the
tables, or populate the table cells with fields that extract
information from your model.

Access

Ribbon Document-Edit > Paragraph > Table >
[option]

Create and format a table

To Action

Insert a table
in the
document

Position the cursor on the point in the text
to create the table, and select the option
'Document-Edit > Paragraph > Table >
Insert Table'.
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The 'New Table Parameters' dialog
displays, in which you specify the
number of table rows and columns. For a
model section table in a report template
you can accept the default values of two
rows and three columns. Click on the OK
button.
Your table might be invisible; if so, select
the option 'Document-Edit > Paragraph >
Table > Show Gridlines' to reveal the
table and cell borders in dotted lines.
These lines are for guidance in creating
the document, and do not display on the
printed document. You can add printable
borders using other context menu options.
The editor initially creates a table with
cells of equal width across the page; you
can change the cell width by dragging the
cell borders using the mouse, or using
other context menu options.

Insert a new
row above
the current
row

Click on a row and then select the option
'Document-Edit > Paragraph > Table >
Insert Row'.

Insert a new
column to the
left of the

Click on a column and then select the
option 'Document-Edit > Paragraph >
Table > Insert Column'.
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current
column

Merge cells Highlight the cells to merge and select
the option 'Document-Edit > Paragraph >
Table > Merge Cells'.
The width and/or height of the resulting
cell is the sum of the widths and/or the
sum of the heights of the merged cells.
You can merge cells across a row, down
a column, and in a block spanning both
rows and columns.

Split a cell Select the cell to split and select the
option:

'Document-Edit > Paragraph > Table >·

Split Cell Horizontally' to split the
selected cell into two cells of equal
width within the column
'Document-Edit > Paragraph > Table >·

Split Cell Vertically' to split the cell
into two cells of equal height, doubling
the height of the whole row

Any text in the original cell is assigned to
the first cell, and the second cell is
created empty.

Delete cells Select the cells to delete and select the
option 'Document-Edit > Paragraph >

(c) Sparx Systems 2021 Page 281 of 416



Document Reports 2 September, 2021

Table > Delete Cells'.
The 'Delete Table Cells' dialog displays,
on which you specify whether to delete:

Cells - deletes the highlighted cells;·

realign the column and/or row after
doing this
Columns - deletes the column or·

columns containing the highlighted
cells, or
Rows - deletes the row or rows·

containing the highlighted cells
If you delete all cells in a table, the table
itself is automatically deleted.

Position the
table on the
page

Click on any part of the table and select
the option 'Document-Edit > Paragraph >
Table > Row Position'.
The 'Table Row Alignment' dialog
displays, on which you select a radio
button to left-justify, center or
right-justify the table on the page.
Leave the 'All Rows in the Table'
checkbox selected.
This menu option has greater effect if the
table is narrower than the page or text
column.

Set the height Highlight the rows to adjust and select
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of a row, or
all rows

the option 'Document-Edit > Paragraph >
Table > Row Height'.
The 'Row Height Parameters' dialog
displays; you can select to:

Allow the row height to be determined·

automatically
Set a minimum row height, or·

Set an exact row height·

If you are setting the height, type the
value in twips.
You can apply the setting to the selected
rows only, or select the 'Apply to all rows
in the current table' checkbox to set the
height of all rows in the table.

Add a header
row

Select the top row of the table, and then
select the option 'Document-Edit >
Paragraph > Table > Header Row'. Apply
any heading text, settings and formatting
to the highlighted row.
In the document or compiled report, the
heading row is repeated at the top of the
columns each time the table flows on to a
new page. In a report, if the heading row
is populated with the values from field
names, the heading rows on subsequent
pages reflect the values from that first
row.
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This option operates on the single row at
the top of the table, and not on multiple
rows. If you edit the table and add a row
to the top of the table to act as a new
header, selecting the menu option on the
new row clears the previous setting.

Keep row
text together
if it continues
over a page

Select the rows to protect (preferably all
rows in the table) and select the option
'Document-Edit > Paragraph > Table >
Keep Row Together'.
If the row continues over the end of the
page, the whole row is moved to the top
of the next page.

Set the text
flow in the
table rows

Select the rows and select the option
'Document-Edit > Paragraph > Table >
Row Text Flow'.
The 'Table Text Flow' dialog displays, on
which you select a radio button to set the
text flow in the rows to:

Left to right·

Right to left·

Default·

You can apply the text flow to just the
selected rows, or select the 'Apply to all
rows in the current table' checkbox to set
the text flow for all rows in the table.
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This option also moves the selected rows
over to the appropriate side of the page or
column.

Set the width
of selected
cells

Select the cells to act on and select the
option 'Document-Edit > Paragraph >
Table > Cell Width'.
The 'Set Cell Width' dialog displays, on
which you set the width of the cells and
the margin between the text and the left
and right sides of each cell, both in twips.
You can apply the settings to:

All cells in the table·

The selected cells only·

The complete column or columns·

containing the selected cells, or
The complete row or rows containing·

the selected cells

Define the
width of the
cell borders

Select the cells to act on and select the
option 'Document-Edit > Paragraph >
Table > Cell Border Width'.
The 'Set Cell Border' dialog displays, on
which you set the width of the lines at
any or all of the top, bottom, left and right
of the selected cells. If you want the
border to enclose:

The selected cells as a block, select the·
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'Draw outline border around the
selected cells' checkbox
Each selected cell separately, leave the·

checkbox unselected
You can also set the margin between the
text in each cell and the left and right
borders, in twips, and apply all the
settings to:

All cells in the table·

The selected cells only·

The complete column or columns·

containing the selected cells, or
The complete row or rows containing·

the selected cells

Define the
color of the
cell borders

Select the cells to act on and select the
option 'Document-Edit > Paragraph >
Table > Cell Border Color'.
The 'Set Cell Border Color' dialog
displays, on which you set the color of
each of the lines at the top, bottom, left
and right of a cell, or all of the cell
borders at once.
You can apply the settings to:

All cells in the table·

The selected cells only·

The complete column or columns·

containing the selected cells, or
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The complete row or rows containing·

the selected cells

Define the
degree of
shading on
the cell color

Select the cells to act on and select the
option 'Document-Edit > Paragraph >
Table > Cell Shading'.
The 'Cell Shading Parameters' dialog
displays, in which you type the shading
percentage.
Shading is the intensity of the cell
background color, expressed as a
percentage, and is uniform across the
selected cells. If the cells have no colored
background, a shading of 0% is white.
For colored backgrounds, 0% is the color
initially set. In all cases, a shading of
100% is black.
You can apply the setting to:

All cells in the table·

The selected cells only·

The complete column or columns·

containing the selected cells, or
The complete row or rows containing·

the selected cells

Define the
background
color of the

Select the cells to act on and select the
option 'Document-Edit > Paragraph >
Table > Cell Color'.
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cell The 'Cell Color Parameters' dialog
displays. Click on the Set Color button
to display the 'Color' dialog, on which
you select a basic color or define a more
specific color.
When you have selected the color, click
on the OK button.
You can apply the setting to:

All cells in the table·

The selected cells only·

The complete column or columns·

containing the selected cells, or
The complete row or rows containing·

the selected cells

Vertically
align text in
cells

Select the cells to act on and select the
option 'Document-Edit > Paragraph >
Table > Cell Vertical Align'.
The 'Cell Vertical Alignment' dialog
displays, on which you select to align the
text in the selected cells by the top, center
or bottom of the cell or the baseline of the
lowest top line of text.
Text in a table defaults to being aligned
with the top of the cell and, as you type it
in, it scrolls downwards. You can change
this alignment to the center or bottom of
the cell so that text scrolls out from the
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center or up from the bottom of the cell.
If you have special formatting - such as
'before-paragraph' spacing - you can align
the text to the base of the lowest first line
(the baseline), so that text in a row of
cells is aligned with the special formatted
text rather than with the top or bottom of
the cell. If the special formatting is
changed or removed, the text remains
aligned.
You can apply the setting to:

All cells in the table·

The selected cells only·

The complete column or columns·

containing the selected cells, or
The complete row or rows containing·

the selected cells

Rotate the
text of a cell
to display
vertically

Select the cells to act on and select the
option 'Document-Edit > Paragraph >
Table > Cell Rotate Text'.
The 'Cell Text Rotation' dialog displays,
on which you select to display text
vertically up the cell, vertically down the
cell or, if the text is already vertical,
horizontally across the cell,
Text in a table defaults to running
horizontally across the cell from left to
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right, and scrolling down the cell from
top to bottom. You can change the text
position so that the text is rotated through
90 degrees to display:

From top to bottom, scrolling across·

the cell from right to left, or
From bottom to top, scrolling across·

the cell from left to right
If the text is running horizontally, you
can type as much as you need - the row
height increases to accommodate the text.
If the text is running vertically, you adjust
the row height and column width
manually to accommodate your text.
You can apply the setting to:

All cells in the table·

The selected cells only·

The complete column or columns·

containing the selected cells, or
The complete row or rows containing·

the selected cells

Select a
column

Click on a cell and select the option
'Document-Edit > Paragraph > Table >
Select Current Column'.
The whole column is highlighted and
selected for further formatting.
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Show
gridlines

Show or hide grid lines for the current
table. Note that, for printing purposes,
'Border Width' must be set to a non-zero
value.

Notes

Under some circumstances, a table in a generated report·

might repeat the header row rather than the output row; if
this occurs, create another row in the table between the
header row and the output row, and leave this blank

(c) Sparx Systems 2021 Page 291 of 416



Document Reports 2 September, 2021

Format Paragraphs

When you create a document template or document the
default paragraph styles are already defined, as they are
derived directly from the Normal.rtf style template file.
Within the document you can edit any of these paragraph
styles or apply individual formatting to text blocks as you
need.

Each formatting option operates on the current paragraph, or
on a highlighted block of text.

Access

Ribbon Document-Edit > Paragraph > Paragraph
> [options]

There is also a range of icons in the
'Paragraph' panel of the 'Document-Edit'
ribbon, that provide direct access to
commonly used paragraph formatting
options

Paragraph formatting options
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To Action

Clear all
paragraph
formatting

Select the 'Paragraph | Normal' menu
option.
All paragraph formatting applied to the
current paragraph or selected text will be
removed.

Center text Select the 'Paragraph | Center' menu
option, or press Alt+8.

Right-justify
text

Select the 'Paragraph | Right Justify'
menu option, or press Alt+9.

Justify both
sides of text

Select the 'Paragraph | Justify Both' menu
option.

Double
Space

Select the 'Paragraph | Double Space'
menu option to put a double line space
between paragraphs.

Indent
paragraph
left

Select the 'Paragraph > Indent Left' menu
option, or press Alt+L.
Select the option again to increase the
indent.
To reduce or cancel the indent, click on
the 'Decrease Indent' icon in the Ribbon.
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Indent
paragraph
right

Select the 'Paragraph | Indent Right' menu
option or press Alt+R.
Select the option again to increase the
indent.

Create
hanging
indent

Select the 'Paragraph | Hanging Indent'
menu option, or press Alt+T.
Select the option again to increase the
indent of all lines below the first.

Keep
paragraph
lines together

Select the 'Paragraph | Keep Together'
menu option.
The editor attempts to keep all lines
within the paragraph on the same page.

Keep
paragraphs
together

Select the 'Paragraph | Keep with Next'
menu option.
The editor attempts to keep the last line
of the current paragraph and the first line
of the next paragraph on the same page.

Prevent
'widow' and
'orphan' lines

Select the 'Paragraph | Widow/Orphan
Control' menu option.
The editor attempts to avoid having:

the first line of the paragraph on the·

previous page ('widow' line)
the last line of the paragraph on the·
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next page ('orphan' line)

Start text on
new page

Move the cursor to the point at which to
start the new page, and select the
'Paragraph | Page Break Before' menu
option.

Insert border
and shading
for text block

Select the 'Paragraph | Border and
Shading' menu option.
The 'Paragraph Box Parameters' dialog
displays, on which you specify:

Which sides of the box to display·

(including a line between text lines)
Whether the lines are thick or doubled·

The degree of gray shading behind the·

text
The color of the lines·

Define line
spacing

Select the 'Paragraph | Paragraph Spacing'
menu option.
The 'Paragraph Spacing Parameters'
dialog displays, on which you specify the
line spacing and the point spacing before
and after lines.
Alternatively, to just set double line
spacing, select the 'Paragraph | Double
Space' menu option.
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Set a
background
color for text
space

Select the 'Paragraph | Background Color'
menu option.
The 'Color' dialog displays, on which you
select the background color.
The editor highlights the full width of the
page in that color, for the selected lines.

Create a
bulleted list

Select the 'Paragraph | Bullet' menu
option.
The editor formats the lines into a simple
bullet list.
If you want to indent the list (or a part of
it) further, select the 'Paragraph | Increase
Level' menu option. If you have increased
the indent but now want to decrease it,
select the 'Paragraph | Decrease Level'
option.

Create a
numbered list

Highlight the required lines of text and
select the 'Paragraph | Numbering' menu
option.
The editor formats the lines into a simple
numbered list.
To create multiple-level numbered lists,
see Set the list characters.

Apply
numbering to

(Used in the 'Document Template
Editor'.)

(c) Sparx Systems 2021 Page 296 of 416



Document Reports 2 September, 2021

paragraphs Set up a numbering list and overrides1.
('Document-Edit > Edit > Edit > List
and Overrides > Create List Item' and
'Create List Override').
Apply the numbering levels to the2.
template sections ('Document-Edit >
Paragraph > Paragraph > List
Numbering').

Apply a
paragraph
style from the
template
stylesheet

Select the 'Paragraph | Style' menu
option.
The 'Select a Style' dialog displays,
listing the currently-defined paragraph
styles in the template stylesheet.
Select the required style and click on the
OK button.

Set text flow
in document

To set the text flow for:
A highlighted block of text, select the·

'Document-Edit > Paragraph >
Paragraph > Text Flow' ribbon option;
the 'Paragraph Text Flow' dialog
displays
The entire document, select the·

'Document-Edit > Edit > Document
Text Flow' menu option; the 'Document
Text Flow' dialog displays

In either case, select the required text
flow direction and click on the OK
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button. The options are:
Left to right·

Right to left·

Default·

The 'Default' action depends on the
language setting of the system; for
example, if the system language is
Hebrew or Chinese, the default text flow
is right to left.

Paragraph
Marker

Displays or hides the various space
markers in the text, such as:

The paragraph marker at the end of·

each paragraph
The Tab indicators between tabbed·

blocks of text, and
The blank character marker between·

words
This option is useful when working with
page-formatted text that is structured
using both style definitions and
key-strokes.

Set the list
characters

When you have set up your bulleted or
numbered list elements, you can toggle
between the list character options using
the drop-down arrow icon just to the left
of the bullet list icon on the lower toolbar
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of the document template editor.
When you click on this icon, you are
prompted to select between a single-level
list format and a multiple-level list
format. When you select one of these
options, you then make a further selection
between:

Single-level: Arabic numerals, Roman·

numerals, upper-case letters and
lower-case letters
Multiple-level: Arabic numerals,·

Roman numerals and bullet symbols
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Define Document Sections

Using the Document Editor, you can partition your text
into separate sections, present the text in a section in
columnar format, and set different page orientations and
printing for each section. A multiple section document is
useful to:

Change the presentation and format of the text for·

different areas of information

Change between portrait and landscape orientation for·

different parts of the document

Vary the page margins from one page to another·

Access

Ribbon Document-Edit > Edit > Insert > Insert
Break > Section Break

Create a section

Select the 'Insert | Insert Break | Section Break' menu option.
This creates a new section on a new page.

The section break is represented by a dotted line; if this is
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not visible, click on the  icon in the 'Paragraph' panel of
the 'Document-Edit' ribbon.

The 'Section Break' menu option is not effective when 'Edit
Page Header/Footer' is active, because editing control passes
to the header and footer bands away from the body of the
document.

Set section properties

Section properties apply to all the document content
following the section break, up to the next section break
line.

Select the option 'Document-Edit > Edit > Edit > Edit
Section' to display the 'Section Parameters' dialog. Complete
each panel to set up the section as you require.

To Action

Set number
of columns in
a section

The 'Number of Columns' field defaults
to '1', to present the text as a normal page
of text (effectively a single column).
To structure the text in two or more
columns on a page:

In the 'Number of Columns' field, type·

the number of columns to divide the
text into across the page
In the 'Space Between the Columns'·

field, type the separation of the
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columns, in inches
If you want to separate the columns·

with a vertical line, select the 'Line
Between Columns' checkbox

When you close the dialog, the text is
displayed in the selected number of
columns of equal width, across the page.
The text wraps at the edge of the column
and, when it reaches the foot of the page,
continues at the top of the next column.

Start section
on new page

If you want to insert a page break before
the new section, select the 'Start Section
on New Page' checkbox.
If you also want to adjust the page
numbering so that the new section starts
at a specific page, select the 'Restart Page
Number at' checkbox and type the page
number.
The section start page will often be 1, but
this facility is also useful for inserting
another document of a constant number
of pages between, for example, an
introduction and a technical section.

Set text
direction

Set the direction of the text flow within
the section by selecting the appropriate
radio button.
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Set page
orientation

Set the page orientation within the section
by selecting the appropriate radio button.

Set paper size
for section

Select a standard paper size for the pages
of the section.
Alternatively, you can scroll down the list
and select the 'Custom Size' option, and
then define the page width and height, in
inches.
You can also define special page margins
by selecting the option 'Document-Edit >
File > File > Page Layout'.

Set paper
source

The 'Paper Source' selections both default
to 'Auto Select', so that the pages of the
section print from whatever paper trays
have paper available.
If you are printing on paper from a
specific tray, or are manually feeding
paper to the printer for this section, select
the appropriate option. You can select
different options for the first page of the
section and subsequent pages of the
section.

Delete a section break

(c) Sparx Systems 2021 Page 303 of 416



Document Reports 2 September, 2021

Move the cursor onto the labeled Section Break line and
press the Delete key.

When you delete a section break, the section properties of
the preceding section now apply to the document content
following the deleted line.
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Set Tabs

Using the Document Editor, you can define left, right,
center and decimal tab points to define the positions of text
strings and columns across the page. A paragraph or
highlighted block of text can have as many as twenty tab
points, which apply to every line of the selected text.

If you do not set tab points, the Tab key moves the cursor to
default tab points at 0.5-inch intervals.

Access

Ribbon Select 'Document-Edit > Paragraph', then
choose one of:

Set Tab·

Clear Tab·

Clear All Tabs,·

or click on the ruler at the top of the page.

Create and Clear Tab Points
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Operation Detail

Using the
ruler

If the ruler is not visible, select the option
'Document-Edit > File > View >
Horizontal Ruler'.
To create a:

Left tab, click on the required tab·

position on the ruler; the left tab is
indicated on the ruler by an 'L' shape
Right tab, right-click on the required·

tab position on the ruler; the right tab is
indicated on the ruler by a reversed 'L'
shape
Center tab, press Shift and click on the·

required tab position on the ruler; the
center tab is indicated on the ruler by
an inverted 'T' shape
Decimal tab, press Shift and right-click·

on the required tab position on the
ruler; the decimal tab stop is indicated
on the ruler by an inverted 'T' shape
with a dot on the right hand side
This tab is for numbers with a decimal
point; numbers scroll left from the tab
until you type the point, then numbers
scroll right.

To move a tab position, click on the tab
symbol on the ruler and drag it to the new
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position.

Using the Set
Tab menu
option

The 'Paragraph > Set Tab' menu option
displays the 'Set a Tab Position' dialog,
on which you select from a set of radio
buttons to specify the tab type.
The dialog provides two advantages over
the ruler; you can:

Set the tab position with more precision·

and with a clear value (in inches) that
you can duplicate
Select from a set of radio buttons to·

add or remove a dotted, broken or solid
line preceding the tab point

Click on the OK button to save the
settings.

Clearing a
single tab
point

Highlight the block of text and select the
'Paragraph | Clear Tab' menu option.
The 'Clear a Tab Position' dialog
displays.
Select the tab to clear and click on the
OK button.

Clearing all
tab points for
a text block

Select the block of text and select the
'Paragraph | Clear All Tabs' menu option.
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Notes

The option 'Document-Edit > File > Manage > Snap To·

Grid' affects the movement of the tabs (and the paragraph
indentation markers) on the ruler; when you select this
option, the movements of the tab markers are locked on to
an invisible grid at intervals of 1/16 inch (half a ruler
division)
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Manage Page Breaks

As you set up the document structure, you might want to
insert a page or column break to force a specific part of the
document content to start on a new page or column.

Access

Ribbon Document-Edit > Edit > Insert > Insert
Break > Page Break, or
Document-Edit > Edit > Insert > Insert
Break > Column Break

Keyboard
Shortcuts

Ctrl+Enter (page break)

Force a page break

Select the option 'Document-Edit > Edit > Insert > Insert
Break > Page Break', or press Ctrl+Enter.

The forced page break is indicated by a labeled solid line; if
this is not visible, click on the  icon, in the 'Paragraph'
panel of the 'Document-Edit' ribbon.
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Create a column break

Move the cursor to the appropriate point in the column text
and select the option 'Document-Edit > Edit > Insert > Insert
Break > Column Break'. The break is indicated by a labeled
'dot and dash' line.

Normally in a multiple column section, the text flows from
the end of one column to the top of the next column; a
column break forces the text to the next column before the
current column is completely filled.

Delete a break

A page break or column break is indicated by a labeled line.
To delete the break, move the cursor onto this line and press
the Delete key.
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Insert Headers, Footers, Footnotes and
Endnotes

When creating a document report or template, you can
include page headers, footers, endnotes and footnotes. You
switch options on to create and edit these items, and then
switch these options off again to protect the entries. While
you are creating headers and footers, you can also continue
to edit the body of the document. You can create headers
and footers:

To apply throughout the document·

Separately for each section that you might create in your·

document

Separately for the first page of the document and for the·

subsequent pages (for example, to leave no header and
footer text on the title page of the document)

Separately for left-hand and right-hand pages·

Header and footer options

To Action

Create the
page header
and footer

Select the option 'Document-Edit > Edit
> Edit > Page Header/Footer > Edit Page
Header/Footer'.
A dotted line marks off the header area at
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the top of the page and the footer area at
the bottom of the page. This dotted line is
at a position that is set using the 'Page
Setup' dialog ('Document-Edit > File >
File > Page Layout').
Within each of these two areas, a
paragraph marker displays to indicate
where the text will sit relative to the top
and bottom edges of the paper. This
position is also defined on the 'Page
Setup' dialog.
You can type in any kind of free-form or
formatted text and insert icons as you
prefer. You would normally work well
within the defined areas for the header
and footer, but if the text exceeds the
area, the dotted lines simply move to
accommodate the text.

Edit or delete
the page
header and
footer text

Select the option 'Document-Edit > Edit
> Edit > Page Header/Footer > Edit Page
Header/Footer', move the cursor to the
text and make any changes required. If
you need to, delete the text altogether.

Create
separate
header and
footer for the

Select the option 'Document-Edit > Edit
> Edit > Page Header/Footer > Edit Page
Header/Footer' to access the header and
footer text spaces.
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initial page of
the document

Select the option 'Document-Edit > Edit
> Edit > Page Header/Footer > First Page
Header/Footer' and either:

The 'Create First Page Header' option,·

or
The 'Create First Page Footer' option·

A paragraph marker displays at the top or
bottom of the first page of the document.
If you want specific text to display on the
first page of the document, type it in and
format it.
Alternatively, leave the spaces blank so
that the first page has no header or footer
text.

Display the
common
document
header and
footer on the
initial page

If you have created a separate initial page
header and/or footer and now want to
display the same header and footer text
on the initial page as is shown on
subsequent pages of the document, you
specifically delete the 'first page
header/footer' assignment.

Select the option 'Document-Edit > Edit
> Edit > Page Header/Footer > Edit Page
Header/Footer' to access the header and
footer text spaces.
Select the option 'Document-Edit > Edit
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> Edit > Page Header/Footer > First Page
Header/Footer' and either:

The 'Delete First Page Header' option·

or
The 'Delete First Page Footer' option·

The 'first page' assignment and text are
removed from the first page header
and/or footer spaces.

Create
separate
header and
footer for
left-hand
pages

Select the option 'Document-Edit > Edit
> Edit > Page Header/Footer > Edit Page
Header/Footer' to access the header and
footer text spaces.
Select the option 'Document-Edit > Edit
> Edit > Page Header/Footer > Left Page
Header/Footer' and either:

The 'Create Left Page Header' option,·

or
The 'Create Left Page Footer' option·

Scroll to the nearest left-hand page and in
the header or footer space type in any
kind of free-form or formatted text and
insert icons as you require.
This text displays on every left-hand page
in the section or, if there are no sections,
in the document.
Format your document to put left-hand
page information on pages with left-hand
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headers and footers. For example, in
English language documents,
even-numbered pages are usually
left-hand pages.

Create
separate
header and
footer for
right-hand
pages

Select the option 'Document-Edit > Edit
> Edit > Page Header/Footer > Edit Page
Header/Footer' to access the header and
footer text spaces.
Select the option 'Document-Edit > Edit
> Edit > Page Header/Footer > Right
Page Header/Footer' and either:

The 'Create Right Page Header' option,·

or
The 'Create Right Page Footer' option·

Scroll to the nearest right-hand page and
in the header or footer space type in any
kind of free-form or formatted text and
insert icons as you require.
This text displays on every right-hand
page in the section or, if there are no
sections, in the document.
Format your document to put right-hand
page information on pages with
right-hand headers and footers. For
example, in English language documents,
odd-numbered pages are usually
right-hand pages, and sections such as
Title, Introduction and Table of Contents
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start on right-hand pages.

Delete left or
right page
headers and
footers

Select the option 'Document-Edit > Edit
> Edit > Page Header/Footer > Edit Page
Header/Footer' to access the header and
footer text spaces.
Select the option 'Document-Edit > Edit
> Edit > Page Header/Footer > <side>
Page Header/Footer' (where <side> is
either Left of Right) and either:

The 'Delete <side> Page Header'·

option, or
The 'Delete <side> Page Footer' option·

You are prompted to confirm the
deletion; click on the Yes button.
Left and Right page headers or footers
balance each other. If you create one, the
system responds as if the other exists but
is blank. If you delete one, the system
responds as if the other is the 'common'
header/footer for the section, and all page
headers now contain that remaining text.

Close and
protect
headers and
footers

Select the option 'Document-Edit > Edit
> Edit > Page Header/Footer > Edit Page
Header/Footer' to access the header and
footer text spaces again, and check that
you cannot move the cursor into the
header and footer spaces.
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Footnote and Endnote options

To Action

Create a
footnote

Move the cursor to the position at which
to insert the footnote marker, and select
the option 'Document-Edit > Edit > Insert
> Footnote/Endnote > Footnote'.
The 'Footnote' dialog displays. In the:

'Footnote Marker' field type the marker·

you want to use, such as a number,
asterisk, hash or letter of the alphabet,
or any text string of up to 10 characters
'Footnote Text' field, type the text of·

the footnote
'Superscript Footnote Marker' field,·

leave the checkbox selected to display
the marker as a superscript, or clear the
checkbox to display the marker in the
same format as the preceding text

Click on the OK button; the editor
inserts the footnote marker at the current
cursor location and displays the marker
and text at the bottom of the page, above
the page footer space.
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Edit footnote
text

Select the option 'Document-Edit > Edit
> Edit > Edit Footnote/Endnote > Edit
Footnote text'.
The marker and text of each footnote
displays in the document text where the
marker was originally inserted,
highlighted by a broken underline.
Locate the text and make the required
changes. These changes are immediately
reflected in the footnote text at the bottom
of the page.
When you have finished editing footnote
text, click again on the option
'Document-Edit > Edit > Edit > Edit
Footnote/Endnote > Edit Footnote text';
the footnote text is no longer shown in
the document text.

Create an
endnote

Move the cursor to the position at which
to insert the endnote marker, and select
the option 'Document-Edit > Edit > Insert
> Footnote/Endnote > Endnote'.
The 'Endnote Parameters' dialog displays.
In the:

'Endnote Marker' field type the marker·

you want to use, such as a number or
letter of the alphabet, or any text string
of up to 10 characters
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'Endnote Text' field, type the text of the·

endnote
'Superscript Endnote Marker' field,·

leave the checkbox selected to display
the marker as a superscript, or clear the
checkbox to display the marker in the
same format as the preceding text

Click on the OK button; the editor
inserts the endnote marker at the current
cursor location and displays the marker
and text at the end of the section or, if
there are no sections, at the end of the
document.

Edit endnote
text

Select the option 'Document-Edit > Edit
> Edit > Edit Footnote/Endnote | Edit
Endnote text'.
The marker and text of each endnote
displays in the document text where the
marker was originally inserted,
highlighted by a broken underline.
Locate the text and make the required
changes; these changes are immediately
reflected in the endnotes at the end of the
section or document.
When you have finished editing endnote
text, click again on the option
'Document-Edit > Edit > Edit > Edit
Footnote/Endnote | Edit Endnote text'; the
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endnote text is no longer shown in the
document text.

Notes

You can create and edit headers and footers whether the·

option 'Document-Edit > File > View > Page Layout
Mode' is switched on or switched off; this option makes
no difference
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Insert Hyperlinks

Within a document, you can insert hyperlinks to display
material held outside the document, such as external
documents, Help topics or web pages.

Access

Ribbon Document-Edit > Edit > Insert >
Hyperlink

Insert hyperlinks

To insert a hyperlink, right-click on the point in the text at
which to create it and select the option 'Document-Edit >
Edit > Insert > Hyperlink'; the 'Insert Hyperlink' dialog
displays.

In the 'Link Text' field, type the text to be hyperlinked and,
in the 'Link Code' field, type or paste the:

Web page URL·

Help topic file name or·

External file path and name·

To capture the Help topic file name and path, right-click on
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the displayed topic and copy the file name and path from the
address field at the top of the screen.

Click on the OK button; the hyperlinked text displays in the
document. Edit the sentence to accommodate the link text.

To display the web page, Help page or external document:

Linked in a document, double-click on the link·

Linked in a report template, compile the report and click·

on the hyperlink in the report

In a Library document, you can also insert hyperlinks to
related objects in the model.

(c) Sparx Systems 2021 Page 322 of 416



Document Reports 2 September, 2021

Insert Images, Objects and Frames

In creating your document or template, you might want to
embed or display images and other objects in the text, to
insert external information and/or structure the text and
graphics on a page. You could insert, for example:

An image in the text or as background to the text·

A link to an image·

An Object Linking and Embedding (OLE) object, which·

you create and edit using an external application

A frame - a rectangular border within the text that can·

contain separate text and pictures, and that the existing
text flows around

A drawing object - a rectangle, text box or line that can sit·

over the existing text

Another document file·

Having inserted an object, you can subsequently move, edit
or delete it.

Insert items

To Action

Insert a
picture in the
document

You can insert a picture bitmap or
Windows metafile in your document as
either an embedded picture or a link to
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the external picture file.
Position the cursor at the point at which
to insert the picture, and select either:

'Document-Edit > Edit > Insert >·

Embed Picture' (F8) or
'Document-Edit > Edit > Insert > Link·

Picture'
A browser dialog displays, through which
you select the picture to insert in the
document; the picture is shown at the
current cursor location.
The embedded picture is saved within the
document; only the filename of the linked
picture is saved with the document,
which is a better option if you intend to
edit the picture over time.

Embed an
OLE object
in the text

Position the cursor at the point at which
to embed the object, and select the
'Document-Edit > Edit > Insert > OLE
Object' menu option.
The 'Insert Object' dialog displays, listing
the applications that are available to
create the object.
When you select an application, the
editor launches it and you create the
object; when you save the application, the
editor inserts an icon or view that
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represents the inserted object.
You can also use the option
'Document-Edit > Edit > Edit > Paste
Special' to import OLE objects, provided
that the object is available in the
clipboard.
You can later edit the object using the
application, by double-clicking on the
object or by selecting the option
'Document-Edit > Edit > Edit > Edit OLE
Object'.

Change the
size and
alignment of
an embedded
picture

Click on the picture and select the option
'Document-Edit > Edit > Edit > Edit
Picture'; the 'Edit Current Picture' dialog
displays, through which you can change
the height and width of the picture, in
inches.
You can also align the top, middle, or
bottom of the picture with the baseline of
any text on the same line as the picture,
or offset the bottom of the picture from
that baseline by any number of twips.

Insert a
background
or watermark
picture for
the document

Select the option 'Document-Edit > File >
Manage > Watermark Picture'; a browser
dialog displays, through which you select
the graphic file to insert as a watermark.
The picture occupies the entire text area,
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pages
(document
report
templates)

and is displayed as a washed-out image.
If you choose an image that is already
washed-out, no watermark is displayed at
all.
To remove the watermark image, deselect
the option 'Document-Edit > File >
Manage > Watermark Picture'.

Insert a
document
File

Position the cursor at the point at which
to insert the file, and select the option
'Document-Edit > Edit > Insert > Insert
RTF File'.

Embed a
frame at the
cursor
position

Select the option 'Document-Edit > Edit
> Insert > Frame'.
The border of the frame displays, with the
cursor at the top left corner. You can
change the size of the frame by clicking
on the border and dragging the small
black 'handles'.

Embed a
drawing
object at the
cursor
position

Select the option 'Document-Edit > Edit
> Insert > Drawing Object'.
The 'Select Drawing Object Type' dialog
displays, on which you select the radio
button for either a:

Text Box·

Rectangle or·
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Line·

Click on the OK button; the selected
object displays, overlaid on the existing
document content. If required, you can
change the size of the object by clicking
on the border and dragging the small
black 'handles'.
You can also change the appearance and
the relationship of the object to the
document text.

Move the
frame or
drawing
object

Click on the outline of the frame or
drawing object and then move the cursor
just outside the outline so that the cursor
changes to a plus-shape.
Drag the plus shape (and hence the
outline) to the new position.

Edit the
border,
background
and impact
on document
text of a
drawing
object

Select the drawing object by clicking on
its outline, then select the option
'Document-Edit > Edit > Edit > Edit
Frame/Drawing Object > Edit Drawing
Object'.
The 'Line and Fill attributes' dialog
displays.
Select the options to define:

Whether to display a border line and, if·

so, your preferred border thickness,
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type and color
Whether the object is transparent or·

filled and, if filled, the fill color
The wrapping behavior of the text·

outside the object:
     -  'Wrap Through' causes the
document text to flow through the
        diagram object so that they
overlap each other
     -  'No Wrap' causes the document
text to skip over the object,
        so that the text resumes below the
object
     -  'Wrap Around the Object' causes
the document text to flow
        around the object, into a column
on one side or the other of
        the object, or on both sides; if you
move the object across the
        page, the editor tends to leave a
wider margin before it starts
        to wrap text to the left of the
object
The Z Order of the object, so that if·

there is an overlap the object either lies
in front of the document text (Z-order =
1) or behind the document text (Z
Order = >1)
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Insert text
into the
frame, text
box or
rectangle

Click inside the outline and type the text
at the cursor position. The text wraps at
the right hand side of the box and, for a:

Frame, extends the bottom border of·

the box
Text box and rectangle, overflows the·

bottom of the box but is still associated
with the box and not with the 'normal'
text of the document; to enclose all
lines adjust the height manually to
enclose the text

If you change the width of the outline,
any text inside the outline is
automatically wrapped to adjust to the
new width.

Rotate text to
display it
vertically in
the frame or
text box

Select the option 'Document-Edit > Edit
> Edit > Edit Frame/Drawing Object >
Rotate Text'. The 'Text rotation' dialog
displays; select the radio button for the
text direction you want to apply:

'Horizontal' (default) - the text flows·

from the top left corner of the box
across the width of the box, wrapping
at the right border and scrolling
downwards
'Top to Bottom' - the characters are·

rotated through 90 degrees to flow
from the top right corner of the box
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downward, wrapping at the bottom
edge of the box and scrolling right to
left
'Bottom to Top' - the characters are·

rotated through 90 degrees to flow
from the bottom left corner of the box
upward, wrapping at the top edge of the
box and scrolling left to right

If the text is running horizontally, you
can type as much as you need - the box
height increases to accommodate the text.
If the text is running vertically, and it
flows outside the box, you adjust the box
height and width manually to
accommodate your text.
Click on the OK button to apply the
change.

Insert a
picture into a
frame or
drawing
object text
box

Click inside the outline and either insert
the picture as previously explained, or
copy and paste it at the cursor position.
If the frame or text box contains only the
picture, the picture size is automatically
adjusted to as nearly fill the outline as
possible without distorting the image.
If you change the width or height of the
box, the picture is adjusted to completely
fill the outline; you continue manually
adjusting the outline to reduce the
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distortion of the image.

Lock a frame
or drawing
object to a
point on the
page

You can fix the position of the outline to
a specific point so that as you enter and
format the text the outline maintains its
position relative to that point.
The default position is relative to the first
character of the paragraph, in which case
the outline moves on the page with any
change that affects the position of the
paragraph.
You can also fix the position relative to
either the:

Top edge of the page or·

Top margin of the page·

In these cases, if the document text on the
page is adjusted it flows past the outline.
Click on the outline and select the option
'Document-Edit > Edit > Edit > Edit
Frame/Drawing Object > Vertical Base
Position' menu option.
The 'Object Position' dialog displays.
Select the radio button for the locking
point you prefer:

'Top of the Page'·

'Top Margin'·

'Current Paragraph'·

Click on the OK button to apply the
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lock.

Delete a
frame or
drawing
object

Click on the outline and press the Delete
key.
The editor prompts you to confirm the
deletion; click on the Yes button.
This deletion is reversible - press Ctrl+Z
or select the option 'Document-Edit >
Edit > Edit > Undo'.
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Checking Text

In developing a document or template, you would probably
want to spell-check the text that you have entered; for
example, to make sure that 'boiler-plate' text is correct, as it
will be used many times in many reports. In the Document
Editor you can both spot-correct a word from a
context-sensitive list, or run a spell checker over the whole
document. You can also check the use of a word against an
online thesaurus, to see if there is a more precise term or to
check the opposite meaning of the word.

Access

Ribbon Document-Edit > Edit > Spell Check >
[options]

Check Spelling

To Action

Spot-correct
a word

Select the option 'Document-Edit > Edit
> Spell Check > Auto Spell Checking'.
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When the 'Auto Spell Checking' option is
on, the Document Editor automatically
checks the spelling of all typed or pasted
text in the document (but not field names
or generated text). Words that are
apparently spelt incorrectly are
underlined in red.
Right-click on an underlined word; a
short list displays, containing the correct
spelling of the assumed word and a
selection of other words that this word
might have been intended to be. Click on:

One of the words, to use it in place of·

the misspelt word
The 'Ignore All' option to use the word·

as it is in this context
The 'Add' option to add the word to the·

suggested list of spellings/other words
You might be using a language for which
there is no spelling dictionary installed,
or text that contains a high proportion of
new terms, in which case you might not
want to have the auto spell function
underlining all the text. You can turn it
off by selecting the 'Other | Auto Spell'
option again.

Run the spell
checker over

Select the option 'Document-Edit > Edit
> Spell Check > Spell Check'.
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the whole
document

The 'Check Spelling' dialog displays,
identifying the first apparent spelling
mistake in the document.
You might want to modify the things that
the Spell Checker identifies as errors;
click on the Options button to tailor the
operation of the checker.
Having tailored the spell checker,
respond to each of the possible errors that
it highlights in your document.
When you have acted on all the words
presented by the Spell Checker (or
clicked on the Cancel button) a status
message displays identifying the number
of words picked up and the number of
those words you have corrected. Click on
the OK button.

Run Thesaurus

To Action

Access the
Thesaurus

Select a word in the text, then select the
option 'Document-Edit > Edit > Spell
Check > Thesaurus'.
The 'Thesaurus' dialog displays, showing
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the:
Selected word·

Word-categories the word belongs to,·

in the 'Categories' panel
List of synonyms for the word within·

the first category (words that have the
same meaning as the selected word) in
the 'Synonyms' panel

If there are several categories, click on
each one to display the synonyms within
each category.

Display
antonyms

If you want to display the antonyms for
the word (the opposite meanings of the
word), select the Antonyms checkbox.
The Antonyms title displays in the
Categories panel, with the
word-categories for the opposite of the
selected word listed underneath.
Click on a category name to list the
antonyms in that category, in the
Synonyms panel.

Check for
homonyms

A homonym is a word that sounds similar
to another and can be confused with it.
For example, 'Sympathy' might be
confused with 'Empathy' or 'Symphony'.
If you want to check that you have not
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chosen a sound-alike word by mistake,
click on the Suggest button.
The 'Suggestions' dialog displays, listing
possible sound-alike words. If you want
to use one of those words, or check for
another with the same meaning, click on
the Look up button.
The 'Thesaurus' dialog refreshes with the
new word you have selected.

Search for
new terms

If you want to examine a totally different
word, in the 'Term' field type the new
word and click on the Look up button.
The display changes to show the
synonyms (and antonyms) of the new
word.

Change to a
synonym

Click on a synonym (or an antonym, if
required) in the list, and click on the OK
button.
The word in the text changes to the
selection.
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Track Changes

In a team environment, two or more people might work on
developing documents and/or templates. You might,
therefore, need to review each other's work, or just be able
to see what changes another person has made to the file. In
the Document editor, you can turn on change tracking to
highlight the changes you make to the text.

Access

Ribbon Document-Edit > Edit > Tracking >
[options]

Tracking options

To Action

Turn tracking
on

Select the option 'Document-Edit > Edit
> Tracking > Enable Tracking'.
Any changes made after Tracking is
turned on are immediately highlighted:

Inserted text - printed in a different·
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color
Deleted text - struck through with a·

single colored line
Formatting changes - indicated by a·

colored dotted underline
A change bar is also inserted in the page
or column margin to indicate the line on
the page on which the change was made.
If you mouse over a highlighted change, a
tool-tip displays the type of change, the
name of the person who made the change,
and the date and time the change was
made.

Turn tracking
off

Select the option 'Document-Edit > Edit
> Tracking > Enable Tracking' again.
Any changes made after Tracking was
turned on remain highlighted, but
changes made after tracking was turned
off are not highlighted.

Hide changes If you want to review the document as it
is, without the highlighted changes, but
you do not want to lose the changes or
highlighting, select the option
'Document-Edit > Edit > Tracking > Hide
Changes'.
The highlighted additions and deletions
are hidden, and the remaining text closes
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up. Format changes are not hidden.
To expose the hidden changes, click on
the option 'Document-Edit > Edit >
Tracking > Hide Changes' again.

Locate
changes

Select the option 'Document-Edit > Edit
> Tracking > Find Next Change' or
'Document-Edit > Edit > Tracking > Find
Previous Change' to search the text and
place the cursor on the next or previous
change made, respectively.

Respond to
change

If you want to assess each change and act
on your decision, select the option:

'Document-Edit > Edit > Tracking >·

Accept Change' to confirm the change,
or
'Document-Edit > Edit > Tracking >·

Reject Change' to reverse the change to
the original text or format

In either case, the change tracking
markings are removed. You can make
further changes if necessary.

Accept all
changes

If you are not assessing each change, for
example if you just want to see what a
colleague has done before making your
own changes, you can accept all changes
across the document in one action.
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Select the option 'Document-Edit > Edit
> Tracking > Accept All Changes'.

Reject all
changes

If you are not assessing each change, but
just want to reverse all changes across the
document in one action, select the option
'Document-Edit > Edit > Tracking >
Reject All Changes'.
A prompt displays for you to confirm the
action; click on the Yes button.
You might do this if, for example, you or
a colleague have edited the wrong version
of a document or acted on a technical
change that was itself reversed.

(c) Sparx Systems 2021 Page 341 of 416



Document Reports 2 September, 2021

Protect Document Contents

When you have created a document, or some important text
within a document, you might want to protect it from being
edited or deleted so that it is safe from accidental change.
The Document Editor defaults to locking against
protection, so you first turn off the lock and then protect
either the whole document or a selected block of text. Once
protection is set, neither you nor any other user can change
the text without specifically removing the protection.

Access

Ribbon Document-Edit > File > Manage > Text
Selection Lock
Document-Edit > Font > Font > Protect
Document-Edit > File > Manage >
Protect Document

Protect text

To Action
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Enable text
protection

By default, the Text Selection Lock is
enabled.
Select the option 'Document-Edit > File >
Manage > Text Selection Lock' to disable
this option.
You can now set protection on your text.
To re-enable the protection lock and
prevent protection of further text, select
the option 'Document-Edit > File >
Manage > Text Selection Lock' again.
The text that you have already protected,
however, remains protected and cannot
be edited until you or another user
specifically removes the protection. You
cannot remove protection from this text
until you turn off the protection lock
again.

Protect text Highlight the line, block or section of text
to be protected, and select the option
'Document-Edit > Font > Font > Protect'.
The selected text is displayed in a gray
font, and cannot be edited.
If the menu option is unavailable, or the
text is not faded, it means that you have
not removed the protection lock.
To release the text for editing again,
highlight it and reselect the option
'Document-Edit > Font > Font > Protect'.
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You can select and release a portion of
the protected text; the remainder stays
protected.

Protect a document

Within the document or template, select the option
'Document-Edit > File > Manage > Protect Document'.

The entire document is protected.

An exception is protecting a template in the Document
Template Designer. As you select checkboxes in the
'Sections' panel, section markers are still added to the
'Content' panel. You cannot, however, add fields or text
between the markers.

To release the document for editing again, reselect the
option 'Document-Edit > File > Manage > Protect
Document'.
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Virtual Documents

Both standard and custom report templates generate
documents that present information reflecting the
organization of the Browser window. You can also
generate document and web reports independent of that
organization, grouping and ordering individual Packages
and elements according to whatever criteria you want to
apply. For this purpose, you use virtual documents.

You can create separate virtual documents describing, say,
the Requirements, Use Cases or Design elements of a
project, based on individual Model Document elements.
Alternatively, you can make these separate sections of one
report, retaining their own different formats but with
common headers and footers, organized under a Report
Package element. Any Table of Contents, Stylesheet and/or
Cover Page you select would be applied to the combined
document and could apply your corporate standards across
all the Model Document sections. You can create as many
virtual documents as you want, for as many combinations of
information as you need.

Elements, Templates and Content
Definitions

Construct Detail
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Document
Elements

Report Package and Model Document
elements are available from the
'Documentation' page of the Diagram
Toolbox; on the Toolbox, click on  to
display the 'Find Toolbox Item' dialog
and specify 'Report Package' or 'Model
Document'.

When you drag the Report Package and
Model Document elements onto a
diagram, these symbols display,
respectively:

The 'Documentation' Toolbox page also
provides the:

Document Artifact icon, to create an·

element into which you can generate a
virtual document or through which you
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can add a Linked Document to an
element
Chart template icons, to present the·

values of selected properties of
elements in a number of graphical
formats
Report and Matrix Specification·

elements, which capture report and
matrix profiles to help you regenerate
custom reports and matrixes
consistently
A Master Document icon that has been·

replaced by the Report Package and is
therefore deprecated; you can still use
the Master Document instead of the
Report Package, but you do not need to
provide a value for its RTFTemplate
Tagged Value

Templates For each Model Document element, you
can use a standard document template
(such as Model Report) or you can create
a custom template; for example, a
specifically-designed Requirements
template for a Requirements document,
or a Use Case template for a section on
Use Cases.
For web reports, you identify the template
on the 'Publish as HTML' dialog; for
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document reports, you specify the
template name as the value of the
RTFTemplate Tagged Value.

Content The content of the report is defined as
either:

A list of Packages (defined as·

attributes) dragged onto the Model
Document element in whatever order
or combination is most appropriate to
your requirements; you can easily add
or delete Packages as necessary
or
(Not for web reports) a standard search·

(identified by Tagged Values) created
within the Model Search facility -
when you generate the document, this
search captures the required data
throughout the model and populates the
document; note that diagram searches
are not supported

You can control the sequence in which
information is presented in the document
by, for example, changing the sequence
of Packages in the Model Document or
the sequence of Model Documents in the
Report Package.
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Notes

In a Model Document for a document report, you should·

not define both a list of Packages and a search; if both are
present, when you generate the document it is created
from the Package list only

You cannot use Bookmarking in Report Package·

elements, which effectively replace Bookmarking in
Word
Bookmarking requires each bookmark to be unique; when
you generate a report with a standard template (including
in a single Model Document element), each bookmark is
unique and there is a 1:1 association between the
Elements-details being generated and the elements in the
repository
As Report Packages are intended to contain multiple
sub-documents, the association ceases to be 1:1; there is
no simple method that enables the generated data to be
uniquely identified directly in association with the
original element
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Create Report Packages

If you want to create a series of documents - or sections of a
document - that are individually tailored but are generated
and organized as a single unit, you can design each
document in its own Model Document element but organize
these elements under a Report Package. This is a Package
element with a child Common diagram to which you add the
Model Document elements. You can then generate a
document with common contents and the headers and
footers, and each section having its own appearance defined
by a template appropriate to the section content. When you
add Model Document elements to a Report Package, the
Report Package element resembles this:

The Report Package element and child diagram are listed in
the Browser window as shown:

Create a Report Package
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Ste
p

Action

1 Open or create a diagram in which to create the
Report Package. The diagram can be of any type,
although 'Documentation' automatically provides the
correct Toolbox page.

2 If the Toolbox 'Documentation' page is not already
shown, click on  to display the 'Find Toolbox Item'
dialog and specify 'Documentation'.

3 Drag the 'Report Package' icon onto the diagram.
The system prompts you for the name of the Report
Package element.

4 Type the element name and click on the OK button.
The system creates the Report Package element and
a child Custom diagram of the same name.

5 If creating a Report Package for an HTML report, go
to step 6.
Otherwise, open the 'Tags' tab of the Properties
window (the 'Start > Desktop > Design > Properties'
ribbon option) and click on the Report Package
element. A number of Tagged Values are available,
the first set of which you can use to define the
Report Constants for the document cover page
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details:
ReportAlias·

ReportAuthor·

ReportClipboard·

ReportDateLong·

ReportDateShort·

ReportFilename·

ReportFilenameShort·

ReportKeywords·

ReportName·

ReportSource·

ReportStatus·

ReportSummary·

ReportTitle·

ReportVersion·

6 Return to the Browser window and open the Report
Package child diagram. At this point, you can
provide the content for the generated document, by
creating Model Document elements on the child
diagram

7 Having set up the Report Package, and created or
added and set up its Model Documents as required,
you can generate the document report on the Report
Package Document; this pulls in the contents of the
Model Documents.
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Create Model Document

If you want to create a single document that captures details
from specific but separate areas of your model, you can
define that document using a Model Document element.
You can also create a number of individual documents and
combine them as sections of a larger document, defining the
larger document in a Report Package element. You can
create as many Model Document elements as are necessary
to provide the independent documents or the sections of the
document you require.

You can also set up a Model Document element to collate a
number of separate Packages to be included in an XML file
for export to another model. See the Generate Model
Document XML Help topic.

Prerequisites

Before you create a Model Document element, you might
have to:

Create the appropriate document or web page template to·

define the structure and appearance of the document

For a document, determine whether to provide the content·

of the document using selected Packages or a Model
Search and - if necessary - create the Model Search to use
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Create a Model Document element

Ste
p

Action

1 Either:
Open the child Custom diagram of the Report·

Package element you have created or
If you are creating separate Model Documents,·

create a new Documentation diagram ('All
Perspectives | Extended | ModelDocument' in the
'New Diagram' dialog)

The new diagram can live anywhere in the model
hierarchy, outside the Packages you are adding to the
document; you could create a diagram called
'Documentation' within a specific Documentation
Package, and use this to hold the independent Model
Document elements for your virtual documents.
You can also create Model Documents on any other
convenient type of diagram, changing the Toolbox
page to 'Documentation' (step 2).

2 From the 'Documentation' page of the Toolbox (click
on  to display the 'Find Toolbox Item' dialog and
specify 'Documentation') drag the 'Model Document'
icon onto the diagram to create a new Model
Document element.
Give the element an appropriate name; for example,
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if the documentation is relevant to the shopping cart
requirements of a model, you could call it
ShoppingCartReqDocumentation.
Click on the OK button.

3 If you are creating a Model Document element for a
web report, go now to the Add Packages to Model
Document topic.
Otherwise, open the 'Tags' tab of the Properties
window (the 'Start > Desktop > Design > Properties'
ribbon option) and click on the Model Document
element.
A number of Tagged Values are available, the first
set of which you can use to define the Report
Constants for the cover page details, if this Model
Document element defines a stand-alone document:

ReportAlias·

ReportAuthor·

ReportClipboard·

ReportDateLong·

ReportDateShort·

ReportFilename·

ReportFilenameShort·

ReportKeywords·

ReportName·

ReportSource·

ReportStatus·
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ReportSummary·

ReportTitle·

ReportVersion·

In the remaining Tagged Values you define the
template and, if appropriate, Model Search to use to
generate the document:

RTFTemplate·

SearchName·

SearchValue·

4 The value of the RTFTemplate Tagged Value
defaults to 'Model Report' as the template to use for
this Model Document. If you want to use a different
template, click on the drop-down arrow at the right
of the value field and select the required template.

5 If you are creating a list of Packages for the Model
Document, go now to the Add Packages to Model
Document topic.
Otherwise, click on the drop-down arrow to the
right of the SearchName Tagged Value, and click on
the model search type to populate this Model
Document.
In a Model Document for a document report, do not
define both a list of Packages and a search; if both
are present, when you generate the document it is
created from the Package list only.
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6 If necessary for your Model Search, type a search
term in the SearchValue Tagged Value.

7 Create further Model Document elements as
required.
Your Model Document element appears in the
Browser window with a Class icon, as shown:

When you have created all the required Model
Document elements, go to the Document Order
topic.

Notes

Diagram Searches are not supported·

Custom SQL searches are supported if they are returning·

elements; the SQL must include ea_guid AS
CLASSGUID (case sensitive) and the object type
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Add Packages to Model Document

After you create a Model Document element, one of the two
options available to you is to identify the Packages to
document in the reports generated from the element. You
can add as many Packages as you need, from anywhere in
the model.

Add Packages to Model Document element

Ste
p

Action

1 Open the Documentation diagram, and locate a
Package in the Browser window to add to the
documentation; for example, a Resources Package in
a Dynamic view.

2 Drag and drop the Package from the Browser
window onto the Model Document element, as
shown:

3 Adding the Package creates an attribute with the
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same name as the Package; the attribute can be seen
in the Model Document element in the Attributes
compartment:

Repeat step 2 for each of the Packages you want to
include in the document.

4 You could now generate your report as a document
or as a web page, but you might prefer to first review
how your Package list impacts the order in which
information is presented in the report.
You can change the sequence of Packages, or delete
any Packages that are no longer required.
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Delete Package in Model Document

In your use of Model Document elements to generate
documents on specific Packages, you might determine that a
Package you have identified to be documented is no longer
necessary. You can omit the Package from your
documentation by deleting the corresponding attribute from
the Model Document element.

Delete Package from Model Document
element

Ste
p

Action

1 In the Browser window, expand the Model
Document element to list the Package attributes.

2 Right-click on the attribute for the Package to omit,
and select the 'Delete Attribute' option.
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Alternatively

Ste
p

Action

1 In either the Browser window or the diagram,
right-click on the Model Document element and
select the 'Features > Attributes' option.
The Features window displays at the 'Attributes'
page.

2 On the Attributes list, click on the attribute for the
Package to omit.

3 Click on the Delete button to remove the attribute
from the document element.
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Document Order

The order in which information is compiled into a virtual
document depends on:

The sequence of Model Document elements in a Report·

Package element

Whether you define a Model Search in a Model·

Document element (not for web reports)

Whether you define a Package list in a Model Document·

element, and how you order that list

You can review and, if necessary, amend the order in which
information is to be compiled, before you generate the
document or web page.

Document Sequences

Aspect Detail

Model
Document
Sequence

When you generate a document from a
Report Package element, the sequence in
which the sections are created is
determined by the order in which the
child Model Document elements are
listed in the Browser window.
You can create elements anywhere in a
diagram, therefore for sequencing
information the document generator
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refers to the Browser window.
If necessary, change the sequence using
the Up Arrow button and Down Arrow
button in the Browser window header
bar to move a Model Document element
up or down within the Package.

Model
Search

A Model Search presents the
information in the order specified by the
query. For example:
SELECT t_object.Name FROM t_object
ORDER BY Name;

Package
Order

When you create a Package list in a
Model Document element, the sequence
of information is determined by the order
in which the Package attributes are listed
within the element.
You can change the sequence using the
'Attributes' page of the Features window
and, if you prefer a Package to be in a
different section of the document (another
Model Document element), you can
move the attribute from one Model
Document element to another.
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Change sequence of Packages in a Model
Document element

Ste
p

Action

1 In the Browser window or diagram, either
right-click on the Model Document element and
select the 'Features | Attributes' option, or click on
the element and press Ctrl+5.
The Features window displays at the 'Attributes'
page.

2 In the Attributes list, right-click on the attribute to
move and select 'Move Up' or 'Move Down' to
change the order in which the corresponding
Packages are included in the documentation.

3 Click on the Close button.

Move a Package attribute from one Model
Document to another

Ste Action
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p

1 In the Browser window, expand both Model
Document elements so that they list their Package
attributes.

2 Click-and-hold on the attribute to move, and drag it
onto the name of the target Model Document
element.

3 Release the mouse button.
The attribute is removed from the source element
and added to the top of the list of attributes in the
target element.

4 If necessary, move the attribute down the attribute
list, as described in the Change sequence of
Packages in a Model Document element section.
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Generate the Document

When you have created one or more Model Document
elements and, if necessary, a Report Package element, and
you have set the document order and established any section
numbering you want to apply, you can generate printable
documentation from these elements.

You can also use a Model Document element containing a
number of separate Packages to generate an XML file for
export to another model. See the Generate Model Document
XML Help topic.

Access

Select a Report Package or a Model Document element
either in the Browser window or on a diagram, and display
the Generate Documentation dialog in one of these ways:

Ribbon Publish > Model Reports > Report
Builder > Generate Documentation

Keyboard
Shortcuts

F8

Context
Menu

In a diagram, right-click on the Model
Document element | Documentation |
Generate Documentation
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In the Browser window :  |
Documentation | Generate
Documentation (RTF/PDF/DOCX)

Generate virtual documentation

Ste
p

Action

1 On the 'Generate Documentation' dialog, set the
generating options for your document as required.

2 Click on the Generate button to create the
documentation.
The Report Generator works through the defined
content of the Report Package element and/or the
Model Document elements and pulls in the
information from either the listed Packages or the
executed searches, formatted according to the
templates identified in the RTFTemplate Tagged
Value for each Model Document element.

3 If you have not selected the 'View Document on
Completion' checkbox, click on the View button to
view the documentation.
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Generate Report to an Artifact
Element

When working with virtual documents, it is also possible to
directly generate a report as a Linked Document associated
with a Document Artifact element. Because the generated
report is stored directly in the model, rather than in the
current user's file system, it is much easier to share the
report in a team-based modeling environment. The Linked
Document also eliminates the separation of the modeled
system and the generated document output, keeping
everything integrated and readily accessible.

To generate a report to a Document Artifact's Linked
Document, you start with either:

A Report Package element with Model Document·

elements, or

An independent Model Document element·

The Report Package will contain defined Model Documents
and the Model Documents will identify templates and
Packages or Model Searches. At this point you can quickly
and easily create a Document Artifact element on which to
generate the report.

Create a Document Artifact element

Ste Action
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p

1 On the Documentation diagram, click on the Report
Package element or the independent Model
Document element.

2 Drag and release the Quick Linker arrow to the right
of the Report Package or Model Document element,
and select the 'Common | Document' menu option to
create a (Trace) connector and the Artifact element.
Optionally, you can name the element as well.

Generate a report to a Document Artifact
element

Ste
p

Action

1 Right-click on the Document Artifact and select the
option 'Create Document to Artifact'.
The 'Generate Documentation' dialog displays.

2 The text field values are automatically set.
Select any checkboxes required (such as 'View
Document on Completion'), and click on the
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Generate button.

3 When the report generation is complete, the report
displays as a Linked Document of the Document
Artifact element (if not, click on the View button on
the 'Generate Documentation' dialog).

Note

If you have a Report Package with Model Document·

elements, you can easily create a Document Artifact to
test one of the Model Documents individually; in this
case, you need to remove the Document Artifact before
creating a report from the Report Package again,
otherwise the Artifact becomes part of the report instead
of being a vehicle for the report
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The Legacy RTF Report Generator

Creating a Rich Text Format (RTF) document is a simple
and flexible process. An RTF document is based on an
element or (more usually) a Package in your project. To
produce a document, you select the Package or element to
report on in the Browser window, Package Browser,
Diagram List or Model Search, then press F8 to display
the 'Generate Documentation' dialog. On the 'Options' tab,
click on the Switch Generator button to access the legacy
'Rich Text Format Report' dialog.

The 'Rich Text Format Report' dialog enables you to set the
exact contents and look and feel of your report. You enter
the file name of the report, a heading, additional notes,
template name (for saving the set-up) and other options.
You can also select the style of the report; either plain or
formal.

Optionally, you can set up a filter, the details to include,
element types to exclude, whether to process child
Packages, whether to show diagrams and the diagram
format.

You can switch back to the 'Generate Documentation' dialog
by clicking on the Switch RTF Generator button.

Notes

The Legacy Generator is available if you have RTF·
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templates created in releases of Enterprise Architect prior
to 4.1, and you prefer to generate RTF reports using the
original generator; however, as you can generate reports
from these templates using the post-Enterprise Architect
4.1 RTF Generator, the Legacy Generator and instructions
for its use are no longer updated

Reports produced using the Legacy RTF Generator do·

reflect the Notes formatting feature in any text associated
with elements

The 'Rich Text Format Report' dialog panels are·

individually described in the subsequent topics of this
section (as listed); the dialog has a lot of options - you can
use them selectively to produce output at the level of
detail suited to your project
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Document a Single Element

RTF documentation can also be generated for a single
element.

Access

Select the element for which to generate documentation,
then open the 'Generate Documentation' dialog using one of
the methods outlined here.

Ribbon Publish > Model Reports > Report
Builder > Generate Documentation >
Options : Switch generator

Keyboard
Shortcuts

F8 | Options | Switch Generator
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Set the Main RTF Properties

The main section of the 'Rich Text Format Report' dialog
enables you to set the output location and appearance of the
final RTF document.

Set Output Location and Appearance

Ste
p

Action

1 Open the 'Rich Text Format Report' dialog.

2 Supply an Output Filename to save the report into;
always include the extension .rtf as part of the
filename.

3 In the 'Template Name' field, provide the name of
the template to generate the report from.

4 Select a report Style: Formal or Basic.

5 Type a Heading for your report; this appears as the
first heading item in your output.

6 Select your required Heading Style and Initial
Heading Level Indent from the drop-down lists.
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Notes

It is recommended that you enter a full path name for your·

report; the images in your report are saved externally in an
images directory, and supplying the full directory path
avoids confusion over the location of these images

If you move your report you must also move the images·

directory
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Apply a Filter

On the 'Rich Text Format Report' dialog you can apply a
filter  to include or exclude elements by date modified,
phase or status. This helps to track changes and break a
document into multiple delivery phases.

Open the 'Rich Text Format Report' dialog.

To enable the date filter, select the checkbox in the 'Date'·

field

In the first two 'Only include objects' fields, click on the·

drop-down arrows and select the appropriate criteria
(Modified/Created, Before/After)

The Package phase filter applies at the Package level (not·

the element level) and ignores the phase of the root
Package that you are documenting; to enable the phase
filter, in the 'Where Package Phase' field click on the
drop-down arrow and select an operator
Enterprise Architect filters out all Packages that do not
meet the selection criteria; all elements in the Package are
ignored, regardless of their individual phase

The element status filter enables you to limit the output by·

element status; unlike the Package phase filter, this filter
applies to every element
You can filter against a status of like or unlike a criterion,
such as 'like proposed', or against the 'in' and 'not in'
operators, such as 'in approved', 'not in validated'; when
using the 'in' and 'not in' operators, enter a
comma-separated list of status types as your criteria
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expression

(c) Sparx Systems 2021 Page 379 of 416



Document Reports 2 September, 2021

Exclude Elements

Using the 'Rich Text Format Report' dialog, you can exclude
elements of any type from your final output; this is useful
when you want to highlight particular items and not
overburden a report with too much detail.

To do this:

Open the 'Rich Text Format Report' dialog.1.

Click on each element to exclude, or click on the All2.
button to exclude all elements.

Click on the None button to clear your selections.3.
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RTF Diagram Format

It is possible to output diagrams to Bitmap files, GIF files or
Windows Metafiles.

To do this:

Open the 'Rich Text Format Report' dialog.1.

In the 'Diagram format' panel (bottom center of the2.
dialog) select the required format for the report.

Generally the two metafile options ('EMF' and 'WMF')3.
are recommended; however, there are times that the others
might be suitable.
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Include model items in report

The 'Model Include' panel of the 'Rich Text Format Report'
dialog has these options:

'Glossary' to include the Project Glossary·

'Tasks' to include project tasks·

'Issues' to include project issues·

Select the appropriate checkbox to include the items in the
generated RTF documentation.
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RTF Report Options

Additional RTF report options you can select from the
'Options' panel on the 'Rich Text Format Report' dialog are
shown here.

You can select whether or not to recursively document
Packages, show diagrams or add a page break before each
new Package. Select the:

'Process all Children' checkbox to recursively process all·

child Packages within the main Package

'Show Diagrams' checkbox to include diagrams in your·

document; clear this item for no diagrams

'New page per package' checkbox to force a page break on·

each new Package (excepting empty Packages)

'Document all elements' checkbox to include all elements·

included in the project

'Document Packages' checkbox to document the Package·

as an element in addition to the documentation that would
normally be produced for Package documentation

'Hide 'note-less' elements' checkbox to exclude all·

elements without notes from the documentation

'Embed Diagrams in Document' checkbox to ensure that·

the diagram images are contained within the RTF
document rather than stored in a linked external file

'Skip root package' checkbox to exclude the parent·

Package from the documentation and include only the
child Packages
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'Document Linked Elements' checkbox to include the·

object details for linked elements that do not originate
from the selected Package

'Use Heading styles for Details' checkbox to ensure that·

the details are formatted as heading styles rather than
formatted text; this option is only available when the
'Heading Style' field in the 'Main' section of the 'Rich Text
Format Report' dialog is set to 'Max 9 levels - elements
are Package + 1'
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Select Document Sections

Using the 'For each Object Include' section of the 'Rich Text
Format Report' dialog you can select the documentation
sections to include in your report.

What you include or exclude governs how simple or
detailed your report is. You can create multiple reports at
different levels of detail for different audiences. Experiment
with these options to see what effect inclusion or exclusion
has. Most items are self-explanatory.

Selecting the checkbox against a category item in the list
selects all of the options that are contained in the category.
To expand a category, click on the + symbol next to the
category name. To exercise greater control over a category
of options expand the top level item and then select the
required individual items from the list.

Sometimes an item applies only to a certain type of element;
for example, 'Attributes' only applies to Class elements and
a few other element types. The 'Child Diagrams' option
shows or hides any diagrams that are attached under a model
element; for example, a Use Case might have a Scenario
diagram attached.

Notes

Use this feature to produce the right level of detail for·

your audience; technical readers might want to see
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everything, whilst management might require only the
general outline
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Custom Language Settings

If you export RTF-format documents from Enterprise
Architect in languages other than English, you can
customize the codepage, default language ID and character
set that Enterprise Architect uses when generating RTF.
This makes it much easier to generate documentation
appropriate to your country or locale.

You can also set up a list of word substitutions. For
instance, where Enterprise Architect would include the word
'Figure', you can specify another word to replace it that is
either in your language or more meaningful to your readers.

Set up Substitutions

Ste
p

Action

1 Open the 'Rich Text Format Report' dialog.

2 In the 'Language' panel (bottom left of dialog) click
on the Adjust button.
The 'Customize RTF Language' dialog displays.

3 Double-click on an item to set or clear its Substitute
word.
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4 When you have finished, click on the OK button.

Set Up Language, Codepage and Character
Set

Ste
p

Action

1 From the drop-down lists in the 'Language',
'Codepage' and 'Charset' fields, select the language,
codepage and character set that most closely match
your location.

2 If required, modify the Substitute Tags by
double-clicking on each and manually setting the
value (for advanced use only).

3 To clear the substitution list, double-click on each
item in turn and delete the substitute value.

4 When you have completed the settings, click on the
OK button to save them.
Now when you generate RTF documents, the
substitute tags are used in the output.
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Notes

If you want to generate reports in a language that requires·

Unicode support, please note that Enterprise Architect
.eap files default to using JET 3.5 as the database engine,
which does not support Unicode character sets (see the
Startup topic); to provide Unicode support in your project,
either upsize to a DBMS repository, or set JET 4.0 as the
database engine and download a copy of the Jet 4.0
EABase model from the Sparx Systems website, then do
an EAP to EAP transfer of your model into the Jet 4.0 file

You can transport these language and tag definitions·

between models, using the 'Configure > Model > Transfer
> Export Reference Data' and 'Import Reference Data'
ribbon options
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Generate the Report

Once you have set up the document properties as required,
click on the Generate button to generate the report.

When you have generated the document, click on the View
button to open the report in MS WordTM.
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Legacy Report Style Templates

Using the 'Legacy RTF Style Editor' you can edit the RTF
associated with various sections of the RTF Report facility
in Enterprise Architect. You would typically use this
functionality to customize a report's look and feel for your
company or client.

If you have previously defined and saved a template, click
on the Load button on the 'Rich Text Format Report' dialog
to open the list of defined templates. Select one in order to
load it as the current template; all the features saved become
the current features. This enables you to define a set of
standard report types that streamline document production.

Access

Ribbon

Create or Edit RTF Style Templates

Ste
p

Action
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1

2 To edit an existing Legacy template, expand the
Legacy Templates tree and double-click on the
template name, or right-click and select the 'Modify
Document Template' option. The 'RTF Style Editor'
displays.

3 Alternatively, to create a new Legacy template,
right-click on 'Legacy Templates' and select the
'Create RTF Style Template (Legacy)' option.
A prompt displays for the new template name.

4 Type the name of the new template and click on the
OK button.
The RTF Style Editor displays.

RTF Style Editor

The RTF Style Editor contains a list of all available RTF
fragments for modification and customization.

Each fragment typically contains RTF plus one or more
special tag names that Enterprise Architect replaces with
information during generation. Currently you cannot alter
the content within the tag names, but you can omit a
complete tag by removing it, or alter its basic display
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properties in the surrounding RTF.

Special tag names are delimited by # characters; for
example, #NOTES#

Click on the:

Get Default button to retrieve the default Enterprise·

Architect template for the currently-selected template item
in the left hand list

Save button to save the version of the template for this·

style only

Delete button to remove your modified version of the·

template, which causes Enterprise Architect to use the
default template during report generation

To select a template during report generation, click on the
'Style' drop-down arrow on the 'Rich Text Format Report'
dialog. Once a style is selected, Enterprise Architect applies
that to the current report. Select <Basic> for the inbuilt
style.

Notes

The RTF Style Editor discussed here automatically·

displays when you modify or create a Legacy RTF
template; if you select a template created in the more
recent Document Template Editor, that editor opens
automatically instead

You can transport these RTF templates between models,·

using the 'Configure > Model > Transfer > Export
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Reference Data' and 'Import Reference Data' ribbon
options

To delete a template, right-click on it and select the·

'Delete Document Template' option

You can also alter the custom language settings·
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Save as Document

The Document feature enables a particular documentation
configuration to be 'remembered', linking the loaded
template within the 'Report' dialog to the current highlighted
Package. If a particular template is always used with a
specific Package, and multiple cases of documentation exist
to be propagated, saving these as Documents can ease
document generation later.

Create and use Documents

Ste
p

Action

1 Open the 'Rich Text Format Report' dialog.

2 Click on the Save as Document button.
The 'Save current as document definition' dialog
displays.

3 In the 'Enter Value' field, type a name for the
document and click on the OK button. The
document is added to the 'Resources' tab of the
Browser window for easy future access.

4 To generate documentation from the 'Resources' tab
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of the Browser window, right-click on the required
document.
The context menu displays.

5 Select the required context menu option.
Open Document - Opens the corresponding·

document file, as specified by the template
'Filename' property
Generate Document - Opens the 'Report' dialog,·

loaded with the specified template
Auto Generate Document - Generates·

documentation, with the document located at the
path specified by the template's 'Filename'
property
Delete Document - Removes the specified·

document
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Use Microsoft Word

When generating reports with the 'legacy' Report Generator,
you can use Microsoft WordTM to easily incorporate
additional features in the reports. You can:

Create a custom master document combining separate·

reports, to add a common table of contents, table of
figures, headers and footers

Create documents with sustainable links to generated·

'pieces' of Enterprise Architect output, pre-divided using
bookmarks, and updated automatically when the
document is opened

Open a report in Word·

Change linked images to embedded images·

Notes

With the more recent, 'enhanced' Document Report·

Generator, many of the facilities provided by Word have
been incorporated into the Generator or otherwise
rendered unnecessary; it is therefore likely that you would
have no need to use Word in generating your reports - you
can use Virtual Documents, for example, instead of
Word master documents and Bookmarks

These topics on the use of Word are therefore included·

only to support users who are still working with the
'Legacy' Report Generator, or who are using Word for
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personal preference

When you develop a report using Word with Enterprise·

Architect, leave definition of the section styles in the
Editor to the final stages just prior to report generation;
Word truncates the section bookmarks, as it uses a smaller
field length for sections

In Word, you can review and edit reports generated by·

Enterprise Architect, but you cannot import them back
into Enterprise Architect without damaging the section
style definition
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Open a Report in Microsoft Word

If you want to use Microsoft WordTM to open a document
file generated in Enterprise Architect, simply load Word and
open the file as a normal document. Word converts the file
for display.

If Word is your default handler of document files, you can
also load up and view the report by either:

Double-clicking on the output file, or·

Clicking on the View button on the 'Generate·

Documentation' dialog
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Change Linked Images to Embedded

One of the options available when generating document
reports is to embed images in the document, instead of
incorporating links to the image files. You would embed
images if you want the document to be portable (separated
from the directory containing the image files), but use links
to the image files if you want to update the images without
regenerating the document. You would be more likely to
link to image files when developing the model and
documentation, and more likely to embed images when the
document was ready for review or use.

If you have generated the document report with linked
images and imported the document into WordTM, and you
want to distribute that document, you can convert the file
links to embedded images without having to go back to
Enterprise Architect to regenerate the document with
embedded images.

Break image links in Word

Ste
p

Action

1 Open the required document in Word.

2 Select the 'Edit | Links' menu option.
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3 Highlight all links in the Links list.

4 Select the 'Save Picture in Document' checkbox.

5 Click on the Break Link button.

6 When prompted, click on the Yes button to break
the links.
Word breaks the links and saves copies of the
images inside the document.
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Document Bookmarks

If you want to create a complex document that consists of
sections of one or more document reports, rather than one
complete report, you can create a master document in
Microsoft WordTM and within it create links to the report
sections using their bookmarks. Bookmarks are
GUID-based numbers that are automatically created for
Packages, diagrams and elements, and placed in a document
when it is generated. Every object is bookmarked in the
document according to these rules:

All alphabetic and numeric characters remain the same·

All other characters (including spaces) are converted to·

underscores

For example UC01: Use Case Model becomes
UC01__Use_Case_Model. A Package bookmark applies
from the beginning of a Package to the end, and includes all
child Packages and elements underneath. You can also
manually assign bookmarks if you want to have references
to additional subdivisions of a model or document. If you
change your model and regenerate your document report,
you can simply refresh the links in the master document in
Word to automatically update the Word document.

When you use bookmarks to add sections of a generated
report to a Word master document, you work with Word and
the Enterprise Architect Browser window open at the same
time.
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Add a Bookmarked Section of an RTF
Document to a Word Document

Ste
p

Action

1 Within the Word file, position the cursor at the point
at which to insert the section of the document.

2 Select the Word 'Insert | File' menu option.
The 'Insert File' dialog displays.

3 Browse for and select the document file to insert,
then click on the Range button.

4 In the Enterprise Architect Browser window,
right-click on the Package, diagram or element to
include in the documentation.
The context menu displays.

5 To paste the object's bookmark into the clipboard,
select the menu option:

Copy/Paste | Copy Documentation Bookmark·

6 In Word, in the 'Range' cell of the 'Insert File' dialog,
press Ctrl+V to paste the information from the
clipboard.
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7 Click on the OK button.

8 Click on the drop-down arrow next to the Insert
button. A short menu displays containing two
options:

Insert - embeds a permanent copy of the text·

Insert as Link - creates a link that can be updated·

if you alter the source document
Select the 'Insert as Link' option.

9 Repeat steps 1 to 8 for each section of each
document you want to include in the Word
document.

10 Select the 'Word Tools | Options' menu option and,
on the 'Options' dialog, select the 'General' tab and
select the 'Update automatic links at Open'
checkbox.
Whenever the Word document is opened, the links to
the document sections will be automatically updated
with any changes made to the generated documents.

Notes

You cannot use Bookmarking in Report Package·
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elements, which effectively replace Bookmarking in
Word
Bookmarking requires each bookmark to be unique; when
you generate a report with a standard template (including
in a single Model Document element), each bookmark is
unique and there is a 1:1 association between the element
details being generated and the elements in the repository
As Report Packages are intended to contain multiple
sub-documents, the association ceases to be 1:1; there is
no simple method that enables the generated data to be
uniquely identified directly in association with the
original element
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Features of Word

When you have generated reports in the Enterprise Architect
'legacy' report generator, you can open them in Microsoft
WordTM to enhance the output of your project
documentation. Some of the things you might do include:

Add a table of contents·

Add a table of figures·

Add headers and footers·

Manipulate the report tables·

Set an option to refresh linked files automatically·
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Add Table of Contents

Among the features of Microsoft WordTM that can be
incorporated into generated Enterprise Architect document
reports is a Table of Contents, which can be used to aid
navigation of the documentation and enhance readability.
The Table of Contents provides hyperlinks to the diagrams
in the electronic version of the documentation, and page
numbers in both the printed and electronic versions of the
documentation.

Include Table of Contents in document

Ste
p

Action

1 In Word, open the report to which to add a Table of
Contents.

2 Select the 'Insert | Reference | Index and Tables'
menu option.

3 Click on the 'Table of Contents' tab to set the options
that are available for setting up the Table of
Contents.
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Notes

The format of the Table of Contents is dependant on the·

heading levels created when the document is generated; to
set the heading styles in the document, see the RTF
Report Options topic
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Add Table of Figures

Among the features of Microsoft WordTM that can be
incorporated into generated Enterprise Architect reports is a
Table of Figures, which can be used to aid navigation of the
documentation and enhance readability. The Table of
Figures provides hyperlinks to the diagrams in the electronic
version of the documentation, and page numbers in both the
printed and electronic versions of the documentation.

Include Table of Figures in document

Ste
p

Action

1 In Word, open the report to which to add a table of
figures.

2 Select the 'Insert | Reference | Index and Tables'
menu option.

3 Click on the 'Table of Figures' tab to set the options
that are available for setting up the table of figures.
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Add Headers and Footers

Among the features of Microsoft WordTM that can be
incorporated into generated Enterprise Architect document
reports are headers and footers.

Include headers and footers in the document
report

Ste
p

Action

1 In Word, open the report to which to add headers
and footers.

2 Select the 'View | Header and Footer' menu option,
and enter the appropriate information into the header
section and the footer section of the document.
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Manipulate Tables in Word

In the document reports generated from the Legacy report
generator in Enterprise Architect, tables are included when
items such as attributes and methods are selected in the 'For
each Object' section of the 'Rich Text Format Report' dialog.
Microsoft WordTM offers several levels of customization for
tables and can be used to enhance formatting the tables in
situations where the margins of the table exceed the
dimensions of the page size selected for printing in Word.

Manually resize the table

When the amount of detail for a documented item, such as
an attribute or operation, exceeds the margins of the page in
Word, you can manually resize the table in order to view all
of the details.

Ste
p

Action

1 Select the table that exceeds the margin size.

2 Mouse over the border of the table until the mouse
pointer changes into the 'drag' icon, as shown.
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3 Drag the cursor to the left to reduce the width of the
table, and then select the 'Document-Edit > File >
File > Print Preview' menu option to confirm that the
table borders are within the page margins.

4 Resize all of the tables that overhang the margins of
the page, using steps 1 to 3.

Apply styles to tables

One of the customizable properties of Word when working
with tables is the ability to apply a style to a table, so that
you can rapidly change the appearance of the table.

Ste
p

Action

1 In Word, open the report in which to change the
table styles.
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2 Locate and select the table for which to adjust the
appearance.

3 Select the 'Table | Table Auto Format' menu option.
The 'Table Autoformat' dialog displays.
From here you can specify a predefined table style
from the Table styles list, or create a new style by
clicking on the New button. The table styles defined
in the 'Table Autoformat' dialog only apply to one
table at a time so you must apply the style to each
table individually.
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Refresh Links

If you link into reports generated in Enterprise Architect,
you can set an option in the Microsoft WordTM master
document so that each time the document is opened, the
links are refreshed and - if the reports have changed - the
linked text is automatically updated.

Access

MS Word Tools | Options > General

Refresh linked report text

Ste
p

Action

1 Select the 'Update automatic links at Open'
checkbox.

2 Click on the OK button.
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