Recent Posts

Pages: [1] 2 3 ... 10
1
I figured it out. You have to do the following:

  • Add a ValueType to your Block Definition Diagram with the name Hours in this case.
    Create a Part in the block for ESS and name it "mean time to repair"
    Stereotype the part with <<mop>> (the standard SysML 1.5 stereotypes have <<moe>> by default)
    The "values" compartment should now show up in the diagram
2
Reinstalling EA doesn't change anything.
There is clearly something missing on my new Win11 config which prevents EA from opening some of the eapx files.

I'd like to find the right data pack to fix this as it's annoying.
My workaround for the time being:
- Create a new eapx on my PC
- Copy this new eapx and the original one (that cannot be opened) to a different PC (or local WM)
- Use the file to file project transfer to duplicate all data to the new eapx
- Use the new eapx





3
General Board / How do you show the "values" compartment in a SysML block?
« Last post by mse on Today at 08:04:16 pm »
I'm trying to basically recreate the ESS block in the book "A Practical Guide to SysML", figure 17.19. I wanted to know how you can create the compartment "values" in the block. So far I can get the owned behaviors, operations, and ports to show, but that compartment called "values" which has some <<mop>> stereotype entries is what I cannot find. I thought about adding value types to the diagram, but that does not help, nor do I know if that is how you create a <<mop>> entry.

How do I add value entries to a block and more importantly get them to show up in the compartments?
4
Bugs and Issues / Re: Windows 11 Jet Engine 4 issue: not a valid password
« Last post by qwerty on Today at 07:41:20 pm »
Creating a new eap is only a file copy from EA's program folder. No wonder this works. May you re-install EA?

q.
5
Bugs and Issues / Windows 11 Jet Engine 4 issue: not a valid password
« Last post by Guillaume on Today at 07:18:03 pm »
Hi,

I'm switching to a new PC with Windows 11 and EA 15.2. It's got office 365 desktop application, incl. Access for Ms 365 MSO.
I simply tried to open an existing EAPx file and I'm getting an error message: An Error has occurred: not a valid password.
If I open EA Example project (eapx), I'm alos getting an error.
I found a similar thread here: https://sparxsystems.com/forums/smf/index.php?topic=43971.0

I tried to unset and set the JET 4.0 in EA preferences, but it doesn't sort the issue. I also tried to open it with EA16.1 32 bits but I'm getting the same error.
I can create a new eapx file which works ok.

Note that my previous computer had Windows 11 and it worked fine.
I found msjet40.dll in C:\Windows\SysWOW64
I tried to install Access 2007 Runtime but that didn't sort the problem.

What can I do to fix this ?


6
Whilst a solution has been found for Javascript, there isn't any for JScript  + EA 16 64 bits. Is it unlilkely there will be any solution in the future (feasbility issue) ?

Options are:
- Use EA 16.1 32 bits: whilst using 64 bits is a default recommendation, I'm not convinced yet there will be any major impact for users in installing the 32 bits version
- Migrate the code to Javascript and use the custom solution: this can be time consuming if there is quite a lot of code to make compatible with Javascript

Notes:
- there doesn't seem to be any impact for VBScript projects with EA 16 64 bits
- Session.input is unfortunately limited as it doesn't support a custom text to be displayed e.g. provide the name of the diagram to process: A, B, C...
7
Hi,

I have an ArchiMate MDG with custom stereotypes. An Application Component stereotype has tagged values under groups and I can't get the required order for thse tagged values.
For tagged values that are not refGuid or refGuidList, I manage the order with the attributes within the stereotype class.
For refGuids, an association is created from the stereotype class to the linked classes. I created a new refGuid tagged value and I can't find any solution not to have it listed as the last tagged value within the group.
I tried moving in and out of the group, deleting an old tagged value, create in a different order, change the _tagGroupings, etc.

The only solution at the moment is to manually change the MDG XML file but this is obviously not ideal.

8
Bugs and Issues / Re: Call Behaviors not working
« Last post by EAButNotForGames on April 15, 2024, 07:30:43 pm »
Update:
Invoke Behavior of a Class is not functioning, but Invoke Behavior of an Activity is.
So if you want to use an operation in an activity diagram, the operation must be under the activity.
9
Details:
I've redefined ArchiMate_Capability with my own stereotype, using _HideUMLLinks. Then I added a stereotyped relation with stereotype ArchiMate3::ArchiMate_Composition.
This works just fine when linking two existing ArchiMate_Capability elements using either the quicklinker or the toolbox.
When using the quicklinker to create a new ArchiMate_Capability however I'm getting a ArchiMate3::ArchiMate_Capability, and not a MyProfile::ArchiMate_Capability.
If I have redefined the stereotype ArchiMate3::ArchiMate_Capability, and my MDG is the active one, I expect every new ArchiMate Capability to be a MyProfile::ArchiMate_Capability, not only the ones I create using the toolbox.

Steps to Reproduce:
- Redefine ArchiMate3::ArchiMate_Capability with MyProfile::ArchiMate_Capability
- Add stereotyped relation to self with stereotype ArchiMate3::ArchiMate_Composition
- set the MDG with MyProfile as active technology
- Create a ArchiMate_Capability (resulting in MyProfile::ArchiMate_Capability)
- Use the quicklink to create a new ArchiMate_Capability via the Composes relation
- Notice that EA creates a standard ArchiMate3::ArchiMate_Capability, and complains about the relation to be invalid

Reported

Geert
10
Automation Interface, Add-Ins and Tools / Re: Find options in Regestr Editor
« Last post by marc.zeller on April 14, 2024, 06:57:22 am »
Thank you very much! Works.

Regards,
Marc
Pages: [1] 2 3 ... 10