Author Topic: PCS v5 recommended PHP version?  (Read 3124 times)

skiwi

  • EA Expert
  • ****
  • Posts: 2065
  • Karma: +46/-82
    • View Profile
PCS v5 recommended PHP version?
« on: May 03, 2022, 01:52:01 pm »
What is the recommended PHP version for PCS v5?
Orthogonality rules
Using EA16.1 (1627) on Windows 11 Enterprise/64 bit. Repositories in SQLServer2019 DB Schema 1558.
WebEA on Pro Cloud Server 4.2.64

wivel

  • EA User
  • **
  • Posts: 241
  • Karma: +12/-1
  • Driven by Models
    • View Profile
Re: PCS v5 recommended PHP version?
« Reply #1 on: May 04, 2022, 07:23:55 am »
Hi

Think I remember a release note for one of the latest versions of PCS 4.x mentioning fixes relating to PHP 8.x, so I assume PHP 8.x will work for PCS 5.x. The user manual still refers to PHP 7.2.2, though.

Henrik

wivel

  • EA User
  • **
  • Posts: 241
  • Karma: +12/-1
  • Driven by Models
    • View Profile
Re: PCS v5 recommended PHP version?
« Reply #2 on: May 04, 2022, 11:00:41 pm »
Hi

Think I remember a release note for one of the latest versions of PCS 4.x mentioning fixes relating to PHP 8.x, so I assume PHP 8.x will work for PCS 5.x. The user manual still refers to PHP 7.2.2, though.

Henrik
From the PCS 4.2 build 65 release notes:
WebEA
  • Now supports PHP 8's removal of curly braces array syntax
  • Now supports PHP 8's behavior change that caused a 'Deprecated: Required parameter' error during login

Henrik