Author Topic: XML transformation generates a missing protocol prefix exception  (Read 204 times)

Kamal Hammoutene

  • EA User
  • **
  • Posts: 42
  • Karma: +0/-0
    • View Profile
Hello

I have the following exception when I try a basic XML/XSLT transformation (EA 16.0.5 trial version). I have attached the package XMI.
I have (almost) followed the procedure described in https://sparxsystems.com/enterprise_architect_user_guide/14.0/model_domains/model_an_xsl_transformation.html but created the XML file and XSLT file objects directly in EA.

Adding that, even though I enter the XSLT code via the EA GUI in the XSLT file object stored document, when I try to export that file object, the exported file is empty.

Thank you for your help.

[384102621]      Stack recording threshold set to 3 frames
[384102828]      Debug XSL Transformation
[384102828]      Using XSL stylesheet: C:\Users\ADMINI~1\AppData\Local\Temp\EADocs\BF70A65D-5B48-4de5-9436-8B0FEDE92C89\Xslt1.xsl
[384102828]      with XML input: C:\Users\ADMINI~1\AppData\Local\Temp\EADocs\25C226D7-203F-4082-87E0-D142819ABAE4\XmlFile1.xml
[384102829]      Default Directory is C:\Program Files\Sparx Systems\EA Trial
[384102829]      Agent dll found: C:\Program Files\Sparx Systems\EA Trial\vea\x86\SSXMLAgent32.DLL
[384102829]      Default Directory is C:\Program Files\Sparx Systems\EA Trial
[384102829]      Debug Session Started
[384102829]      Agent: Started
[384102935]      arseException: missing protocol prefix,
[384102957]      Debug Session Ended
[384102957]      Shutting down

I didn't find a way to attach the XMI file to this message so I could send it if needed.
« Last Edit: July 20, 2022, 12:26:40 am by Kamal Hammoutene »