Author Topic: Evaluating EA 16: UML 2.x XMI export incredibly slow  (Read 290 times)

Richard Freggi

  • EA User
  • **
  • Posts: 409
  • Karma: +15/-7
    • View Profile
Evaluating EA 16: UML 2.x XMI export incredibly slow
« on: August 02, 2022, 01:49:25 am »
I downloaded eval copy of EA 16, imported some models from my old EA 13 via UML 2.1 XMI, no problem.
Now I'm exporting them back from EA16 to UML 2.1 XMI and it's incredibly slow, minutes per object and I have 10K objects in the model

Before I submit a bug report I'd like to check if others are seeing the same thing?
PS I know there's native XMI now, just wanted to know if UML 2.x is a bug or what

Paolo F Cantoni

  • EA Guru
  • *****
  • Posts: 8227
  • Karma: +233/-129
  • Inconsistently correct systems DON'T EXIST!
    • View Profile
Re: Evaluating EA 16: UML 2.x XMI export incredibly slow
« Reply #1 on: August 02, 2022, 08:16:33 am »
Hi Richard,
I believe Sparx used to steer people away from UML 2.1 transport between EA instances.  Even today, UML 1.x is preferred for XML transport.  UML 2.1, I suspect, is principally there for import from external applications.

I only use UML 1.x.  Increasingly I'm using the Native formats for inter-EA transport (which I understand you can't use in this case).

HTH,
Paolo
Inconsistently correct systems DON'T EXIST!
... Therefore, aim for consistency; in the expectation of achieving correctness....
-Semantica-
Helsinki Principle Rules!

Richard Freggi

  • EA User
  • **
  • Posts: 409
  • Karma: +15/-7
    • View Profile
Re: Evaluating EA 16: UML 2.x XMI export incredibly slow
« Reply #2 on: August 02, 2022, 01:00:09 pm »
Confirmed!  XMI 1.1 export works fine.  So it is a bug on 2.1 but 1.1 is fine for me.  Thanks Paolo!!!