Author Topic: Bug: Stereotype supression doesn't  (Read 1280 times)

sargasso

  • EA Practitioner
  • ***
  • Posts: 1406
  • Karma: +1/-2
  • 10 COMFROM 30; 20 HALT; 30 ONSUB(50,90,10)
    • View Profile
Bug: Stereotype supression doesn't
« on: October 25, 2006, 04:11:18 am »
( Having a great time today)


Diagram option - "Show element stereotypes" when turned off, doesn't suppress «device» stereotypes

In a deployment diagram, when I turn off this option, the node element stereotypes dissappear but the device elements still show «device».

Repro:

Having coloured all the passive nodes (devices) in a luverly  shade of light grey and all the active nodes in various obnoxious hues of my choice, I thought I could make the picky a bit more readable by turning off the stereotype display.  NUP!

Why doesn't this flag hide all stereotypes???


Dare I say it!   C - C - C


bruce


p.s.  The model is a 5-tier deployment with full redundancy across all info paths.  There are 176 nodes and devices in the entire solution and I am going cross eyed trying to find the missing connectivities.

p.p.s. Paolo - how do you get guillements into your posts??
« Last Edit: October 25, 2006, 04:42:23 am by sargasso »
"It is not so expressed, but what of that?
'Twere good you do so much for charity."

Oh I forgot, we aren't doing him are we.

«Midnight»

  • EA Guru
  • *****
  • Posts: 5651
  • Karma: +0/-0
  • That nice Mister Grey
    • View Profile
Re: Bug: Stereotype supression doesn't
« Reply #1 on: October 25, 2006, 04:28:42 am »
Don't know how to navigate you out of your current dilemma Bruce, but I can help with the character insertion.

Since browsers act pretty strangely when you try to use the Alt+<keypad> combinations, you can either:
  • Use the Character Map applet. In recent times it has migrated to System Tools under the Accessories group.
  • Turn Num Lock on (I very rarely do this, so I really have to remind myself) and enter these as Unicode characters. « is Alt+0171 (the 0 is important) and » is Alt+0187.

HTH, David
No, you can't have it!

sargasso

  • EA Practitioner
  • ***
  • Posts: 1406
  • Karma: +1/-2
  • 10 COMFROM 30; 20 HALT; 30 ONSUB(50,90,10)
    • View Profile
Re: Bug: Stereotype supression doesn't
« Reply #2 on: October 25, 2006, 04:45:19 am »
 :-[ :-[ :-[ :-[ :-[ :-[ :-[ :-[ :-[
(Just like I showed two people how to put Euro and Yen symbols into a Word document 4 days ago)
:-[ :-[ :-[ :-[ :-[ :-[ :-[ :-[ :-[

thanks David


bruce
« Last Edit: October 25, 2006, 04:46:23 am by sargasso »
"It is not so expressed, but what of that?
'Twere good you do so much for charity."

Oh I forgot, we aren't doing him are we.

Simon M

  • EA Administrator
  • EA Guru
  • *****
  • Posts: 6445
  • Karma: +55/-6
    • View Profile
Re: Bug: Stereotype supression doesn't
« Reply #3 on: October 25, 2006, 03:04:46 pm »
My guess is that it's because «device» is not actually a stereotype but a keyword.

Still, I agree that they should be hidden too.
Simon

support@sparxsystems.com