Author Topic: Cloud Services Error retrieving results: WAIT_TIMEOUT  (Read 9157 times)


  • EA Novice
  • *
  • Posts: 16
  • Karma: +0/-0
    • View Profile
Cloud Services Error retrieving results: WAIT_TIMEOUT
« on: February 08, 2020, 10:00:19 am »
Hi All,

I get the below errors when I try to do an Import via .xml to an existing model or if I try to Import Storage from RAS. It is the same error for both.
I am using pro cloud express to host the models on a server. We are using AWS RDS and EC2 instances.

For a transfer via RAS it is hung up on -

Importing package: [MyStorageName]
Adding Elements to Diagram: [ADiagramInMyStorage]

with the below error

Sparx Systems Cloud Services [2009]
Error retrieving results: WAIT_TIMEOUT

For the .xml transfer it is hung up on -

Adding connectors to diagram

with the same error

Sparx Systems Cloud Services [2009]
Error retrieving results: WAIT_TIMEOUT

Roman Liebsch

  • EA Novice
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: Cloud Services Error retrieving results: WAIT_TIMEOUT
« Reply #1 on: July 16, 2020, 06:49:19 pm »
It is an old issues which I have also requested to Sparx. Just want to leave my experience here.
My Background is similar and reproducible for XMI and RAS.

If I want to exchange bigger data among different repositories than I use first an XMI export with Version 1.1(in EA15 I also tried "Native") or RAS register - that is working so far.
But the import is crashing or hanging via XMI or RAS when using larger files and often when there are a lot of references not solvable as I use a sub package of a larger context.
So I will have an inconsistent project afterwards.
I often get an WAIT_TIMEOUT from the Cloud Service, based on a OBDC Warning of a found Deadlock.
Either EA will hang (and GUI will soften in the background) at the import stage "Resolving Link" or "Fix Up external References" for example, the adding stage is often not critical. At the end EA hangs and does not consume any memory anymore if I look to the Task manager.

Big imports using ODBC on the server itself only work with the ODBC and even there the cloud connection fails. So the LAN/WAN in between shouldn't be an issue.

However if I use the EA1354 the deadlock warning still appears from time to time but EA13 will keep on importing and fixing all references right without an Out of Memory error. But I don't want to use EA13 anymore.

Even playing around with different versions of MySql and the ODBC Connectors won't solve the issue. I believe that there is kind of time out or buggy failure reaction in the cloud service on a lot of missing references that are not found in the repos.

Sparx answered:
When you were importing the XML file(s) and receiving the deadlock error, did the folder containing the information being imported already exist in the repository?  The only time we were able to duplicate that error is when EA had to delete the previous information before doing the import, this occurs for all XMI 1.1 imports.  We will need to investigate the cause of these deadlocks.