Author Topic: v16 - Problem with accessing .eapx from 32-bit version  (Read 190 times)

Paolo F Cantoni

  • EA Guru
  • *****
  • Posts: 8228
  • Karma: +233/-129
  • Inconsistently correct systems DON'T EXIST!
    • View Profile
v16 - Problem with accessing .eapx from 32-bit version
« on: July 27, 2022, 12:00:00 pm »

On our machine, we have both 32-bit and 64-bit EA installed.  When we try to access any .eapx repository with the 32-bit version, we get the following message when we try to open a diagram.
DAO.Database [0x00000d0e]
Invalid Memo, OLE, or Hyperlink Object in subquery 't_object.PDATA2'.

The diagram opens "Empty" - no diagram objects are visible.  Everything else seems to work OK.  As far as we can tell, there is NOTHING wrong with thet_object.PDATA2 column.  Since v16 64-bit didn't support MS Access, we didn't try.  However, in the last few days, Sparxian Eve mentioned using the  64-bit version of the Microsoft Access Database Engine 2010 Redistributable in another thread.  So we installed it and tried to access the same file.  Success!  No problem!

Does anyone else see anything like this?  It's pretty weird!

TIA,
Paolo

BTW: We can't install the 32-bit version of the Redistributable because we have 64-bit office products.

[Edit: Forgot to say that "Alles ist in Ordnung" with v15.2]
« Last Edit: July 27, 2022, 03:41:15 pm by Paolo F Cantoni »
Inconsistently correct systems DON'T EXIST!
... Therefore, aim for consistency; in the expectation of achieving correctness....
-Semantica-
Helsinki Principle Rules!